summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/hplib/hplib-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/hplib/hplib-test_git.bb')
-rw-r--r--recipes-bsp/hplib/hplib-test_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/hplib/hplib-test_git.bb b/recipes-bsp/hplib/hplib-test_git.bb
new file mode 100644
index 00000000..574fa2a7
--- /dev/null
+++ b/recipes-bsp/hplib/hplib-test_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "TI High performance library test binaries"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/runtime/hplib/src/COPYING.txt;md5=b7982a377c680ad71ca2fbb735982462"
4
5DEPENDS = "common-csl-ip qmss-lld sa-lld pktlib hplib"
6
7include hplib.inc
8
9CHOICELIST = "yes no"
10
11S = "${WORKDIR}/git/ti/runtime/hplib"
12
13EXTRA_OEMAKE += '-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}'
14
15do_compile () {
16 for device in ${DEVICELIST}
17 do
18 for choice in ${CHOICELIST}
19 do
20 oe_runmake tests HPLIB_SRC_DIR=${S} USEDYNAMIC_LIB=$choice DEVICE="$device"
21 done
22 done
23}
24
25do_install () {
26 for device in ${DEVICELIST}
27 do
28 oe_runmake installbin INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
29 done
30}