summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
index 2686810d..987055b0 100644
--- a/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
+++ b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
@@ -3,22 +3,16 @@ SUMMARY = "Diagnostic tool for TI K3 processors"
3LICENSE = "BSD-3-Clause" 3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d" 4LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d"
5 5
6inherit cmake
7
6PV = "0.2+git${SRCPV}" 8PV = "0.2+git${SRCPV}"
7 9
8COMPATIBLE_MACHINE = "k3" 10COMPATIBLE_MACHINE = "k3"
9 11
10BRANCH ?= "master" 12BRANCH ?= "master"
11SRCREV = "81581afb405085755aea7744c1d196533e8094c4" 13SRCREV = "859e1cc105a01a8a4a58318679f92e2135a03a99"
12 14
13SRC_URI = "git://git.ti.com/git/k3conf/k3conf.git;protocol=https;branch=${BRANCH}" 15SRC_URI = "git://git.ti.com/git/k3conf/k3conf.git;protocol=https;branch=${BRANCH}"
14 16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18
17do_compile () {
18 oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install ${S}/k3conf ${D}${bindir}
24}