summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-08-30 13:20:54 -0500
committerRyan Eatmon <reatmon@ti.com>2023-08-30 15:29:44 -0500
commit411f2d4b21a4a01d62efc320b64e6fa25c6aa6f3 (patch)
tree039849d891b2339ea01c6d6020879378829af6a1
parent43676653a9cfbef483c2b66904ec352369e2a021 (diff)
downloadmeta-ti-cicd.master.202309010100.tar.gz
k3conf: Update SRCREV and move to cmakecicd.master.202309010100
The SRCREV change corresponds to a commit that changes from make to cmake for building k3conf, so we need to update the recipe as well. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb12
1 files changed, 3 insertions, 9 deletions
diff --git a/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
index 2686810d..987055b0 100644
--- a/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
+++ b/meta-ti-bsp/recipes-devtools/k3conf/k3conf_git.bb
@@ -3,22 +3,16 @@ SUMMARY = "Diagnostic tool for TI K3 processors"
3LICENSE = "BSD-3-Clause" 3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d" 4LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=7154c0ffcd418064ffa528e34e70ca9d"
5 5
6inherit cmake
7
6PV = "0.2+git${SRCPV}" 8PV = "0.2+git${SRCPV}"
7 9
8COMPATIBLE_MACHINE = "k3" 10COMPATIBLE_MACHINE = "k3"
9 11
10BRANCH ?= "master" 12BRANCH ?= "master"
11SRCREV = "81581afb405085755aea7744c1d196533e8094c4" 13SRCREV = "859e1cc105a01a8a4a58318679f92e2135a03a99"
12 14
13SRC_URI = "git://git.ti.com/git/k3conf/k3conf.git;protocol=https;branch=${BRANCH}" 15SRC_URI = "git://git.ti.com/git/k3conf/k3conf.git;protocol=https;branch=${BRANCH}"
14 16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18
17do_compile () {
18 oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install ${S}/k3conf ${D}${bindir}
24}