summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-11-04 01:47:26 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-11-04 09:59:48 -0500
commitf01c8007f58d268bd0dd2a6b2c8b140b8c11913e (patch)
tree62d7ebf1f973082662d229028dd1584337af1536 /recipes-bsp
parentc252c773147b650727819a3a6e60be0111ad6e0f (diff)
downloadmeta-ti-f01c8007f58d268bd0dd2a6b2c8b140b8c11913e.tar.gz
qmss-lld: Only build binaries relevent to the machine
* Due to this change, the init script is no longer needed Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rwxr-xr-xrecipes-bsp/qmss-lld/files/init_qmss.sh47
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld-test_git.bb3
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld.inc7
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld_git.bb23
4 files changed, 16 insertions, 64 deletions
diff --git a/recipes-bsp/qmss-lld/files/init_qmss.sh b/recipes-bsp/qmss-lld/files/init_qmss.sh
deleted file mode 100755
index af695318..00000000
--- a/recipes-bsp/qmss-lld/files/init_qmss.sh
+++ /dev/null
@@ -1,47 +0,0 @@
1#*
2#* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/
3#*
4#*
5#* Redistribution and use in source and binary forms, with or without
6#* modification, are permitted provided that the following conditions
7#* are met:
8#*
9#* Redistributions of source code must retain the above copyright
10#* notice, this list of conditions and the following disclaimer.
11#*
12#* Redistributions in binary form must reproduce the above copyright
13#* notice, this list of conditions and the following disclaimer in the
14#* documentation and/or other materials provided with the
15#* distribution.
16#*
17#* Neither the name of Texas Instruments Incorporated nor the names of
18#* its contributors may be used to endorse or promote products derived
19#* from this software without specific prior written permission.
20#*
21
22#! /bin/sh
23compatible=$(cat /proc/device-tree/compatible)
24
25cd /usr/lib
26case "$compatible" in
27 *k2hk*)
28 device=k2hk
29 ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1
30 ;;
31 *k2l*)
32 device=k2l
33 ln -sf libqmss_k2l.so.1.0.0 libqmss_device.so.1
34 ;;
35 *k2e*)
36 device=k2e
37 ln -sf libqmss_k2e.so.1.0.0 libqmss_device.so.1
38 ;;
39 *)
40 device=unknown
41 ;;
42esac
43
44if [ $device != unknown ]; then
45 ln -sf libqmss_device.so.1 libqmss_device.so
46 echo qmss library link established for device : $device
47fi
diff --git a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb
index 7c19364f..60a35b12 100644
--- a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb
+++ b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb
@@ -1,11 +1,10 @@
1DESCRIPTION = "TI QMSS low level driver unit test and example binaries" 1DESCRIPTION = "TI QMSS low level driver unit test and example binaries"
2COMPATIBLE_MACHINE = "keystone"
3 2
4DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld" 3DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld"
5 4
6include qmss-lld.inc 5include qmss-lld.inc
7 6
8PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
9 8
10CHOICELIST = "yes no" 9CHOICELIST = "yes no"
11 10
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc
index efd681e4..1cf9b0b2 100644
--- a/recipes-bsp/qmss-lld/qmss-lld.inc
+++ b/recipes-bsp/qmss-lld/qmss-lld.inc
@@ -1,6 +1,9 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" 2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d"
3 3
4COMPATIBLE_MACHINE = "keystone"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
4QMSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git" 7QMSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git"
5QMSS_LLD_GIT_PROTOCOL = "git" 8QMSS_LLD_GIT_PROTOCOL = "git"
6QMSS_LLD_GIT_BRANCH = "master" 9QMSS_LLD_GIT_BRANCH = "master"
@@ -16,6 +19,8 @@ SRCREV = "${QMSS_LLD_SRCREV}"
16PV = "02.01.00.11" 19PV = "02.01.00.11"
17INC_PR = "r1" 20INC_PR = "r1"
18 21
19DEVICELIST = "k2h k2k k2l k2e" 22DEVICELIST_k2hk-evm = "k2h k2k"
23DEVICELIST_k2l-evm = "k2l"
24DEVICELIST_k2e-evm = "k2e"
20 25
21S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}" 26S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}"
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb
index 83c9a7e3..813929ec 100644
--- a/recipes-bsp/qmss-lld/qmss-lld_git.bb
+++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb
@@ -1,18 +1,10 @@
1DESCRIPTION = "TI QMSS low level driver library" 1DESCRIPTION = "TI QMSS low level driver library"
2COMPATIBLE_MACHINE = "keystone"
3 2
4DEPENDS="common-csl-ip rm-lld" 3DEPENDS="common-csl-ip rm-lld"
5 4
6include qmss-lld.inc 5include qmss-lld.inc
7 6
8PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
9
10SRC_URI += "file://init_qmss.sh"
11
12inherit update-rc.d
13
14INITSCRIPT_NAME = "init_qmss.sh"
15INITSCRIPT_PARAMS = "defaults 10"
16 8
17do_compile () { 9do_compile () {
18# Now build the lld 10# Now build the lld
@@ -27,11 +19,14 @@ do_compile () {
27do_install () { 19do_install () {
28 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 20 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
29 21
30# Set the generic device library symbolic link to default k2h 22 # Set the generic device library symbolic link to default k2h
31 cd ${D}${libdir} 23 cd ${D}${libdir}
32 ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 24
25 # Link only the first device in the list
26 for device in ${DEVICELIST}
27 do
28 ln -sf libqmss_${device}.so.1.0.0 libqmss_device.so.1
29 break
30 done
33 ln -sf libqmss_device.so.1 libqmss_device.so 31 ln -sf libqmss_device.so.1 libqmss_device.so
34# Copy init scripts
35 install -d ${D}${sysconfdir}/init.d/
36 install -c -m 755 ${WORKDIR}/init_qmss.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
37} 32}