summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-11-04 01:47:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-11-04 09:59:44 -0500
commitc252c773147b650727819a3a6e60be0111ad6e0f (patch)
treecf99cdca1012717180f219d4e02cdcc317754d77 /recipes-bsp
parent8618a97a988637fecfc6dc53e58e0684134a42a2 (diff)
downloadmeta-ti-c252c773147b650727819a3a6e60be0111ad6e0f.tar.gz
qmss-lld: Clean up recipes
* Use INC_PR to track recipe revisions * Define variables for GIT SRC_URI parameters Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld-test_git.bb2
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld.inc17
-rw-r--r--recipes-bsp/qmss-lld/qmss-lld_git.bb1
3 files changed, 15 insertions, 5 deletions
diff --git a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb
index 438d8402..7c19364f 100644
--- a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb
+++ b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb
@@ -5,6 +5,8 @@ DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld"
5 5
6include qmss-lld.inc 6include qmss-lld.inc
7 7
8PR = "${INC_PR}.0"
9
8CHOICELIST = "yes no" 10CHOICELIST = "yes no"
9 11
10do_compile () { 12do_compile () {
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc
index 29ef0ce0..efd681e4 100644
--- a/recipes-bsp/qmss-lld/qmss-lld.inc
+++ b/recipes-bsp/qmss-lld/qmss-lld.inc
@@ -1,14 +1,21 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" 2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d"
3 3
4BRANCH ="master" 4QMSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git"
5SRC_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git;destsuffix=git/ti/drv/qmss;protocol=git;branch=${BRANCH}" 5QMSS_LLD_GIT_PROTOCOL = "git"
6QMSS_LLD_GIT_BRANCH = "master"
7QMSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/qmss"
6 8
7# commit ID corresponding to DEV.QMSS_LLD.02.01.00.11 9# commit ID corresponding to DEV.QMSS_LLD.02.01.00.11
8SRCREV = "2024ab2d411c1a6dd3f5e768a3cb30c2a685f1e4" 10QMSS_LLD_SRCREV = "2024ab2d411c1a6dd3f5e768a3cb30c2a685f1e4"
11
12BRANCH ="${QMSS_LLD_GIT_BRANCH}"
13SRC_URI = "${QMSS_LLD_GIT_URI};destsuffix=${QMSS_LLD_GIT_DESTSUFFIX};protocol=${QMSS_LLD_GIT_PROTOCOL};branch=${BRANCH}"
14SRCREV = "${QMSS_LLD_SRCREV}"
15
9PV = "02.01.00.11" 16PV = "02.01.00.11"
17INC_PR = "r1"
10 18
11DEVICELIST = "k2h k2k k2l k2e" 19DEVICELIST = "k2h k2k k2l k2e"
12 20
13BASEDIR = "${WORKDIR}/git" 21S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}"
14S = "${BASEDIR}/ti/drv/qmss"
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb
index 38b07621..83c9a7e3 100644
--- a/recipes-bsp/qmss-lld/qmss-lld_git.bb
+++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb
@@ -5,6 +5,7 @@ DEPENDS="common-csl-ip rm-lld"
5 5
6include qmss-lld.inc 6include qmss-lld.inc
7 7
8PR = "${INC_PR}.0"
8 9
9SRC_URI += "file://init_qmss.sh" 10SRC_URI += "file://init_qmss.sh"
10 11