summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-11-04 22:46:52 +0000
committerRyan Eatmon <reatmon@ti.com>2022-11-23 16:08:24 -0600
commit92fdd13c1ca58328a9bf4cd6a3a950ed62925fa9 (patch)
treed9128cabbb756085a328017ec954021c4aa8d261 /meta-ti-bsp/recipes-bsp
parentcc0afdae52b5c740ffc499598d431578584f2a83 (diff)
downloadmeta-ti-92fdd13c1ca58328a9bf4cd6a3a950ed62925fa9.tar.gz
cmem-mod: Remove CMEM kernel module
CMEM has been deprecated for removal for some time now. All users should have migrated to the Linux upstream DMA-BUF Heaps framework. Remove CMEM. We only remove the kernel module part in this patch to prevent builds from breaking in the meta-arago layer due to dependencies on the CMEM library. These packages should either be updated or disabled. After that we will remove the library. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
-rw-r--r--meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb18
-rw-r--r--meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb2
2 files changed, 0 insertions, 20 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb b/meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb
deleted file mode 100644
index ea2cc5f4..00000000
--- a/meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1DESCRIPTION = "Kernel module for contiguous memory allocation from userspace"
2
3include cmem.inc
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR:append = "a"
7PR = "${MACHINE_KERNEL_PR}"
8
9inherit module
10
11EXTRA_OEMAKE += '-f lu.mak KERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" TOOLCHAIN_PREFIX="${TOOLCHAIN_PREFIX}" EXEC_DIR="${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/extra"'
12MAKE_TARGETS = "module"
13
14KERNEL_MODULE_AUTOLOAD += "cmemk"
15
16do_install:prepend() {
17 cp ${B}/src/cmem/module/Module.symvers ${B}/ || true
18}
diff --git a/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb b/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb
index f69c22fb..2042b08a 100644
--- a/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb
@@ -2,8 +2,6 @@ DESCRIPTION = "The cmem component supports contiguous memory allocation from use
2 2
3include cmem.inc 3include cmem.inc
4 4
5RDEPENDS:${PN} = "cmem-mod"
6
7PR = "r0" 5PR = "r0"
8 6
9PACKAGES =+ "${PN}-test" 7PACKAGES =+ "${PN}-test"