summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-11-04 22:46:52 +0000
committerRyan Eatmon <reatmon@ti.com>2022-11-23 16:08:24 -0600
commit92fdd13c1ca58328a9bf4cd6a3a950ed62925fa9 (patch)
treed9128cabbb756085a328017ec954021c4aa8d261
parentcc0afdae52b5c740ffc499598d431578584f2a83 (diff)
downloadmeta-ti-92fdd13c1ca58328a9bf4cd6a3a950ed62925fa9.tar.gz
cmem-mod: Remove CMEM kernel module
CMEM has been deprecated for removal for some time now. All users should have migrated to the Linux upstream DMA-BUF Heaps framework. Remove CMEM. We only remove the kernel module part in this patch to prevent builds from breaking in the meta-arago layer due to dependencies on the CMEM library. These packages should either be updated or disabled. After that we will remove the library. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb18
-rw-r--r--meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/cmem.inc96
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/cmem.dtsi38
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am571x.dtsi29
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am5729-beagleboneai.dtsi40
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am572idk.dtsi40
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am574x.dtsi40
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra71x.dtsi29
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra72x.dtsi29
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra76x.dtsi29
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem.dtsi40
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb1
13 files changed, 0 insertions, 431 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb b/meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb
deleted file mode 100644
index ea2cc5f4..00000000
--- a/meta-ti-bsp/recipes-bsp/cmem/cmem-mod_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1DESCRIPTION = "Kernel module for contiguous memory allocation from userspace"
2
3include cmem.inc
4
5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR:append = "a"
7PR = "${MACHINE_KERNEL_PR}"
8
9inherit module
10
11EXTRA_OEMAKE += '-f lu.mak KERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" TOOLCHAIN_PREFIX="${TOOLCHAIN_PREFIX}" EXEC_DIR="${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/extra"'
12MAKE_TARGETS = "module"
13
14KERNEL_MODULE_AUTOLOAD += "cmemk"
15
16do_install:prepend() {
17 cp ${B}/src/cmem/module/Module.symvers ${B}/ || true
18}
diff --git a/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb b/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb
index f69c22fb..2042b08a 100644
--- a/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cmem/cmem_git.bb
@@ -2,8 +2,6 @@ DESCRIPTION = "The cmem component supports contiguous memory allocation from use
2 2
3include cmem.inc 3include cmem.inc
4 4
5RDEPENDS:${PN} = "cmem-mod"
6
7PR = "r0" 5PR = "r0"
8 6
9PACKAGES =+ "${PN}-test" 7PACKAGES =+ "${PN}-test"
diff --git a/meta-ti-bsp/recipes-kernel/linux/cmem.inc b/meta-ti-bsp/recipes-kernel/linux/cmem.inc
deleted file mode 100644
index fd913f6c..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/cmem.inc
+++ /dev/null
@@ -1,96 +0,0 @@
1# Add concept of machine variants to split DTBs into subsets
2#
3# Use these for temporary overrides
4CMEM_MACHINE = "${MACHINE}"
5CMEM_MACHINE:am57xx-evm = "am571x am572x am572idk am5729-beagleboneai am574x"
6CMEM_MACHINE:am57xx-hs-evm = "am571x am572x am572idk am5729-beagleboneai am574x"
7CMEM_MACHINE:dra7xx-evm = "dra71x dra72x dra74x dra76x"
8CMEM_MACHINE:dra7xx-hs-evm = "dra71x dra72x dra74x dra76x"
9
10# Set cmem.dtsi per machine or machine variant
11CMEM_DTSI = "cmem.dtsi"
12CMEM_DTSI_am571x = "cmem-am571x.dtsi"
13CMEM_DTSI_am572idk = "cmem-am572idk.dtsi"
14CMEM_DTSI_am5729-beagleboneai = "cmem-am5729-beagleboneai.dtsi"
15CMEM_DTSI_am574x = "cmem-am574x.dtsi"
16CMEM_DTSI_dra71x = "cmem-dra71x.dtsi"
17CMEM_DTSI_dra72x = "cmem-dra72x.dtsi"
18CMEM_DTSI_dra76x = "cmem-dra76x.dtsi"
19
20# Split device trees between variants
21CMEM_DEVICETREE = "${KERNEL_DEVICETREE}"
22CMEM_DEVICETREE_am571x = "am571x-idk.dtb am571x-idk-lcd-osd101t2045.dtb am571x-idk-lcd-osd101t2587.dtb"
23CMEM_DEVICETREE_am572x = "am57xx-beagle-x15.dtb am57xx-beagle-x15-revc.dtb"
24CMEM_DEVICETREE_am572idk = "am572x-idk.dtb am572x-idk-lcd-osd101t2045.dtb am572x-idk-lcd-osd101t2587.dtb"
25CMEM_DEVICETREE_am5729-beagleboneai = "am5729-beagleboneai.dtb"
26CMEM_DEVICETREE_am574x = "am574x-idk.dtb am574x-idk-lcd-osd101t2587.dtb"
27CMEM_DEVICETREE_dra71x = "dra71-evm.dtb"
28CMEM_DEVICETREE_dra72x = "dra72-evm.dtb dra72-evm-lcd-osd101t2045.dtb dra72-evm-lcd-osd101t2587.dtb \
29 dra72-evm-revc.dtb dra72-evm-revc-lcd-osd101t2045.dtb dra72-evm-revc-lcd-osd101t2587.dtb"
30CMEM_DEVICETREE_dra74x = "dra7-evm.dtb dra7-evm-lcd-osd101t2045.dtb dra7-evm-lcd-osd101t2587.dtb"
31CMEM_DEVICETREE_dra76x = "dra76-evm.dtb dra76-evm-tfp410.dtb"
32
33# Flag to enable CMEM injection
34RESERVE_CMEM ?= "0"
35
36# Variables which influence setup_cmem
37CMEM_VARS = "RESERVE_CMEM CMEM_MACHINE"
38CMEM_VARS += "CMEM_DTSI ${@' '.join(map(lambda s: 'CMEM_DTSI_' + s, (d.getVar('CMEM_MACHINE') or '').split()))}"
39CMEM_VARS += "CMEM_DEVICETREE ${@' '.join(map(lambda s: 'CMEM_DEVICETREE_' + s, (d.getVar('CMEM_MACHINE') or '').split()))}"
40
41# Add correct cmem.dtsi to SRC_URI for each variant for a given machine
42python do_unpack() {
43 old_overrides = d.getVar('OVERRIDES', False)
44
45 # Initialize with empty string to simplify logic to append to SRC_URI
46 cmem_dtsi = set([''])
47
48 for cmem_machine in (d.getVar('CMEM_MACHINE') or '').split():
49 # Create copy of data for additional override
50 localdata = bb.data.createCopy(d)
51 localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides))
52 bb.data.update_data(localdata)
53
54 cmem_dtsi.add(localdata.getVar('CMEM_DTSI'))
55
56 d.appendVar('SRC_URI', ' file://'.join(cmem_dtsi))
57 bb.build.exec_func('base_do_unpack', d)
58}
59
60python do_setup_cmem() {
61 import shutil
62
63 old_overrides = d.getVar('OVERRIDES', False)
64
65 if d.getVar('RESERVE_CMEM') is '1':
66 for cmem_machine in (d.getVar('CMEM_MACHINE') or '').split():
67 # Create copy of data for additional override
68 localdata = bb.data.createCopy(d)
69 localdata.setVar('OVERRIDES', '%s:%s' % (cmem_machine, old_overrides))
70 bb.data.update_data(localdata)
71
72 # Get source directory and dtsi filename
73 src_dir = localdata.getVar('WORKDIR')
74 src_dtsi = localdata.getVar('CMEM_DTSI')
75
76 # Get destination directory and destination dtsi filename which adds
77 # the MACHINE prefix.
78 dst_dir = os.path.join(localdata.getVar('S'), localdata.expand('arch/${ARCH}/boot/dts'))
79 dst_dtsi = localdata.expand('${MACHINE}-${CMEM_DTSI}')
80
81 # Copy cmem.dtsi into source tree
82 if localdata.getVar('ARCH') is 'arm64':
83 shutil.copy(os.path.join(src_dir,src_dtsi), os.path.join(dst_dir,'ti',dst_dtsi))
84 else:
85 shutil.copy(os.path.join(src_dir,src_dtsi), os.path.join(dst_dir,dst_dtsi))
86
87 # Inject dtsi into each dts in list
88 for dtb in (localdata.getVar('CMEM_DEVICETREE') or '').split():
89 dts = dtb[:-4] + '.dts'
90
91 with open(os.path.join(dst_dir,dts), 'a') as dts_file:
92 dts_file.write('\n#include "%s"\n' % dst_dtsi)
93}
94
95do_patch[postfuncs] += "do_setup_cmem"
96do_patch[vardeps] += "${CMEM_VARS}"
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/cmem.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/cmem.dtsi
deleted file mode 100644
index 23119861..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/cmem.dtsi
+++ /dev/null
@@ -1,38 +0,0 @@
1/*
2 * This is a placeholder for CMEM reserved memory declarations. This
3 * is simply an example and does not actually reserve any memory for
4 * CMEM.
5 *
6 * The commented sections below provide an example for how to provide
7 * a reserved memory region for CMEM to use as a buffer pool.
8 */
9/ {
10/*
11 reserved-memory {
12 cmem_block_mem_0: cmem_block_mem@a0000000 {
13 reg = <0x0 0xa0000000 0x0 0x0a000000>;
14 no-map;
15 status = "okay";
16 };
17 };
18*/
19
20 cmem {
21 compatible = "ti,cmem";
22 #address-cells = <1>;
23 #size-cells = <0>;
24
25 #pool-size-cells = <2>;
26
27 status = "disabled";
28/*
29 status = "okay";
30
31 cmem_block_0: cmem_block@0 {
32 reg = <0>;
33 memory-region = <&cmem_block_mem_0>;
34 cmem-buf-pools = <1 0x0 0x0a000000>;
35 };
36*/
37 };
38};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am571x.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am571x.dtsi
deleted file mode 100644
index ebd61296..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am571x.dtsi
+++ /dev/null
@@ -1,29 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x0c000000>;
9 no-map;
10 status = "okay";
11 };
12 };
13
14 cmem {
15 compatible = "ti,cmem";
16 #address-cells = <1>;
17 #size-cells = <0>;
18
19 #pool-size-cells = <2>;
20
21 status = "okay";
22
23 cmem_block_0: cmem_block@0 {
24 reg = <0>;
25 memory-region = <&cmem_block_mem_0>;
26 cmem-buf-pools = <1 0x0 0x0c000000>;
27 };
28 };
29};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am5729-beagleboneai.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am5729-beagleboneai.dtsi
deleted file mode 100644
index e0511d08..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am5729-beagleboneai.dtsi
+++ /dev/null
@@ -1,40 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x18000000>;
9 no-map;
10 status = "okay";
11 };
12
13 cmem_block_mem_1_ocmc3: cmem_block_mem@40500000 {
14 reg = <0x0 0x40500000 0x0 0x100000>;
15 no-map;
16 status = "okay";
17 };
18 };
19
20 cmem {
21 compatible = "ti,cmem";
22 #address-cells = <1>;
23 #size-cells = <0>;
24
25 #pool-size-cells = <2>;
26
27 status = "okay";
28
29 cmem_block_0: cmem_block@0 {
30 reg = <0>;
31 memory-region = <&cmem_block_mem_0>;
32 cmem-buf-pools = <1 0x0 0x18000000>;
33 };
34
35 cmem_block_1: cmem_block@1 {
36 reg = <1>;
37 memory-region = <&cmem_block_mem_1_ocmc3>;
38 };
39 };
40};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am572idk.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am572idk.dtsi
deleted file mode 100644
index 6c39e22c..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am572idk.dtsi
+++ /dev/null
@@ -1,40 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x20000000>;
9 no-map;
10 status = "okay";
11 };
12
13 cmem_block_mem_1_ocmc3: cmem_block_mem@40500000 {
14 reg = <0x0 0x40500000 0x0 0x100000>;
15 no-map;
16 status = "okay";
17 };
18 };
19
20 cmem {
21 compatible = "ti,cmem";
22 #address-cells = <1>;
23 #size-cells = <0>;
24
25 #pool-size-cells = <2>;
26
27 status = "okay";
28
29 cmem_block_0: cmem_block@0 {
30 reg = <0>;
31 memory-region = <&cmem_block_mem_0>;
32 cmem-buf-pools = <1 0x0 0x20000000>;
33 };
34
35 cmem_block_1: cmem_block@1 {
36 reg = <1>;
37 memory-region = <&cmem_block_mem_1_ocmc3>;
38 };
39 };
40};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am574x.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am574x.dtsi
deleted file mode 100644
index 8fb3e871..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-am574x.dtsi
+++ /dev/null
@@ -1,40 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x18000000>;
9 no-map;
10 status = "okay";
11 };
12
13 cmem_block_mem_1_ocmc3: cmem_block_mem@40500000 {
14 reg = <0x0 0x40500000 0x0 0x100000>;
15 no-map;
16 status = "okay";
17 };
18 };
19
20 cmem {
21 compatible = "ti,cmem";
22 #address-cells = <1>;
23 #size-cells = <0>;
24
25 #pool-size-cells = <2>;
26
27 status = "okay";
28
29 cmem_block_0: cmem_block@0 {
30 reg = <0>;
31 memory-region = <&cmem_block_mem_0>;
32 cmem-buf-pools = <1 0x0 0x18000000>;
33 };
34
35 cmem_block_1: cmem_block@1 {
36 reg = <1>;
37 memory-region = <&cmem_block_mem_1_ocmc3>;
38 };
39 };
40};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra71x.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra71x.dtsi
deleted file mode 100644
index ebd61296..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra71x.dtsi
+++ /dev/null
@@ -1,29 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x0c000000>;
9 no-map;
10 status = "okay";
11 };
12 };
13
14 cmem {
15 compatible = "ti,cmem";
16 #address-cells = <1>;
17 #size-cells = <0>;
18
19 #pool-size-cells = <2>;
20
21 status = "okay";
22
23 cmem_block_0: cmem_block@0 {
24 reg = <0>;
25 memory-region = <&cmem_block_mem_0>;
26 cmem-buf-pools = <1 0x0 0x0c000000>;
27 };
28 };
29};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra72x.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra72x.dtsi
deleted file mode 100644
index ebd61296..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra72x.dtsi
+++ /dev/null
@@ -1,29 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x0c000000>;
9 no-map;
10 status = "okay";
11 };
12 };
13
14 cmem {
15 compatible = "ti,cmem";
16 #address-cells = <1>;
17 #size-cells = <0>;
18
19 #pool-size-cells = <2>;
20
21 status = "okay";
22
23 cmem_block_0: cmem_block@0 {
24 reg = <0>;
25 memory-region = <&cmem_block_mem_0>;
26 cmem-buf-pools = <1 0x0 0x0c000000>;
27 };
28 };
29};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra76x.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra76x.dtsi
deleted file mode 100644
index 9d207db5..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem-dra76x.dtsi
+++ /dev/null
@@ -1,29 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x18000000>;
9 no-map;
10 status = "okay";
11 };
12 };
13
14 cmem {
15 compatible = "ti,cmem";
16 #address-cells = <1>;
17 #size-cells = <0>;
18
19 #pool-size-cells = <2>;
20
21 status = "okay";
22
23 cmem_block_0: cmem_block@0 {
24 reg = <0>;
25 memory-region = <&cmem_block_mem_0>;
26 cmem-buf-pools = <1 0x0 0x18000000>;
27 };
28 };
29};
diff --git a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem.dtsi b/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem.dtsi
deleted file mode 100644
index c7781c48..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/files/dra7xx/cmem.dtsi
+++ /dev/null
@@ -1,40 +0,0 @@
1/ {
2 reserved-memory {
3 #address-cells = <2>;
4 #size-cells = <2>;
5 ranges;
6
7 cmem_block_mem_0: cmem_block_mem@a0000000 {
8 reg = <0x0 0xa0000000 0x0 0x0c000000>;
9 no-map;
10 status = "okay";
11 };
12
13 cmem_block_mem_1_ocmc3: cmem_block_mem@40500000 {
14 reg = <0x0 0x40500000 0x0 0x100000>;
15 no-map;
16 status = "okay";
17 };
18 };
19
20 cmem {
21 compatible = "ti,cmem";
22 #address-cells = <1>;
23 #size-cells = <0>;
24
25 #pool-size-cells = <2>;
26
27 status = "okay";
28
29 cmem_block_0: cmem_block@0 {
30 reg = <0>;
31 memory-region = <&cmem_block_mem_0>;
32 cmem-buf-pools = <1 0x0 0x0c000000>;
33 };
34
35 cmem_block_1: cmem_block@1 {
36 reg = <1>;
37 memory-region = <&cmem_block_mem_1_ocmc3>;
38 };
39 };
40};
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index fdb34a84..a0af03c5 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -7,7 +7,6 @@ inherit kernel
7 7
8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" 8DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh"
9require recipes-kernel/linux/setup-defconfig.inc 9require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/cmem.inc
11require recipes-kernel/linux/ti-uio.inc 10require recipes-kernel/linux/ti-uio.inc
12require recipes-kernel/linux/bundle-devicetree.inc 11require recipes-kernel/linux/bundle-devicetree.inc
13require recipes-kernel/linux/kernel-rdepends.inc 12require recipes-kernel/linux/kernel-rdepends.inc