summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2024-03-12 10:42:42 -0500
committerRyan Eatmon <reatmon@ti.com>2024-03-13 08:18:28 -0500
commit2c4db5806986359b0c7c17ea503801a3b65531ec (patch)
tree2f6fa2f42910a63061c146e31339395b0cd67466 /meta-ti-bsp/recipes-bsp
parent41bd985020294b5198c88a3f8eadb3796caac6f7 (diff)
downloadmeta-ti-2c4db5806986359b0c7c17ea503801a3b65531ec.tar.gz
prusw-fw: Combine PRU-Switch firmwares into single package
The firmware for different machines and versions are named differently so there is no need to have machine specific packages for each of these firmwares. Move all the PRU-Switch firmwares into single package. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp')
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb24
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb24
2 files changed, 16 insertions, 32 deletions
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
deleted file mode 100644
index 6e296e7c..00000000
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "PRU Ethernet Switch firmware for AM65xx SR2.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0"
7
8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
9
10TARGET = " \
11 am65x-sr2-pru0-prusw-fw.elf \
12 am65x-sr2-pru1-prusw-fw.elf \
13 am65x-sr2-rtu0-prusw-fw.elf \
14 am65x-sr2-rtu1-prusw-fw.elf \
15 am65x-sr2-txpru0-prusw-fw.elf \
16 am65x-sr2-txpru1-prusw-fw.elf \
17"
18
19do_install() {
20 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
21 for f in ${TARGET}; do
22 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
23 done
24}
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
index 755f93b9..be407363 100644
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb
@@ -1,17 +1,25 @@
1SUMMARY = "PRU Switch firmware for AM57xx, AM437x and AM335x" 1SUMMARY = "PRU Switch firmware"
2 2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4 4
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
6 6
7COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 7COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx|am65xx|am64xx"
8 8
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9TARGET = " \
10 10 am335x-pru0-prusw-fw.elf \
11TARGET = "" 11 am335x-pru1-prusw-fw.elf \
12TARGET:ti33x = "am335x-pru0-prusw-fw.elf am335x-pru1-prusw-fw.elf" 12 am437x-pru0-prusw-fw.elf \
13TARGET:ti43x = "am437x-pru0-prusw-fw.elf am437x-pru1-prusw-fw.elf" 13 am437x-pru1-prusw-fw.elf \
14TARGET:am57xx = "am57xx-pru0-prusw-fw.elf am57xx-pru1-prusw-fw.elf" 14 am57xx-pru0-prusw-fw.elf \
15 am57xx-pru1-prusw-fw.elf \
16 am65x-sr2-pru0-prusw-fw.elf \
17 am65x-sr2-pru1-prusw-fw.elf \
18 am65x-sr2-rtu0-prusw-fw.elf \
19 am65x-sr2-rtu1-prusw-fw.elf \
20 am65x-sr2-txpru0-prusw-fw.elf \
21 am65x-sr2-txpru1-prusw-fw.elf \
22"
15 23
16do_install() { 24do_install() {
17 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss 25 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss