summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorParesh Bhagat <p-bhagat@ti.com>2023-11-28 15:11:56 +0530
committerRyan Eatmon <reatmon@ti.com>2023-11-28 09:18:04 -0600
commitedcd569448e271ef518a9a5540c9da2464e514db (patch)
tree1fdaf8f50621437606446706840e78fa14fd171b
parent54b55b55fa52777c2a8ef9a9a0c350bd80b085f6 (diff)
downloadmeta-ti-edcd569448e271ef518a9a5540c9da2464e514db.tar.gz
Update SRCREV for ti-jailhouse
Update SRCREV for ti-jailhouse. All the patches which was being applied via yocto have been moved to ti-jailhouse repo now. So remove the patches from SRC_URI and files. Signed-off-by: Paresh Bhagat <p-bhagat@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-arm64-k3-am625-sk-Add-crypto-memory-region.patch52
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-k3-use-intx-for-bar_mask.patch72
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/files/0002-configs-arm64-k3-am625-sk-Switch-inmate-boot-console.patch62
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/files/0003-configs-arm64-k3-am625-sk-Add-VTM-memory-region.patch53
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/files/0004-configs-arm64-k3-am625-sk-Add-GPMC-memory-region.patch51
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb7
6 files changed, 1 insertions, 296 deletions
diff --git a/meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-arm64-k3-am625-sk-Add-crypto-memory-region.patch b/meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-arm64-k3-am625-sk-Add-crypto-memory-region.patch
deleted file mode 100644
index bfb57ae3..00000000
--- a/meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-arm64-k3-am625-sk-Add-crypto-memory-region.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From 723ca87d25c1f8bac68d2608dbc3b5e8caba69ca Mon Sep 17 00:00:00 2001
2From: Andreas Dannenberg <dannenberg@ti.com>
3Date: Mon, 12 Sep 2022 13:22:04 -0500
4Subject: [PATCH] configs: arm64: k3-am625-sk: Add crypto memory region
5
6Add the memory region for the AM62x crypto accelerator to the device-
7specific config file. This fixes a runtime exception when the kernel
8accesses that memory region:
9
10<snip>
11Unhandled data read at 0x40910010(4)
12
13FATAL: unhandled trap (exception class 0x24)
14<snip>
15
16Upstream-Status: Submitted [jailhouse-dev@googlegroups.com]
17
18Signed-off-by: Andreas Dannenberg <dannenberg@ti.com>
19Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
20---
21 configs/arm64/k3-am625-sk.c | 9 ++++++++-
22 1 file changed, 8 insertions(+), 1 deletion(-)
23
24diff --git a/configs/arm64/k3-am625-sk.c b/configs/arm64/k3-am625-sk.c
25index 2e5c3aef..4b0b8043 100644
26--- a/configs/arm64/k3-am625-sk.c
27+++ b/configs/arm64/k3-am625-sk.c
28@@ -18,7 +18,7 @@
29 struct {
30 struct jailhouse_system header;
31 __u64 cpus[1];
32- struct jailhouse_memory mem_regions[31];
33+ struct jailhouse_memory mem_regions[32];
34 struct jailhouse_irqchip irqchips[5];
35 struct jailhouse_pci_device pci_devices[2];
36 } __attribute__((packed)) config = {
37@@ -231,6 +231,13 @@ struct {
38 .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
39 JAILHOUSE_MEM_IO,
40 },
41+ /* CRYPTO */ {
42+ .phys_start = 0x40900000,
43+ .virt_start = 0x40900000,
44+ .size = 0x0030000,
45+ .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
46+ JAILHOUSE_MEM_IO,
47+ },
48 /* First Wake Up Domain */ {
49 .phys_start = 0x2b000000,
50 .virt_start = 0x2b000000,
51--
522.34.1
diff --git a/meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-k3-use-intx-for-bar_mask.patch b/meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-k3-use-intx-for-bar_mask.patch
deleted file mode 100644
index c29baed5..00000000
--- a/meta-ti-extras/recipes-ti/jailhouse/files/0001-configs-k3-use-intx-for-bar_mask.patch
+++ /dev/null
@@ -1,72 +0,0 @@
1From 84ea5e9f65fc8082d520267258784cae32c8b499 Mon Sep 17 00:00:00 2001
2From: Ricardo Salveti <ricardo@foundries.io>
3Date: Wed, 1 Mar 2023 22:14:35 -0300
4Subject: [PATCH] configs/k3: use intx for bar_mask
5
6Fixes pci probe failure:
7
8[ 46.795840] pci 0001:00:00.0: BAR 0: no space for [mem size 0x00010000]
9[ 46.802516] pci 0001:00:00.0: BAR 0: failed to assign [mem size 0x00010000]
10[ 46.809512] pci 0001:00:01.0: BAR 0: no space for [mem size 0x00010000]
11[ 46.816158] pci 0001:00:01.0: BAR 0: failed to assign [mem size 0x00010000]
12
13Upstream-Status: Pending
14
15Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
16
17This patch was imported from foundriesio/meta-lmp
18(https://github.com/foundriesio/meta-lmp) as of commit id
1970d419bfd54a99d3591e5a22622fc67f7de82b94.
20
21Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
22---
23 configs/arm64/k3-am625-sk-linux-demo.c | 4 ++--
24 configs/arm64/k3-am625-sk.c | 4 ++--
25 2 files changed, 4 insertions(+), 4 deletions(-)
26
27diff --git a/configs/arm64/k3-am625-sk-linux-demo.c b/configs/arm64/k3-am625-sk-linux-demo.c
28index 6dac8859..dcc5f026 100644
29--- a/configs/arm64/k3-am625-sk-linux-demo.c
30+++ b/configs/arm64/k3-am625-sk-linux-demo.c
31@@ -197,7 +197,7 @@ struct {
32 /* 00:00.0 */ {
33 .type = JAILHOUSE_PCI_TYPE_IVSHMEM,
34 .bdf = 0 << 3,
35- .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX_64K,
36+ .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX,
37 .shmem_regions_start = 0,
38 .shmem_dev_id = 2,
39 .shmem_peers = 3,
40@@ -206,7 +206,7 @@ struct {
41 /* 00:01.0 */ {
42 .type = JAILHOUSE_PCI_TYPE_IVSHMEM,
43 .bdf = 1 << 3,
44- .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX_64K,
45+ .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX,
46 .shmem_regions_start = 5,
47 .shmem_dev_id = 1,
48 .shmem_peers = 2,
49diff --git a/configs/arm64/k3-am625-sk.c b/configs/arm64/k3-am625-sk.c
50index 69ab12a4..dcea42e0 100644
51--- a/configs/arm64/k3-am625-sk.c
52+++ b/configs/arm64/k3-am625-sk.c
53@@ -325,7 +325,7 @@ struct {
54 .type = JAILHOUSE_PCI_TYPE_IVSHMEM,
55 .domain = 1,
56 .bdf = 0 << 3,
57- .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX_64K,
58+ .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX,
59 .shmem_regions_start = 0,
60 .shmem_dev_id = 0,
61 .shmem_peers = 3,
62@@ -335,7 +335,7 @@ struct {
63 .type = JAILHOUSE_PCI_TYPE_IVSHMEM,
64 .domain = 1,
65 .bdf = 1 << 3,
66- .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX_64K,
67+ .bar_mask = JAILHOUSE_IVSHMEM_BAR_MASK_INTX,
68 .shmem_regions_start = 5,
69 .shmem_dev_id = 0,
70 .shmem_peers = 2,
71--
722.34.1
diff --git a/meta-ti-extras/recipes-ti/jailhouse/files/0002-configs-arm64-k3-am625-sk-Switch-inmate-boot-console.patch b/meta-ti-extras/recipes-ti/jailhouse/files/0002-configs-arm64-k3-am625-sk-Switch-inmate-boot-console.patch
deleted file mode 100644
index 3634c415..00000000
--- a/meta-ti-extras/recipes-ti/jailhouse/files/0002-configs-arm64-k3-am625-sk-Switch-inmate-boot-console.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From dbc02104bb469f68034b84f293583df413b8ca56 Mon Sep 17 00:00:00 2001
2From: Andreas Dannenberg <dannenberg@ti.com>
3Date: Mon, 12 Sep 2022 16:08:12 -0500
4Subject: [PATCH] configs: arm64: k3-am625-sk: Switch inmate boot console alias
5 to serial3
6
7Traditionally the serial3 DTS alias is used for the 2nd main-domain UART
8on K3 devices so go ahead and update the alias and its usage accordingly
9for better consistency.
10
11While at it also do a minor cleanup of the UART's DTS node to use the
12TISCI standard definitions as used in the corresponding Kernel DTS files.
13
14Upstream-Status: Submitted [jailhouse-dev@googlegroups.com]
15
16Signed-off-by: Andreas Dannenberg <dannenberg@ti.com>
17Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
18---
19 configs/arm64/dts/inmate-k3-am625-sk.dts | 11 ++++++-----
20 1 file changed, 6 insertions(+), 5 deletions(-)
21
22diff --git a/configs/arm64/dts/inmate-k3-am625-sk.dts b/configs/arm64/dts/inmate-k3-am625-sk.dts
23index c1455073..8e1bebb8 100644
24--- a/configs/arm64/dts/inmate-k3-am625-sk.dts
25+++ b/configs/arm64/dts/inmate-k3-am625-sk.dts
26@@ -1,6 +1,7 @@
27 /dts-v1/;
28
29 #include <dt-bindings/interrupt-controller/arm-gic.h>
30+#include <dt-bindings/soc/ti,sci_pm_domain.h>
31
32 / {
33 model = "Texas Instruments AM625 Inmate Model";
34@@ -10,11 +11,11 @@
35 #size-cells = <2>;
36
37 aliases {
38- serial1 = &main_uart1;
39+ serial3 = &main_uart1;
40 };
41
42 chosen {
43- stdout-path = "serial1:115200n8";
44+ stdout-path = "serial3:115200n8";
45 };
46
47 memory@e0000000 {
48@@ -91,9 +92,9 @@
49 compatible = "ti,am64-uart", "ti,am654-uart";
50 reg = <0x00 0x02810000 0x00 0x100>;
51 interrupts = <GIC_SPI 179 IRQ_TYPE_LEVEL_HIGH>;
52- power-domains = <&k3_pds 152 1>;
53- current-speed = <115200>;
54- clock-frequency = <48000000>;
55+ power-domains = <&k3_pds 152 TI_SCI_PD_EXCLUSIVE>;
56+ clocks = <&k3_clks 152 0>;
57+ clock-names = "fclk";
58 };
59
60 pci@76000000 {
61--
622.34.1
diff --git a/meta-ti-extras/recipes-ti/jailhouse/files/0003-configs-arm64-k3-am625-sk-Add-VTM-memory-region.patch b/meta-ti-extras/recipes-ti/jailhouse/files/0003-configs-arm64-k3-am625-sk-Add-VTM-memory-region.patch
deleted file mode 100644
index c2b68e8d..00000000
--- a/meta-ti-extras/recipes-ti/jailhouse/files/0003-configs-arm64-k3-am625-sk-Add-VTM-memory-region.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From 9c9bba78b5635531fc8946914233af8c8ac8a6f3 Mon Sep 17 00:00:00 2001
2From: Andreas Dannenberg <dannenberg@ti.com>
3Date: Fri, 4 Nov 2022 12:58:48 -0500
4Subject: [PATCH] configs: arm64: k3-am625-sk: Add VTM memory region
5
6Add the memory region for VTM to the device-specific config
7file. This fixes a runtime exception when the kernel accesses
8that memory region:
9
10<snip>
11Unhandled data read at 0xb00308(4)
12
13FATAL: unhandled trap (exception class 0x24)
14<snip>
15
16Upstream-Status: Submitted [jailhouse-dev@googlegroups.com]
17
18written by: Ricardo Salveti <ricardo@foundries.io>
19Signed-off-by: Andreas Dannenberg <dannenberg@ti.com>
20Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
21---
22 configs/arm64/k3-am625-sk.c | 9 ++++++++-
23 1 file changed, 8 insertions(+), 1 deletion(-)
24
25diff --git a/configs/arm64/k3-am625-sk.c b/configs/arm64/k3-am625-sk.c
26index 4b0b8043..fac4eaa6 100644
27--- a/configs/arm64/k3-am625-sk.c
28+++ b/configs/arm64/k3-am625-sk.c
29@@ -18,7 +18,7 @@
30 struct {
31 struct jailhouse_system header;
32 __u64 cpus[1];
33- struct jailhouse_memory mem_regions[32];
34+ struct jailhouse_memory mem_regions[33];
35 struct jailhouse_irqchip irqchips[5];
36 struct jailhouse_pci_device pci_devices[2];
37 } __attribute__((packed)) config = {
38@@ -154,6 +154,13 @@ struct {
39 .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
40 JAILHOUSE_MEM_IO,
41 },
42+ /* Wake Up Domain VTM0 */ {
43+ .phys_start = 0x00b00000,
44+ .virt_start = 0x00b00000,
45+ .size = 0x00001000,
46+ .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
47+ JAILHOUSE_MEM_IO,
48+ },
49 /* First peripheral window, 1 of 2 */ {
50 .phys_start = 0x01000000,
51 .virt_start = 0x01000000,
52--
532.34.1
diff --git a/meta-ti-extras/recipes-ti/jailhouse/files/0004-configs-arm64-k3-am625-sk-Add-GPMC-memory-region.patch b/meta-ti-extras/recipes-ti/jailhouse/files/0004-configs-arm64-k3-am625-sk-Add-GPMC-memory-region.patch
deleted file mode 100644
index 800470bf..00000000
--- a/meta-ti-extras/recipes-ti/jailhouse/files/0004-configs-arm64-k3-am625-sk-Add-GPMC-memory-region.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From c0e85959637a1de61170d1025e1bac8da283ddb9 Mon Sep 17 00:00:00 2001
2From: Andreas Dannenberg <dannenberg@ti.com>
3Date: Thu, 19 Jan 2023 09:43:55 -0600
4Subject: [PATCH] configs: arm64: k3-am625-sk: Add GPMC memory region
5
6Add the memory region for GPMC, used by the AM62Q NAND card.
7
8Upstream-Status: Submitted [jailhouse-dev@googlegroups.com]
9
10Signed-off-by: Andreas Dannenberg <dannenberg@ti.com>
11Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
12---
13 configs/arm64/k3-am625-sk.c | 16 +++++++++++++++-
14 1 file changed, 15 insertions(+), 1 deletion(-)
15
16diff --git a/configs/arm64/k3-am625-sk.c b/configs/arm64/k3-am625-sk.c
17index fac4eaa6..10b5a8f3 100644
18--- a/configs/arm64/k3-am625-sk.c
19+++ b/configs/arm64/k3-am625-sk.c
20@@ -18,7 +18,7 @@
21 struct {
22 struct jailhouse_system header;
23 __u64 cpus[1];
24- struct jailhouse_memory mem_regions[33];
25+ struct jailhouse_memory mem_regions[35];
26 struct jailhouse_irqchip irqchips[5];
27 struct jailhouse_pci_device pci_devices[2];
28 } __attribute__((packed)) config = {
29@@ -231,6 +231,20 @@ struct {
30 .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
31 JAILHOUSE_MEM_IO,
32 },
33+ /* GPMC */ {
34+ .phys_start = 0x3b000000,
35+ .virt_start = 0x3b000000,
36+ .size = 0x00001000,
37+ .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
38+ JAILHOUSE_MEM_IO,
39+ },
40+ /* GPMC */ {
41+ .phys_start = 0x50000000,
42+ .virt_start = 0x50000000,
43+ .size = 0x08000000,
44+ .flags = JAILHOUSE_MEM_READ | JAILHOUSE_MEM_WRITE |
45+ JAILHOUSE_MEM_IO,
46+ },
47 /* CPSW */ {
48 .phys_start = 0x08000000,
49 .virt_start = 0x08000000,
50--
512.34.1
diff --git a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
index ca829986..387b0806 100644
--- a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
+++ b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
@@ -15,16 +15,11 @@ COMPATIBLE_MACHINE = "am62xx|am62pxx"
15TARGET_CC_ARCH += "${LDFLAGS}" 15TARGET_CC_ARCH += "${LDFLAGS}"
16 16
17PV = "0.12+git${SRCPV}" 17PV = "0.12+git${SRCPV}"
18SRCREV = "e57d1eff6d55aeed5f977fe4e2acfb6ccbdd7560" 18SRCREV = "0b29ad90f6f54105b98d6bbf35cc47fb244f7799"
19BRANCH = "master" 19BRANCH = "master"
20 20
21SRC_URI = " \ 21SRC_URI = " \
22 git://git.ti.com/git/jailhouse/ti-jailhouse.git;protocol=https;branch=${BRANCH} \ 22 git://git.ti.com/git/jailhouse/ti-jailhouse.git;protocol=https;branch=${BRANCH} \
23 file://0001-configs-arm64-k3-am625-sk-Add-crypto-memory-region.patch \
24 file://0002-configs-arm64-k3-am625-sk-Switch-inmate-boot-console.patch \
25 file://0003-configs-arm64-k3-am625-sk-Add-VTM-memory-region.patch \
26 file://0001-configs-k3-use-intx-for-bar_mask.patch \
27 file://0004-configs-arm64-k3-am625-sk-Add-GPMC-memory-region.patch \
28" 23"
29 24
30DEPENDS = "virtual/kernel dtc-native python3-mako-native python3-mako make-native" 25DEPENDS = "virtual/kernel dtc-native python3-mako-native python3-mako make-native"