summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorParesh Bhagat <p-bhagat@ti.com>2023-11-23 12:03:20 +0530
committerRyan Eatmon <reatmon@ti.com>2023-11-24 08:20:08 -0600
commit54b55b55fa52777c2a8ef9a9a0c350bd80b085f6 (patch)
tree142c07e6f1a36a4eb58d484bb55642ca7b8416c7
parent85729f84543774ff40afe05fc0220d8556c8f602 (diff)
downloadmeta-ti-54b55b55fa52777c2a8ef9a9a0c350bd80b085f6.tar.gz
ti-extras: Add support for extra kernel/u-boot features for am62pxx
Add support for ti-extras for am62pxx to control the kernel and u-boot repos, branches, and srcrevs via the TI_EXTRAS variable in the local.conf file. Also add am62pxx as compatble machine in jailhouse recipe. So the am62pxx jailhouse build can be done by adding TI_EXTRAS=tie-jailhouse in local.conf. Signed-off-by: Paresh Bhagat <p-bhagat@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf1
-rw-r--r--meta-ti-bsp/conf/machine/am62pxx-evm.conf1
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/ti-extras-rt.inc2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/ti-extras.inc2
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb6
6 files changed, 10 insertions, 4 deletions
diff --git a/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf
index 33254bf2..36915381 100644
--- a/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf
+++ b/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf
@@ -3,6 +3,7 @@
3#@DESCRIPTION: Machine configuration for the TI AM62Px EVM (R5F core) 3#@DESCRIPTION: Machine configuration for the TI AM62Px EVM (R5F core)
4 4
5require conf/machine/include/k3r5.inc 5require conf/machine/include/k3r5.inc
6require conf/machine/include/ti-extras.inc
6 7
7SYSFW_SOC = "am62px" 8SYSFW_SOC = "am62px"
8SYSFW_CONFIG = "evm" 9SYSFW_CONFIG = "evm"
diff --git a/meta-ti-bsp/conf/machine/am62pxx-evm.conf b/meta-ti-bsp/conf/machine/am62pxx-evm.conf
index 931de953..d7c9f589 100644
--- a/meta-ti-bsp/conf/machine/am62pxx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am62pxx-evm.conf
@@ -3,6 +3,7 @@
3#@DESCRIPTION: Machine configuration for the TI AM62PX EVM 3#@DESCRIPTION: Machine configuration for the TI AM62PX EVM
4 4
5require conf/machine/include/am62pxx.inc 5require conf/machine/include/am62pxx.inc
6require conf/machine/include/ti-extras.inc
6 7
7KERNEL_DEVICETREE_PREFIX = " \ 8KERNEL_DEVICETREE_PREFIX = " \
8 ti/k3-am62p5 \ 9 ti/k3-am62p5 \
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc
index e0a94ea6..d32c6529 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc
@@ -1,7 +1,7 @@
1 1
2# This will have priority over generic uboot path 2# This will have priority over generic uboot path
3 3
4COMPATIBLE_MACHINE = "am62xx" 4COMPATIBLE_MACHINE = "am62xx|am62pxx"
5 5
6BRANCH = "ti-u-boot-2023.04" 6BRANCH = "ti-u-boot-2023.04"
7BRANCH:tie-jailhouse = "ti-u-boot-2023.04-jailhouse" 7BRANCH:tie-jailhouse = "ti-u-boot-2023.04-jailhouse"
diff --git a/meta-ti-bsp/recipes-kernel/linux/ti-extras-rt.inc b/meta-ti-bsp/recipes-kernel/linux/ti-extras-rt.inc
index 1fc40934..530a1783 100644
--- a/meta-ti-bsp/recipes-kernel/linux/ti-extras-rt.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/ti-extras-rt.inc
@@ -2,7 +2,7 @@
2# Use different commit, repo and branch for TI extras build 2# Use different commit, repo and branch for TI extras build
3# This will have priority over generic rt path 3# This will have priority over generic rt path
4 4
5COMPATIBLE_MACHINE = "am62xx" 5COMPATIBLE_MACHINE = "am62xx|am62pxx"
6 6
7BRANCH = "ti-rt-linux-6.1.y" 7BRANCH = "ti-rt-linux-6.1.y"
8BRANCH:tie-jailhouse = "ti-rt-linux-6.1.y-jailhouse" 8BRANCH:tie-jailhouse = "ti-rt-linux-6.1.y-jailhouse"
diff --git a/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
index 076a67db..0b22aca9 100644
--- a/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
@@ -2,7 +2,7 @@
2# Use different commit, repo and branch for TI extras build 2# Use different commit, repo and branch for TI extras build
3# This will have priority over generic rt path 3# This will have priority over generic rt path
4 4
5COMPATIBLE_MACHINE = "am62xx" 5COMPATIBLE_MACHINE = "am62xx|am62pxx"
6 6
7BRANCH = "ti-linux-6.1.y" 7BRANCH = "ti-linux-6.1.y"
8BRANCH:tie-jailhouse = "ti-linux-6.1.y-jailhouse" 8BRANCH:tie-jailhouse = "ti-linux-6.1.y-jailhouse"
diff --git a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
index a96a7831..ca829986 100644
--- a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
+++ b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = " \
10 file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \ 10 file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \
11" 11"
12 12
13COMPATIBLE_MACHINE = "am62xx" 13COMPATIBLE_MACHINE = "am62xx|am62pxx"
14 14
15TARGET_CC_ARCH += "${LDFLAGS}" 15TARGET_CC_ARCH += "${LDFLAGS}"
16 16
@@ -55,18 +55,21 @@ JH_CELL_FILES:k3 ?= "k3-*.cell"
55JH_INMATE_DTB ?= "" 55JH_INMATE_DTB ?= ""
56JH_INMATE_DTB:am62xx ?= "inmate-k3-am625-sk.dtb" 56JH_INMATE_DTB:am62xx ?= "inmate-k3-am625-sk.dtb"
57JH_INMATE_DTB:am65xx ?= "inmate-k3-am654-idk.dtb" 57JH_INMATE_DTB:am65xx ?= "inmate-k3-am654-idk.dtb"
58JH_INMATE_DTB:am62pxx ?= "inmate-k3-am62p5-sk.dtb"
58JH_INMATE_DTB:j7 ?= "inmate-k3-j721e-evm.dtb" 59JH_INMATE_DTB:j7 ?= "inmate-k3-j721e-evm.dtb"
59JH_INMATE_DTB:j7200-evm ?= "inmate-k3-j7200-evm.dtb" 60JH_INMATE_DTB:j7200-evm ?= "inmate-k3-j7200-evm.dtb"
60 61
61JH_LINUX_DEMO_CELL ?= "" 62JH_LINUX_DEMO_CELL ?= ""
62JH_LINUX_DEMO_CELL:am62xx ?= "k3-am625-sk-linux-demo.cell" 63JH_LINUX_DEMO_CELL:am62xx ?= "k3-am625-sk-linux-demo.cell"
63JH_LINUX_DEMO_CELL:am65xx ?= "k3-am654-idk-linux-demo.cell" 64JH_LINUX_DEMO_CELL:am65xx ?= "k3-am654-idk-linux-demo.cell"
65JH_LINUX_DEMO_CELL:am62pxx ?= "k3-am62p5-sk-linux-demo.cell"
64JH_LINUX_DEMO_CELL:j7 ?= "k3-j721e-evm-linux-demo.cell" 66JH_LINUX_DEMO_CELL:j7 ?= "k3-j721e-evm-linux-demo.cell"
65JH_LINUX_DEMO_CELL:j7200-evm ?= "k3-j7200-evm-linux-demo.cell" 67JH_LINUX_DEMO_CELL:j7200-evm ?= "k3-j7200-evm-linux-demo.cell"
66 68
67JH_SYSCONFIG_CELL ?= "" 69JH_SYSCONFIG_CELL ?= ""
68JH_SYSCONFIG_CELL:am62xx ?= "k3-am625-sk.cell" 70JH_SYSCONFIG_CELL:am62xx ?= "k3-am625-sk.cell"
69JH_SYSCONFIG_CELL:am65xx ?= "k3-am654-idk.cell" 71JH_SYSCONFIG_CELL:am65xx ?= "k3-am654-idk.cell"
72JH_SYSCONFIG_CELL:am62pxx ?= "k3-am62p5-sk.cell"
70JH_SYSCONFIG_CELL:j7 ?= "k3-j721e-evm.cell" 73JH_SYSCONFIG_CELL:j7 ?= "k3-j721e-evm.cell"
71JH_SYSCONFIG_CELL:j7200-evm ?= "k3-j7200-evm.cell" 74JH_SYSCONFIG_CELL:j7200-evm ?= "k3-j7200-evm.cell"
72 75
@@ -75,6 +78,7 @@ JH_RAMFS_IMAGE ?= "${INITRAMFS_IMAGE}"
75 78
76JH_CMDLINE ?= "" 79JH_CMDLINE ?= ""
77JH_CMDLINE:am62xx ?= "console=ttyS3,115200n8 earlycon=ns16550a,mmio32,0x02810000" 80JH_CMDLINE:am62xx ?= "console=ttyS3,115200n8 earlycon=ns16550a,mmio32,0x02810000"
81JH_CMDLINE:am62pxx ?= "console=ttyS1,115200n8"
78JH_CMDLINE:am65xx ?= "console=ttyS1,115200n8" 82JH_CMDLINE:am65xx ?= "console=ttyS1,115200n8"
79JH_CMDLINE:j7 ?= "console=ttyS3,115200n8" 83JH_CMDLINE:j7 ?= "console=ttyS3,115200n8"
80JH_CMDLINE:j7200-evm ?= "console=ttyS3,115200n8" 84JH_CMDLINE:j7200-evm ?= "console=ttyS3,115200n8"