summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2024-03-12 10:42:40 -0500
committerRyan Eatmon <reatmon@ti.com>2024-03-13 08:18:28 -0500
commit81b671424f5df102ab7a814454eef30fc89a0517 (patch)
treec148c0217961722ddeb4067d2188746d9363600b
parente37033130d439c1e37d8faa3d74b065d23ff70a9 (diff)
downloadmeta-ti-81b671424f5df102ab7a814454eef30fc89a0517.tar.gz
prueth-fw: Combine PRU-ETH firmwares into single package
The firmware for different machines and versions are named differently so there is no need to have machine specific packages for each of these firmwares. Move all the PRU-ETH firmwares into single package. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am65xx-evm.conf2
-rw-r--r--meta-ti-bsp/conf/machine/include/am64xx.inc2
-rw-r--r--meta-ti-bsp/conf/machine/include/am65xx.inc2
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb24
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb22
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb28
6 files changed, 23 insertions, 57 deletions
diff --git a/meta-ti-bsp/conf/machine/am65xx-evm.conf b/meta-ti-bsp/conf/machine/am65xx-evm.conf
index f6eb6f0c..3d8e11b4 100644
--- a/meta-ti-bsp/conf/machine/am65xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am65xx-evm.conf
@@ -6,4 +6,4 @@ require conf/machine/include/am65xx.inc
6 6
7UBOOT_MACHINE = "am65x_evm_a53_defconfig" 7UBOOT_MACHINE = "am65x_evm_a53_defconfig"
8 8
9MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2" 9MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
diff --git a/meta-ti-bsp/conf/machine/include/am64xx.inc b/meta-ti-bsp/conf/machine/include/am64xx.inc
index 85652eef..fb71d271 100644
--- a/meta-ti-bsp/conf/machine/include/am64xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am64xx.inc
@@ -21,4 +21,4 @@ TFA_BOARD = "lite"
21 21
22OPTEEMACHINE = "k3-am64x" 22OPTEEMACHINE = "k3-am64x"
23 23
24MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2" 24MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
diff --git a/meta-ti-bsp/conf/machine/include/am65xx.inc b/meta-ti-bsp/conf/machine/include/am65xx.inc
index 7c9d5fb1..80a7744a 100644
--- a/meta-ti-bsp/conf/machine/include/am65xx.inc
+++ b/meta-ti-bsp/conf/machine/include/am65xx.inc
@@ -26,4 +26,4 @@ TFA_BOARD = "generic"
26 26
27OPTEEMACHINE = "k3-am65x" 27OPTEEMACHINE = "k3-am65x"
28 28
29MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw-am65x" 29MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "prueth-fw"
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
deleted file mode 100644
index 4b6ef75d..00000000
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "PRU Ethernet firmware for AM65xx SR2.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0"
7
8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
9
10TARGET = " \
11 am65x-sr2-pru0-prueth-fw.elf \
12 am65x-sr2-pru1-prueth-fw.elf \
13 am65x-sr2-rtu0-prueth-fw.elf \
14 am65x-sr2-rtu1-prueth-fw.elf \
15 am65x-sr2-txpru0-prueth-fw.elf \
16 am65x-sr2-txpru1-prueth-fw.elf \
17"
18
19do_install() {
20 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
21 for f in ${TARGET}; do
22 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
23 done
24}
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
deleted file mode 100644
index 20b2bfb9..00000000
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1SUMMARY = "PRU Ethernet firmware for AM65x SR1.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_VERSION}"
6PR = "${INC_PR}.0"
7
8COMPATIBLE_MACHINE = "am65xx"
9
10TARGET = " \
11 am65x-pru0-prueth-fw.elf \
12 am65x-pru1-prueth-fw.elf \
13 am65x-rtu0-prueth-fw.elf \
14 am65x-rtu1-prueth-fw.elf \
15"
16
17do_install() {
18 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
19 for f in ${TARGET}; do
20 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
21 done
22}
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
index 463f3faa..b85355e4 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
@@ -1,17 +1,29 @@
1SUMMARY = "PRU Ethernet firmware for AM57xx, AM437x and AM335x" 1SUMMARY = "PRU Ethernet firmware"
2 2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4 4
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
6 6
7COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx" 7COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx|am65xx|am64xx"
8 8
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9TARGET = " \
10 10 am335x-pru0-prueth-fw.elf \
11TARGET = "" 11 am335x-pru1-prueth-fw.elf \
12TARGET:ti33x = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf" 12 am437x-pru0-prueth-fw.elf \
13TARGET:ti43x = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf" 13 am437x-pru1-prueth-fw.elf \
14TARGET:am57xx = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf" 14 am57xx-pru0-prueth-fw.elf \
15 am57xx-pru1-prueth-fw.elf \
16 am65x-pru0-prueth-fw.elf \
17 am65x-pru1-prueth-fw.elf \
18 am65x-rtu0-prueth-fw.elf \
19 am65x-rtu1-prueth-fw.elf \
20 am65x-sr2-pru0-prueth-fw.elf \
21 am65x-sr2-pru1-prueth-fw.elf \
22 am65x-sr2-rtu0-prueth-fw.elf \
23 am65x-sr2-rtu1-prueth-fw.elf \
24 am65x-sr2-txpru0-prueth-fw.elf \
25 am65x-sr2-txpru1-prueth-fw.elf \
26"
15 27
16do_install() { 28do_install() {
17 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss 29 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss