summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2024-03-12 10:42:39 -0500
committerRyan Eatmon <reatmon@ti.com>2024-03-13 08:18:28 -0500
commite37033130d439c1e37d8faa3d74b065d23ff70a9 (patch)
tree6b9189ce7407568302df7333f71b39de901cb235
parent3482c0b47c63dcf2834495a2347e3e313542da93 (diff)
downloadmeta-ti-e37033130d439c1e37d8faa3d74b065d23ff70a9.tar.gz
recipes-bsp: Do not use MACHINE_ARCH when package is not machine specific
Most firmware does not run on the host and is therefor not architecture specific, at least as far as the package manager is concerned. Although the firmware might not be useful on some machines, the package itself is not machine specific. Remove PACKAGE_ARCH. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb2
-rwxr-xr-xmeta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb1
-rw-r--r--meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb1
-rw-r--r--meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb1
11 files changed, 0 insertions, 19 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
index d88bca6e..ed1c7817 100644
--- a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
@@ -10,8 +10,6 @@ PR = "${INC_PR}.0"
10 10
11COMPATIBLE_MACHINE = "j721e|j721s2|j784s4" 11COMPATIBLE_MACHINE = "j721e|j721s2|j784s4"
12 12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15TARGET = "mhdp8546.bin" 13TARGET = "mhdp8546.bin"
16 14
17do_install() { 15do_install() {
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index d1b99979..1a2e911c 100644
--- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -12,8 +12,6 @@ PR = "${INC_PR}.1"
12 12
13COMPATIBLE_MACHINE = "j721s2|j784s4|j722s|am62axx|am62pxx" 13COMPATIBLE_MACHINE = "j721s2|j784s4|j722s|am62axx|am62pxx"
14 14
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17TARGET_WAVE521C = "wave521c_codec_fw.bin" 15TARGET_WAVE521C = "wave521c_codec_fw.bin"
18 16
19SOURCE_WAVE521C = "wave521c_k3_codec_fw.bin" 17SOURCE_WAVE521C = "wave521c_k3_codec_fw.bin"
diff --git a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
index 61b1b986..95ba1e2d 100755
--- a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
@@ -4,7 +4,6 @@ LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db" 4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db"
5 5
6PV = "6.2+git" 6PV = "6.2+git"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8 7
9inherit update-alternatives 8inherit update-alternatives
10 9
diff --git a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
index e58f2d58..ee3a94dc 100644
--- a/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/goodix-fw/goodix-fw_git.bb
@@ -10,8 +10,6 @@ PR = "${INC_PR}.0"
10 10
11COMPATIBLE_MACHINE = "dra7xx" 11COMPATIBLE_MACHINE = "dra7xx"
12 12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin" 13ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin"
16TARGET = "goodix_9271_cfg.bin" 14TARGET = "goodix_9271_cfg.bin"
17 15
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
index 2c0736ed..4b6ef75d 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
@@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
7 7
8COMPATIBLE_MACHINE = "am65xx-evm|am64xx" 8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12TARGET = " \ 10TARGET = " \
13 am65x-sr2-pru0-prueth-fw.elf \ 11 am65x-sr2-pru0-prueth-fw.elf \
14 am65x-sr2-pru1-prueth-fw.elf \ 12 am65x-sr2-pru1-prueth-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
index 8b15ab7f..20b2bfb9 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
@@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
7 7
8COMPATIBLE_MACHINE = "am65xx" 8COMPATIBLE_MACHINE = "am65xx"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12TARGET = " \ 10TARGET = " \
13 am65x-pru0-prueth-fw.elf \ 11 am65x-pru0-prueth-fw.elf \
14 am65x-pru1-prueth-fw.elf \ 12 am65x-pru1-prueth-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
index ea39d73d..bc731094 100644
--- a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
@@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
7 7
8COMPATIBLE_MACHINE = "am65xx-evm|am64xx" 8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12TARGET = " \ 10TARGET = " \
13 am65x-sr2-pru0-pruhsr-fw.elf \ 11 am65x-sr2-pru0-pruhsr-fw.elf \
14 am65x-sr2-pru1-pruhsr-fw.elf \ 12 am65x-sr2-pru1-pruhsr-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
index 63c2d311..6e296e7c 100644
--- a/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
+++ b/meta-ti-bsp/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb
@@ -7,8 +7,6 @@ PR = "${INC_PR}.0"
7 7
8COMPATIBLE_MACHINE = "am65xx-evm|am64xx" 8COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
9 9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12TARGET = " \ 10TARGET = " \
13 am65x-sr2-pru0-prusw-fw.elf \ 11 am65x-sr2-pru0-prusw-fw.elf \
14 am65x-sr2-pru1-prusw-fw.elf \ 12 am65x-sr2-pru1-prusw-fw.elf \
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
index d295a1c1..74729c16 100644
--- a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -9,8 +9,6 @@ PR = "${INC_PR}.0"
9 9
10COMPATIBLE_MACHINE = "j721e" 10COMPATIBLE_MACHINE = "j721e"
11 11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14TARGET = "pvdec_full_bin.fw" 12TARGET = "pvdec_full_bin.fw"
15 13
16do_install() { 14do_install() {
diff --git a/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb b/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
index 7d16ae39..4ec09a70 100644
--- a/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
+++ b/meta-ti-bsp/recipes-bsp/vis-fw/vis_01.50.07.15.bb
@@ -3,7 +3,6 @@ LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://${S}/J6_VIS_DEMO_LINUX_BINARY_01.50.07.15-Manifest.html;md5=a59aa54b9470f555cf086b91dca0afa3" 3LIC_FILES_CHKSUM = "file://${S}/J6_VIS_DEMO_LINUX_BINARY_01.50.07.15-Manifest.html;md5=a59aa54b9470f555cf086b91dca0afa3"
4 4
5COMPATIBLE_MACHINE = "dra7xx" 5COMPATIBLE_MACHINE = "dra7xx"
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7 6
8PR = "r1" 7PR = "r1"
9 8
diff --git a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
index 2452d111..8af49577 100644
--- a/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
+++ b/meta-ti-bsp/recipes-bsp/vpdma-fw/vpdma-fw_03-2012.bb
@@ -4,7 +4,6 @@ LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fd463c9500441ed91d07a0331baa635c" 4LIC_FILES_CHKSUM = "file://COPYING;md5=fd463c9500441ed91d07a0331baa635c"
5 5
6COMPATIBLE_MACHINE = "dra7xx" 6COMPATIBLE_MACHINE = "dra7xx"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8 7
9SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vpdma-fw/03-2012/exports/vpdma-fw_03-2012.tar.gz;protocol=http;name=dra7xx-evm" 8SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vpdma-fw/03-2012/exports/vpdma-fw_03-2012.tar.gz;protocol=http;name=dra7xx-evm"
10SRC_URI[dra7xx-evm.md5sum] = "80176df1350c21d9efa90171789c546e" 9SRC_URI[dra7xx-evm.md5sum] = "80176df1350c21d9efa90171789c546e"