summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Etheridge <detheridge@ti.com>2023-11-22 20:23:24 +0530
committerRyan Eatmon <reatmon@ti.com>2023-11-24 08:15:51 -0600
commit85729f84543774ff40afe05fc0220d8556c8f602 (patch)
tree895977424096c9a32b26f00be3c68c649043ca40
parentd3bcad2cbe63d4e1cd2b4e4418d0b3b9c1f864ed (diff)
downloadmeta-ti-85729f84543774ff40afe05fc0220d8556c8f602.tar.gz
mesa-pvr: use different srcrev for Rogue and SGX GPU platforms
A bug was introduced while trying to unify the Mesa version that is used on SGX GPU's and Rogue GPU's. It manifests itself as an immediate segfault whenever you try and run something like glmark2-es2-wayland or weston-simple-egl on certain Rogue based platforms (specifically am62x). Use different srcrev for Rogue GPU and SGX GPU platforms. The SGX GPU platforms will use the latest commit. Rogue GPU platforms will use the last good working commit before SGX related changes were introduced. This change will be reverted once the issue is rootcaused and a common solution is found for both Rogue and SGX based GPU platforms. Signed-off-by: Darren Etheridge <detheridge@ti.com> Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
index 98d30c5b..55dad414 100644
--- a/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
+++ b/meta-ti-bsp/recipes-graphics/mesa/mesa-pvr_22.3.5.bb
@@ -23,13 +23,17 @@ SRC_URI = " \
23 23
24S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
25 25
26SRCREV = "7c9522a4147836064f582278e4f7115735c16868"
27
28PACKAGECONFIG:append = " \ 26PACKAGECONFIG:append = " \
29 ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver', 'pvr', '', d)} \ 27 ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver', 'pvr', '', d)} \
30 ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \ 28 ${@bb.utils.contains('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-sgx-ddk-km', 'sgx', '', d)} \
31" 29"
32 30
31# Temporary work around to use a different SRCREV for SGX Mesa, vs Rogue Mesa
32# Idea is these two should be the same, but currently a segfault is happening
33# on certain platforms if the sgx commit is used.
34SRCREV = "${@bb.utils.contains('PACKAGECONFIG', 'sgx', '7c9522a4147836064f582278e4f7115735c16868', '54fd9d7dea098b6f11c2a244b0c6763dc8c5690c', d)}"
35PR = "sgxrgx-${SRCREV}"
36
33PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss" 37PVR_DISPLAY_CONTROLLER_ALIAS ??= "tidss"
34PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS}," 38PACKAGECONFIG[pvr] = "-Dgallium-pvr-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"
35PACKAGECONFIG[sgx] = "-Dgallium-sgx-alias=${PVR_DISPLAY_CONTROLLER_ALIAS}," 39PACKAGECONFIG[sgx] = "-Dgallium-sgx-alias=${PVR_DISPLAY_CONTROLLER_ALIAS},"