summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2022-05-04 15:11:22 -0500
committerRyan Eatmon <reatmon@ti.com>2022-05-04 16:45:50 -0500
commit4eff6e4232442a537e25a8ef8b2b592e6f714ffb (patch)
treee83fff970a6d4147542ea7105eff1735896fcca4
parent1bfa882a58530d570b494ab1d0204b9fe99b5a20 (diff)
downloadmeta-ti-4eff6e4232442a537e25a8ef8b2b592e6f714ffb.tar.gz
recipes-bsp: tifs-lpm-stub: Introduce new recipe
This firmware stub is required by the TI foundational security software while transitioning to low power mode. Add a recipe for this compatible with am62xx-evm Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/ti-linux-fw/ti-linux-fw.inc1
-rw-r--r--recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb24
-rw-r--r--recipes-kernel/linux/kernel-rdepends.inc4
3 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
index 3ebdae30..47e76347 100644
--- a/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+++ b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -18,6 +18,7 @@ GOODIX_FW_VERSION = "1.0.0.0"
18CADENCE_MHDP_FW_VERSION = "1.2.17" 18CADENCE_MHDP_FW_VERSION = "1.2.17"
19IMG_DEC_FW_VERSION = "1.0" 19IMG_DEC_FW_VERSION = "1.0"
20CNM_WAVE521_FW_VERSION = "1.0.00" 20CNM_WAVE521_FW_VERSION = "1.0.00"
21TIFS_LPM_STUB_FW_VERSION = "08.03.02"
21 22
22TI_LINUX_FW_SRCREV ?= "917625c2721eef8677df9e47d919005b0d4f93aa" 23TI_LINUX_FW_SRCREV ?= "917625c2721eef8677df9e47d919005b0d4f93aa"
23SRCREV = "${TI_LINUX_FW_SRCREV}" 24SRCREV = "${TI_LINUX_FW_SRCREV}"
diff --git a/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
new file mode 100644
index 00000000..642a8d3a
--- /dev/null
+++ b/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "TI Foundational security Low Power Management Stub"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${TIFS_LPM_STUB_FW_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am62xx-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = "ti-fs-stub-firmware-am62x-gp-signed.bin"
17
18do_install() {
19 install -d ${D}${base_libdir}/firmware/ti-sysfw/
20 install -m 0644 ${S}/ti-sysfw/${TARGET} ${D}${base_libdir}/firmware/ti-sysfw/${TARGET}
21}
22
23FILES_${PN} = "${base_libdir}/firmware"
24
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
index 522d9674..17aee4c2 100644
--- a/recipes-kernel/linux/kernel-rdepends.inc
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -45,3 +45,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw"
45 45
46# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs 46# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
47RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-evm = " cnm-wave-fw" 47RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-evm = " cnm-wave-fw"
48
49# Add run-time dependency for TIFS Low Power Module stub
50RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub"
51