summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2022-05-04 10:16:21 -0500
committerRyan Eatmon <reatmon@ti.com>2022-05-04 16:45:50 -0500
commit1bfa882a58530d570b494ab1d0204b9fe99b5a20 (patch)
tree8d2665f98560d5b6ddfd1d49821467b43aedeeb8
parent1b351e5a9be98d380768984f48ed5b5649323cc7 (diff)
downloadmeta-ti-1bfa882a58530d570b494ab1d0204b9fe99b5a20.tar.gz
uio-module-drv: Remove unneeded patch.
Now that we have moved to a newer version, this patch is no longer needed. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch35
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb2
2 files changed, 0 insertions, 37 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch b/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch
deleted file mode 100644
index 955ef558..00000000
--- a/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From b5c4036dac06817bffd0be21c5fa1b7f75f74e4b Mon Sep 17 00:00:00 2001
2From: Suman Anna <s-anna@ti.com>
3Date: Mon, 19 Apr 2021 13:15:51 -0500
4Subject: [PATCH] uio-module-drv: Replace ioremap_nocache with ioremap
5
6The ioremap_nocache is the same as the regular ioremap and its
7definition has been dropped from the Linux kernel v5.6 onwards in
8commit 4bdc0d676a64 ("remove ioremap_nocache and devm_ioremap_nocache")
9[1]. The uio-module-drv module fails to build against these newer
10kernels, so fix it by simply replacing ioremap_nocache with ioremap.
11
12[1]
13https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=4bdc0d676a643140bdf17dbf7eafedee3d496a3c
14
15Signed-off-by: Suman Anna <s-anna@ti.com>
16---
17 uio_module_drv.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/uio_module_drv.c b/uio_module_drv.c
21index 5a67dd199e21..7cc6005d1f05 100644
22--- a/uio_module_drv.c
23+++ b/uio_module_drv.c
24@@ -240,7 +240,7 @@ static ssize_t uio_module_drv_transfer(struct file *file, char __user *buf,
25 return -EINVAL;
26 }
27
28- virt_addr_p = ioremap_nocache(phys_addr, count);
29+ virt_addr_p = ioremap(phys_addr, count);
30 if (!virt_addr_p) {
31 dev_err(uio_module_drv->dev, "Mapping of virtual memory failed\n");
32 return(-ENOMEM);
33--
342.30.1
35
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index cb61305f..a97e23aa 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -4,8 +4,6 @@ include uio-module-drv.inc
4 4
5FILESEXTRAPATHS_prepend:= "${THISDIR}/${PN}:" 5FILESEXTRAPATHS_prepend:= "${THISDIR}/${PN}:"
6 6
7SRC_URI += "file://0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch"
8
9# This package builds a kernel module, use kernel PR as base and append a local 7# This package builds a kernel module, use kernel PR as base and append a local
10MACHINE_KERNEL_PR_append = "d" 8MACHINE_KERNEL_PR_append = "d"
11PR = "${MACHINE_KERNEL_PR}" 9PR = "${MACHINE_KERNEL_PR}"