summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2023-03-11 21:13:07 +0800
committerJoe MacDonald <joe@deserted.net>2023-03-27 09:34:02 -0400
commit4da226c5c5932c2d266160c00375faac8be6f6cb (patch)
treefdef481aa5c636f48819650abfaadaea0b6eb7c8
parent06ea8425ae6c672691593dcd0686b8f7ee82e1bb (diff)
downloadmeta-selinux-4da226c5c5932c2d266160c00375faac8be6f6cb.tar.gz
selinux-sandbox: upgrade 3.4 -> 3.5
License-Update: Rename COPYING to LICENSE. No content changes. * Drop backport patch. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/selinux/selinux-sandbox/0001-gettext-handle-unsupported-languages-properly.patch49
-rw-r--r--recipes-security/selinux/selinux-sandbox_3.5.bb (renamed from recipes-security/selinux/selinux-sandbox_3.4.bb)3
2 files changed, 1 insertions, 51 deletions
diff --git a/recipes-security/selinux/selinux-sandbox/0001-gettext-handle-unsupported-languages-properly.patch b/recipes-security/selinux/selinux-sandbox/0001-gettext-handle-unsupported-languages-properly.patch
deleted file mode 100644
index f1d8235..0000000
--- a/recipes-security/selinux/selinux-sandbox/0001-gettext-handle-unsupported-languages-properly.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From 70602601ac1cfc4399430ef8609b96fc224d1e25 Mon Sep 17 00:00:00 2001
2From: Vit Mojzis <vmojzis@redhat.com>
3Date: Fri, 24 Jun 2022 16:24:25 +0200
4Subject: [PATCH] gettext: handle unsupported languages properly
5
6With "fallback=True" gettext.translation behaves the same as
7gettext.install and uses NullTranslations in case the
8translation file for given language was not found (as opposed to
9throwing an exception).
10
11Fixes:
12 # LANG is set to any "unsupported" language, e.g. en_US.UTF-8
13 $ chcat --help
14 Traceback (most recent call last):
15 File "/usr/bin/chcat", line 39, in <module>
16 t = gettext.translation(PROGNAME,
17 File "/usr/lib64/python3.9/gettext.py", line 592, in translation
18 raise FileNotFoundError(ENOENT,
19 FileNotFoundError: [Errno 2] No translation file found for domain: 'selinux-python'
20
21Signed-off-by: Vit Mojzis <vmojzis@redhat.com>
22Reviewed-by: Daniel Burgener <dburgener@linux.microsoft.com>
23Acked-by: Petr Lautrbach <plautrba@redhat.com>
24
25Upstream-Status: Backport
26[https://github.com/SELinuxProject/selinux/commit/344463076b2a91e1d2c7f5cc3835dc1a53a05e88]
27
28Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
29---
30 sandbox | 3 ++-
31 1 file changed, 2 insertions(+), 1 deletion(-)
32
33diff --git a/sandbox b/sandbox
34index cd5709f..789621e 100644
35--- a/sandbox
36+++ b/sandbox
37@@ -45,7 +45,8 @@ try:
38 kwargs['unicode'] = True
39 t = gettext.translation(PROGNAME,
40 localedir="/usr/share/locale",
41- **kwargs)
42+ **kwargs,
43+ fallback=True)
44 _ = t.gettext
45 except:
46 try:
47--
482.25.1
49
diff --git a/recipes-security/selinux/selinux-sandbox_3.4.bb b/recipes-security/selinux/selinux-sandbox_3.5.bb
index a5a8e13..2cb55d6 100644
--- a/recipes-security/selinux/selinux-sandbox_3.4.bb
+++ b/recipes-security/selinux/selinux-sandbox_3.5.bb
@@ -5,12 +5,11 @@ sandbox domain only allows applications the ability to read and write \
5stdin, stdout and any other file descriptors handed to it." 5stdin, stdout and any other file descriptors handed to it."
6SECTION = "base" 6SECTION = "base"
7LICENSE = "GPL-2.0-or-later" 7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=393a5ca445f6965873eca0259a17f833" 8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=393a5ca445f6965873eca0259a17f833"
9 9
10require selinux_common.inc 10require selinux_common.inc
11 11
12SRC_URI += "file://sandbox-de-bashify.patch \ 12SRC_URI += "file://sandbox-de-bashify.patch \
13 file://0001-gettext-handle-unsupported-languages-properly.patch \
14 " 13 "
15 14
16S = "${WORKDIR}/git/sandbox" 15S = "${WORKDIR}/git/sandbox"