summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2023-03-11 21:13:06 +0800
committerJoe MacDonald <joe@deserted.net>2023-03-27 09:34:02 -0400
commit06ea8425ae6c672691593dcd0686b8f7ee82e1bb (patch)
treeba810f6223b80d5ac9795721be0025ba9657ec7c
parent64be33c89e33441ac56bfc7226abf63040f090e7 (diff)
downloadmeta-selinux-06ea8425ae6c672691593dcd0686b8f7ee82e1bb.tar.gz
selinux-gui: upgrade 3.4 -> 3.5
License-Update: Rename COPYING to LICENSE. No content changes. * Drop backport patch. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--recipes-security/selinux/selinux-gui/0001-gettext-handle-unsupported-languages-properly.patch199
-rw-r--r--recipes-security/selinux/selinux-gui_3.5.bb (renamed from recipes-security/selinux/selinux-gui_3.4.bb)4
2 files changed, 1 insertions, 202 deletions
diff --git a/recipes-security/selinux/selinux-gui/0001-gettext-handle-unsupported-languages-properly.patch b/recipes-security/selinux/selinux-gui/0001-gettext-handle-unsupported-languages-properly.patch
deleted file mode 100644
index d79db22..0000000
--- a/recipes-security/selinux/selinux-gui/0001-gettext-handle-unsupported-languages-properly.patch
+++ /dev/null
@@ -1,199 +0,0 @@
1From a0a67119412622141a7f8365eff10de6395be7ca Mon Sep 17 00:00:00 2001
2From: Vit Mojzis <vmojzis@redhat.com>
3Date: Fri, 24 Jun 2022 16:24:25 +0200
4Subject: [PATCH] gettext: handle unsupported languages properly
5
6With "fallback=True" gettext.translation behaves the same as
7gettext.install and uses NullTranslations in case the
8translation file for given language was not found (as opposed to
9throwing an exception).
10
11Fixes:
12 # LANG is set to any "unsupported" language, e.g. en_US.UTF-8
13 $ chcat --help
14 Traceback (most recent call last):
15 File "/usr/bin/chcat", line 39, in <module>
16 t = gettext.translation(PROGNAME,
17 File "/usr/lib64/python3.9/gettext.py", line 592, in translation
18 raise FileNotFoundError(ENOENT,
19 FileNotFoundError: [Errno 2] No translation file found for domain: 'selinux-python'
20
21Signed-off-by: Vit Mojzis <vmojzis@redhat.com>
22Reviewed-by: Daniel Burgener <dburgener@linux.microsoft.com>
23Acked-by: Petr Lautrbach <plautrba@redhat.com>
24
25Upstream-Status: Backport
26[https://github.com/SELinuxProject/selinux/commit/344463076b2a91e1d2c7f5cc3835dc1a53a05e88]
27
28Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
29---
30 booleansPage.py | 3 ++-
31 domainsPage.py | 3 ++-
32 fcontextPage.py | 3 ++-
33 loginsPage.py | 3 ++-
34 modulesPage.py | 3 ++-
35 polgengui.py | 3 ++-
36 portsPage.py | 3 ++-
37 semanagePage.py | 3 ++-
38 statusPage.py | 3 ++-
39 system-config-selinux.py | 3 ++-
40 usersPage.py | 3 ++-
41 11 files changed, 22 insertions(+), 11 deletions(-)
42
43diff --git a/booleansPage.py b/booleansPage.py
44index 5beec58..ad11a9b 100644
45--- a/booleansPage.py
46+++ b/booleansPage.py
47@@ -46,7 +46,8 @@ try:
48 kwargs['unicode'] = True
49 t = gettext.translation(PROGNAME,
50 localedir="/usr/share/locale",
51- **kwargs)
52+ **kwargs,
53+ fallback=True)
54 _ = t.gettext
55 except:
56 try:
57diff --git a/domainsPage.py b/domainsPage.py
58index e08f34b..e6eadd6 100644
59--- a/domainsPage.py
60+++ b/domainsPage.py
61@@ -38,7 +38,8 @@ try:
62 kwargs['unicode'] = True
63 t = gettext.translation(PROGNAME,
64 localedir="/usr/share/locale",
65- **kwargs)
66+ **kwargs,
67+ fallback=True)
68 _ = t.gettext
69 except:
70 try:
71diff --git a/fcontextPage.py b/fcontextPage.py
72index bac2bec..767664f 100644
73--- a/fcontextPage.py
74+++ b/fcontextPage.py
75@@ -55,7 +55,8 @@ try:
76 kwargs['unicode'] = True
77 t = gettext.translation(PROGNAME,
78 localedir="/usr/share/locale",
79- **kwargs)
80+ **kwargs,
81+ fallback=True)
82 _ = t.gettext
83 except:
84 try:
85diff --git a/loginsPage.py b/loginsPage.py
86index 18b93d8..7e08232 100644
87--- a/loginsPage.py
88+++ b/loginsPage.py
89@@ -37,7 +37,8 @@ try:
90 kwargs['unicode'] = True
91 t = gettext.translation(PROGNAME,
92 localedir="/usr/share/locale",
93- **kwargs)
94+ **kwargs,
95+ fallback=True)
96 _ = t.gettext
97 except:
98 try:
99diff --git a/modulesPage.py b/modulesPage.py
100index c546d45..02b79f1 100644
101--- a/modulesPage.py
102+++ b/modulesPage.py
103@@ -38,7 +38,8 @@ try:
104 kwargs['unicode'] = True
105 t = gettext.translation(PROGNAME,
106 localedir="/usr/share/locale",
107- **kwargs)
108+ **kwargs,
109+ fallback=True)
110 _ = t.gettext
111 except:
112 try:
113diff --git a/polgengui.py b/polgengui.py
114index a18f1cb..7a3ecd5 100644
115--- a/polgengui.py
116+++ b/polgengui.py
117@@ -71,7 +71,8 @@ try:
118 kwargs['unicode'] = True
119 t = gettext.translation(PROGNAME,
120 localedir="/usr/share/locale",
121- **kwargs)
122+ **kwargs,
123+ fallback=True)
124 _ = t.gettext
125 except:
126 try:
127diff --git a/portsPage.py b/portsPage.py
128index 54aa80d..bee2bdf 100644
129--- a/portsPage.py
130+++ b/portsPage.py
131@@ -43,7 +43,8 @@ try:
132 kwargs['unicode'] = True
133 t = gettext.translation(PROGNAME,
134 localedir="/usr/share/locale",
135- **kwargs)
136+ **kwargs,
137+ fallback=True)
138 _ = t.gettext
139 except:
140 try:
141diff --git a/semanagePage.py b/semanagePage.py
142index 1371d4e..efad14d 100644
143--- a/semanagePage.py
144+++ b/semanagePage.py
145@@ -30,7 +30,8 @@ try:
146 kwargs['unicode'] = True
147 t = gettext.translation(PROGNAME,
148 localedir="/usr/share/locale",
149- **kwargs)
150+ **kwargs,
151+ fallback=True)
152 _ = t.gettext
153 except:
154 try:
155diff --git a/statusPage.py b/statusPage.py
156index c241ef8..832849e 100644
157--- a/statusPage.py
158+++ b/statusPage.py
159@@ -43,7 +43,8 @@ try:
160 kwargs['unicode'] = True
161 t = gettext.translation(PROGNAME,
162 localedir="/usr/share/locale",
163- **kwargs)
164+ **kwargs,
165+ fallback=True)
166 _ = t.gettext
167 except:
168 try:
169diff --git a/system-config-selinux.py b/system-config-selinux.py
170index 1b460c9..9f53b7f 100644
171--- a/system-config-selinux.py
172+++ b/system-config-selinux.py
173@@ -53,7 +53,8 @@ try:
174 kwargs['unicode'] = True
175 t = gettext.translation(PROGNAME,
176 localedir="/usr/share/locale",
177- **kwargs)
178+ **kwargs,
179+ fallback=True)
180 _ = t.gettext
181 except:
182 try:
183diff --git a/usersPage.py b/usersPage.py
184index d51bd96..9acd3b8 100644
185--- a/usersPage.py
186+++ b/usersPage.py
187@@ -37,7 +37,8 @@ try:
188 kwargs['unicode'] = True
189 t = gettext.translation(PROGNAME,
190 localedir="/usr/share/locale",
191- **kwargs)
192+ **kwargs,
193+ fallback=True)
194 _ = t.gettext
195 except:
196 try:
197--
1982.25.1
199
diff --git a/recipes-security/selinux/selinux-gui_3.4.bb b/recipes-security/selinux/selinux-gui_3.5.bb
index fa80860..fbd5e70 100644
--- a/recipes-security/selinux/selinux-gui_3.4.bb
+++ b/recipes-security/selinux/selinux-gui_3.5.bb
@@ -4,12 +4,10 @@ Provide SELinux Management tool (system-config-selinux) and SELinux \
4Policy Generation Tool (selinux-polgengui)" 4Policy Generation Tool (selinux-polgengui)"
5SECTION = "base" 5SECTION = "base"
6LICENSE = "GPL-2.0-or-later" 6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=393a5ca445f6965873eca0259a17f833" 7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=393a5ca445f6965873eca0259a17f833"
8 8
9require selinux_common.inc 9require selinux_common.inc
10 10
11SRC_URI += "file://0001-gettext-handle-unsupported-languages-properly.patch"
12
13S = "${WORKDIR}/git/gui" 11S = "${WORKDIR}/git/gui"
14 12
15DEPENDS = "gettext-native" 13DEPENDS = "gettext-native"