summaryrefslogtreecommitdiffstats
path: root/recipes-security/bastille
diff options
context:
space:
mode:
authormulhern <mulhern@yoctoproject.org>2013-08-25 16:17:49 -0400
committermulhern <mulhern@yoctoproject.org>2013-08-30 15:31:28 -0400
commit7672e9a8a2502ebb851d5a170cb37e1a70578188 (patch)
treebbb3c4d9b53b5ed4d47420a7a604b73da7b4cf89 /recipes-security/bastille
parent7654815dbf81de12493a02063a02c9ee7792b939 (diff)
downloadmeta-security-7672e9a8a2502ebb851d5a170cb37e1a70578188.tar.gz
Bastille: Miscellaneous fixes to the Bastille code base.
[YOCTO #3867] Adds four additional small patches which address miscellaneous small problems in Bastille. The four patches are: fix_missing_use_directives.patch: A number of use directives were missing from several files. These were added as discovered. fix_number_of_modules.patch: The curses interface includes a title for most screens which gives a module, a module number, and the number of modules in the series. Previously the last value was always 0, now it is simply omitted. It would be more desirable to give the correct number, but this would require a significant change to the code base. remove_questions_text_file_references.patch: This version of Bastille does not make use of a Questions.txt file, therefore the specification of the location of this file in the OSMap/*.bastille files has been removed. simplify_B_place.patch: This patch discards redundant variables, mostly defined but not used cases, and makes the error reporting more informative. Signed-off-by: mulhern <mulhern@yoctoproject.org>
Diffstat (limited to 'recipes-security/bastille')
-rw-r--r--recipes-security/bastille/bastille_3.2.1.bb4
-rw-r--r--recipes-security/bastille/files/fix_missing_use_directives.patch54
-rw-r--r--recipes-security/bastille/files/fix_number_of_modules.patch38
-rw-r--r--recipes-security/bastille/files/remove_questions_text_file_references.patch30
-rw-r--r--recipes-security/bastille/files/simplify_B_place.patch40
5 files changed, 166 insertions, 0 deletions
diff --git a/recipes-security/bastille/bastille_3.2.1.bb b/recipes-security/bastille/bastille_3.2.1.bb
index 1af7b34..0165a4e 100644
--- a/recipes-security/bastille/bastille_3.2.1.bb
+++ b/recipes-security/bastille/bastille_3.2.1.bb
@@ -19,6 +19,10 @@ SRC_URI = "http://sourceforge.net/projects/bastille-linux/files/bastille-linux/3
19 file://fix_version_parse.patch \ 19 file://fix_version_parse.patch \
20 file://fixed_defined_warnings.patch \ 20 file://fixed_defined_warnings.patch \
21 file://call_output_config.patch \ 21 file://call_output_config.patch \
22 file://fix_missing_use_directives.patch \
23 file://fix_number_of_modules.patch \
24 file://remove_questions_text_file_references.patch \
25 file://simplify_B_place.patch \
22 " 26 "
23 27
24SRC_URI[md5sum] = "df803f7e38085aa5da79f85d0539f91b" 28SRC_URI[md5sum] = "df803f7e38085aa5da79f85d0539f91b"
diff --git a/recipes-security/bastille/files/fix_missing_use_directives.patch b/recipes-security/bastille/files/fix_missing_use_directives.patch
new file mode 100644
index 0000000..05f145a
--- /dev/null
+++ b/recipes-security/bastille/files/fix_missing_use_directives.patch
@@ -0,0 +1,54 @@
1Upstream Status: Inappropriate [No upstream maintenance]
2
3Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
4
5---
6
7Index: Bastille/Bastille/Firewall.pm
8===================================================================
9--- Bastille.orig/Bastille/Firewall.pm 2008-09-14 19:56:54.000000000 -0400
10+++ Bastille/Bastille/Firewall.pm 2013-08-20 16:28:44.588378000 -0400
11@@ -21,6 +21,7 @@
12 package Bastille::Firewall;
13
14 use Bastille::API;
15+use Bastille::API::AccountPermission;
16 use Bastille::API::FileContent;
17 use Bastille::API::ServiceAdmin;
18
19Index: Bastille/Bastille/SecureInetd.pm
20===================================================================
21--- Bastille.orig/Bastille/SecureInetd.pm 2008-09-14 19:56:58.000000000 -0400
22+++ Bastille/Bastille/SecureInetd.pm 2013-08-20 16:45:02.252378001 -0400
23@@ -12,6 +12,7 @@
24 use lib "/usr/lib";
25
26 use Bastille::API;
27+use Bastille::API::AccountPermission;
28 use Bastille::API::HPSpecific;
29 use Bastille::API::ServiceAdmin;
30 use Bastille::API::FileContent;
31Index: Bastille/Bastille/ConfigureMiscPAM.pm
32===================================================================
33--- Bastille.orig/Bastille/ConfigureMiscPAM.pm 2005-09-12 23:47:28.000000000 -0400
34+++ Bastille/Bastille/ConfigureMiscPAM.pm 2013-08-20 18:36:07.340378001 -0400
35@@ -5,6 +5,7 @@
36 use lib "/usr/lib";
37
38 use Bastille::API;
39+use Bastille::API::FileContent;
40
41 # To DO:
42 #
43Index: Bastille/Bastille/Printing.pm
44===================================================================
45--- Bastille.orig/Bastille/Printing.pm 2008-09-14 19:56:58.000000000 -0400
46+++ Bastille/Bastille/Printing.pm 2013-08-20 19:05:01.532378002 -0400
47@@ -5,6 +5,7 @@
48 use lib "/usr/lib";
49
50 use Bastille::API;
51+use Bastille::API::AccountPermission;
52 use Bastille::API::HPSpecific;
53 use Bastille::API::ServiceAdmin;
54 use Bastille::API::FileContent;
diff --git a/recipes-security/bastille/files/fix_number_of_modules.patch b/recipes-security/bastille/files/fix_number_of_modules.patch
new file mode 100644
index 0000000..743e549
--- /dev/null
+++ b/recipes-security/bastille/files/fix_number_of_modules.patch
@@ -0,0 +1,38 @@
1Upstream Status: Inappropriate [No upstream maintenance]
2
3Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
4
5---
6
7Index: Bastille/Bastille_Curses.pm
8===================================================================
9--- Bastille.orig/Bastille_Curses.pm 2013-08-24 18:21:54.445288000 -0400
10+++ Bastille/Bastille_Curses.pm 2013-08-24 18:29:16.981288000 -0400
11@@ -36,9 +36,6 @@
12 use Curses;
13 use Curses::Widgets;
14
15- # Number_Modules is the number of modules loaded in by Load_Questions
16- $Number_Modules=0;
17-
18 #
19 # Highlighted button is the button currently chosen in the button bar
20 # We preserve this from question to question...
21@@ -397,7 +394,7 @@
22 my $title;
23
24 if ($module) {
25- $title=$module . " of $Number_Modules";
26+ $title=$module;
27 }
28
29 txt_field( 'window' => $window,
30@@ -488,7 +485,7 @@
31 my $title;
32
33 if ($module) {
34- $title=$module . " of $Number_Modules";
35+ $title=$module;
36 }
37
38 noecho;
diff --git a/recipes-security/bastille/files/remove_questions_text_file_references.patch b/recipes-security/bastille/files/remove_questions_text_file_references.patch
new file mode 100644
index 0000000..bd094ee
--- /dev/null
+++ b/recipes-security/bastille/files/remove_questions_text_file_references.patch
@@ -0,0 +1,30 @@
1Upstream Status: Inappropriate [No upstream maintenance]
2
3Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
4
5---
6
7Index: Bastille/OSMap/LINUX.bastille
8===================================================================
9--- Bastille.orig/OSMap/LINUX.bastille 2008-01-25 18:31:35.000000000 -0500
10+++ Bastille/OSMap/LINUX.bastille 2013-08-22 04:48:32.677968002 -0400
11@@ -12,7 +12,6 @@
12
13 bfile,InteractiveBastille,'/usr/sbin/InteractiveBastille'
14 bfile,BastilleBackEnd,'/usr/sbin/BastilleBackEnd'
15-bfile,Questions,'/usr/share/Bastille/Questions.txt'
16 bfile,QuestionsModules,'/usr/share/Bastille/Modules.txt'
17 bfile,TODO,'/var/log/Bastille/TODO'
18 bfile,TODOFlag,'/var/log/Bastille/TODOFlag.txt'
19Index: Bastille/OSMap/OSX.bastille
20===================================================================
21--- Bastille.orig/OSMap/OSX.bastille 2007-09-11 18:09:26.000000000 -0400
22+++ Bastille/OSMap/OSX.bastille 2013-08-22 04:48:47.245968001 -0400
23@@ -10,7 +10,6 @@
24 bdir,share,'/usr/share/Bastille'
25
26 bfile,BastilleBackEnd,'/var/root/Bastille/BastilleBackEnd'
27-bfile,Questions,'/usr/share/Bastille/Questions.txt'
28 bfile,QuestionsModules,'/usr/share/Bastille/Modules.txt'
29 bfile,TODO,'/var/log/Bastille/TODO'
30 bfile,TODOFlag,'/var/log/Bastille/TODOFlag.txt'
diff --git a/recipes-security/bastille/files/simplify_B_place.patch b/recipes-security/bastille/files/simplify_B_place.patch
new file mode 100644
index 0000000..307fdca
--- /dev/null
+++ b/recipes-security/bastille/files/simplify_B_place.patch
@@ -0,0 +1,40 @@
1Upstream Status: Inappropriate [No upstream maintenance]
2
3Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
4
5---
6
7Index: Bastille/Bastille/API.pm
8===================================================================
9--- Bastille.orig/Bastille/API.pm 2013-08-21 08:59:17.939950001 -0400
10+++ Bastille/Bastille/API.pm 2013-08-21 08:59:30.983950001 -0400
11@@ -1679,24 +1679,22 @@
12
13 use File::Copy;
14
15- my $original_source=$source;
16 $source = &getGlobal('BDIR', "share") . $source;
17- my $original_target=$target;
18
19 if ( -e $target and -f $target ) {
20- &B_backup_file($original_target);
21- &B_log("ACTION","About to copy $original_source to $original_target -- had to backup target\n");
22+ &B_backup_file($target);
23+ &B_log("ACTION","About to copy $source to $target -- had to backup target\n");
24 $had_to_backup_target=1;
25 }
26 $retval=copy($source,$target);
27 if ($retval) {
28- &B_log("ACTION","placed file $original_source as $original_target\n");
29+ &B_log("ACTION","placed file $source as $target\n");
30 #
31 # We want to add a line to the &getGlobal('BFILE', "created-files") so that the
32 # file we just put at $original_target gets deleted.
33- &B_revert_log(&getGlobal('BIN',"rm") . " $original_target\n");
34+ &B_revert_log(&getGlobal('BIN',"rm") . " $target\n");
35 } else {
36- &B_log("ERROR","Failed to place $original_source as $original_target\n");
37+ &B_log("ERROR","Failed to place $source as $target\n");
38 }
39
40 # We add the file to the GLOBAL_SUMS hash if it is not already present