summaryrefslogtreecommitdiffstats
path: root/recipes-security/bastille
diff options
context:
space:
mode:
authormulhern <mulhern@yoctoproject.org>2013-08-25 15:28:48 -0400
committermulhern <mulhern@yoctoproject.org>2013-08-30 15:29:48 -0400
commit7654815dbf81de12493a02063a02c9ee7792b939 (patch)
tree0ae8f615b22558e41203d73ca40d773015d32123 /recipes-security/bastille
parent600a74468bf6d2e2f865e7d7c70e68c60c829234 (diff)
downloadmeta-security-7654815dbf81de12493a02063a02c9ee7792b939.tar.gz
Bastille: Preliminary cleanup of existing patches.
[YOCTO #3867] Renames existing patches and removes some changes. Curses-and-IOLoader-changes.patch is renamed to call_output_config.patch. The new patch omits the removal of the pruning step in Load_Questions but retains the replacement of a call to a non-existant function with a call to an appropriate implemented function. yocto-standard-patch.patch is renamed to fixed_defined_warnings.patch. The new patch omits the definition of a yocto distro but includes the defined warnings fix. The recipe file is changed to include the new patches and also to omit a related action in the do_install script. Signed-off-by: mulhern <mulhern@yoctoproject.org>
Diffstat (limited to 'recipes-security/bastille')
-rw-r--r--recipes-security/bastille/bastille_3.2.1.bb5
-rw-r--r--recipes-security/bastille/files/Curses-and-IOLoader-changes.patch50
-rw-r--r--recipes-security/bastille/files/call_output_config.patch19
-rw-r--r--recipes-security/bastille/files/fix_version_parse.patch6
-rw-r--r--recipes-security/bastille/files/fixed_defined_warnings.patch (renamed from recipes-security/bastille/files/yocto-standard-patch.patch)37
5 files changed, 42 insertions, 75 deletions
diff --git a/recipes-security/bastille/bastille_3.2.1.bb b/recipes-security/bastille/bastille_3.2.1.bb
index 008f305..1af7b34 100644
--- a/recipes-security/bastille/bastille_3.2.1.bb
+++ b/recipes-security/bastille/bastille_3.2.1.bb
@@ -17,8 +17,8 @@ SRC_URI = "http://sourceforge.net/projects/bastille-linux/files/bastille-linux/3
17 file://ServiceAdmin.pm \ 17 file://ServiceAdmin.pm \
18 file://config \ 18 file://config \
19 file://fix_version_parse.patch \ 19 file://fix_version_parse.patch \
20 file://yocto-standard-patch.patch \ 20 file://fixed_defined_warnings.patch \
21 file://Curses-and-IOLoader-changes.patch \ 21 file://call_output_config.patch \
22 " 22 "
23 23
24SRC_URI[md5sum] = "df803f7e38085aa5da79f85d0539f91b" 24SRC_URI[md5sum] = "df803f7e38085aa5da79f85d0539f91b"
@@ -136,7 +136,6 @@ do_install () {
136 done 136 done
137 137
138 ln -s ${D}${sbindir}/RevertBastille ${D}${sbindir}/UndoBastille 138 ln -s ${D}${sbindir}/RevertBastille ${D}${sbindir}/UndoBastille
139 sed -i 's/3.8.11-yocto-standard/${KERNEL_VERSION}/g' ${D}${libdir}/Bastille/API.pm
140} 139}
141 140
142FILES_${PN} += "${datadir}/Bastille ${libdir}/Bastille ${libdir}/perl* ${sysconfdir}/*" 141FILES_${PN} += "${datadir}/Bastille ${libdir}/Bastille ${libdir}/perl* ${sysconfdir}/*"
diff --git a/recipes-security/bastille/files/Curses-and-IOLoader-changes.patch b/recipes-security/bastille/files/Curses-and-IOLoader-changes.patch
deleted file mode 100644
index dfe0698..0000000
--- a/recipes-security/bastille/files/Curses-and-IOLoader-changes.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From afa9a32db7f9423b45e0cff898a868de05ad3dee Mon Sep 17 00:00:00 2001
2From: Andrei Dinu <andrei.adrianx.dinu@intel.com>
3Date: Tue, 30 Jul 2013 12:05:39 +0300
4Subject: [PATCH] Curses and IOLoader changes
5
6The linux distribution couldn't be identified when
7running Bastille, and the question pruning method
8couldn't get a match on the questions relevant to
9the repo, so it eliminated all questions.
10
11After answering the questions the checkAndSaveConfig routine
12was called which was missing. Replaced it with outputConfig
13which exists.
14
15Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
16---
17 Bastille/IOLoader.pm | 2 +-
18 Bastille_Curses.pm | 3 ++-
19 2 files changed, 3 insertions(+), 2 deletions(-)
20
21diff --git a/Bastille/IOLoader.pm b/Bastille/IOLoader.pm
22index abb94d7..995d2c2 100644
23--- a/Bastille/IOLoader.pm
24+++ b/Bastille/IOLoader.pm
25@@ -68,7 +68,7 @@ sub Load_Questions($) {
26 my $UseRequiresRules = $_[0];
27
28 my ($current_module_number,$first_question) = &parse_questions();
29- $first_question = &prune_questions($UseRequiresRules,$first_question);
30+ #$first_question = &prune_questions($UseRequiresRules,$first_question);
31 $firstQuestion = $first_question;
32 &B_log("DEBUG","Load Questions, first question: $first_question");
33 &validate_questions();
34diff --git a/Bastille_Curses.pm b/Bastille_Curses.pm
35index 2e1eef4..a2dfb34 100644
36--- a/Bastille_Curses.pm
37+++ b/Bastille_Curses.pm
38@@ -84,7 +84,8 @@ sub do_Bastille {
39 }
40
41 # Output answers to the script and display
42- &checkAndSaveConfig(&getGlobal('BFILE', "config"));
43+
44+ &outputConfig
45
46 # Run Bastille
47
48--
491.7.9.5
50
diff --git a/recipes-security/bastille/files/call_output_config.patch b/recipes-security/bastille/files/call_output_config.patch
new file mode 100644
index 0000000..1e898b1
--- /dev/null
+++ b/recipes-security/bastille/files/call_output_config.patch
@@ -0,0 +1,19 @@
1Upstream Status: Inappropriate [No upstream maintenance]
2
3Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
4
5---
6
7Index: Bastille/Bastille_Curses.pm
8===================================================================
9--- Bastille.orig/Bastille_Curses.pm 2013-08-21 08:58:53.899950000 -0400
10+++ Bastille/Bastille_Curses.pm 2013-08-21 09:20:20.295950005 -0400
11@@ -84,7 +84,7 @@
12 }
13
14 # Output answers to the script and display
15- &checkAndSaveConfig(&getGlobal('BFILE', "config"));
16+ &outputConfig;
17
18 # Run Bastille
19
diff --git a/recipes-security/bastille/files/fix_version_parse.patch b/recipes-security/bastille/files/fix_version_parse.patch
index 3163af1..5923c04 100644
--- a/recipes-security/bastille/files/fix_version_parse.patch
+++ b/recipes-security/bastille/files/fix_version_parse.patch
@@ -1,3 +1,9 @@
1Upstream Status: Inappropriate [No upstream maintenance]
2
3Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
4
5---
6
1Index: Bastille/bin/bastille 7Index: Bastille/bin/bastille
2=================================================================== 8===================================================================
3--- Bastille.orig/bin/bastille 9--- Bastille.orig/bin/bastille
diff --git a/recipes-security/bastille/files/yocto-standard-patch.patch b/recipes-security/bastille/files/fixed_defined_warnings.patch
index 4f78a3b..e7996e3 100644
--- a/recipes-security/bastille/files/yocto-standard-patch.patch
+++ b/recipes-security/bastille/files/fixed_defined_warnings.patch
@@ -11,36 +11,32 @@ in Bastille.
11Fixed also some warnings regarding defined statements 11Fixed also some warnings regarding defined statements
12in API.pm. 12in API.pm.
13 13
14Upstream Status: Inappropriate [No upstream maintenance]
15
14Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com> 16Signed-off-by: Andrei Dinu <andrei.adrianx.dinu@intel.com>
17
18Signed-off-by: Anne Mulhern <mulhern@yoctoproject.org>
19
15--- 20---
16 Bastille/API.pm | 12 ++++++------ 21 Bastille/API.pm | 12 ++++++------
17 1 file changed, 6 insertions(+), 6 deletions(-) 22 1 file changed, 6 insertions(+), 6 deletions(-)
18 23
19diff --git a/Bastille/API.pm b/Bastille/API.pm 24Index: Bastille/Bastille/API.pm
20index 40f8c72..ebbe9f7 100644 25===================================================================
21--- a/Bastille/API.pm 26--- Bastille.orig/Bastille/API.pm 2008-09-14 19:56:53.000000000 -0400
22+++ b/Bastille/API.pm 27+++ Bastille/Bastille/API.pm 2013-08-21 08:55:26.715950001 -0400
23@@ -445,8 +445,8 @@ sub GetDistro() { 28@@ -445,8 +445,8 @@
24 $release=`/usr/bin/uname -sr`; 29 $release=`/usr/bin/uname -sr`;
25 } 30 }
26 else { 31 else {
27- print STDERR "$err Could not determine operating system version!\n"; 32- print STDERR "$err Could not determine operating system version!\n";
28- $distro="unknown"; 33- $distro="unknown";
29+ #print STDERR "$err Could not determine operating system version!\n"; 34+ print STDERR "$err Could not determine operating system version!\n";
30+ $distro="3.8.11-yocto-standard"; 35+ $distro="unknown"
31 } 36 }
32 37
33 # Figure out what kind of system we're on. 38 # Figure out what kind of system we're on.
34@@ -537,7 +537,7 @@ sub getSupportedOSHash () { 39@@ -1284,7 +1284,7 @@
35 "DB2.2", "DB3.0",
36 "RH6.0","RH6.1","RH6.2","RH7.0",
37 "RH7.1","RH7.2","RH7.3","RH8.0",
38- "RH9",
39+ "RH9","3.8.11-yocto-standard",
40 "RHEL5",
41 "RHEL4AS","RHEL4ES","RHEL4WS",
42 "RHEL3AS","RHEL3ES","RHEL3WS",
43@@ -1284,7 +1284,7 @@ sub B_write_sums {
44 40
45 my $sumFile = &getGlobal('BFILE',"sum.csv"); 41 my $sumFile = &getGlobal('BFILE',"sum.csv");
46 42
@@ -49,7 +45,7 @@ index 40f8c72..ebbe9f7 100644
49 45
50 open( SUM, "> $sumFile") or &B_log("ERROR","Unable to open $sumFile for write.\n$!\n"); 46 open( SUM, "> $sumFile") or &B_log("ERROR","Unable to open $sumFile for write.\n$!\n");
51 47
52@@ -1318,7 +1318,7 @@ sub B_check_sum($) { 48@@ -1318,7 +1318,7 @@
53 my $file = $_[0]; 49 my $file = $_[0];
54 my $cksum = &getGlobal('BIN',"cksum"); 50 my $cksum = &getGlobal('BIN',"cksum");
55 51
@@ -58,7 +54,7 @@ index 40f8c72..ebbe9f7 100644
58 &B_read_sums; 54 &B_read_sums;
59 } 55 }
60 56
61@@ -1375,7 +1375,7 @@ sub listModifiedFiles { 57@@ -1375,7 +1375,7 @@
62 sub B_isFileinSumDB($) { 58 sub B_isFileinSumDB($) {
63 my $file = $_[0]; 59 my $file = $_[0];
64 60
@@ -67,6 +63,3 @@ index 40f8c72..ebbe9f7 100644
67 &B_log("DEBUG","Reading in DB from B_isFileinSumDB"); 63 &B_log("DEBUG","Reading in DB from B_isFileinSumDB");
68 &B_read_sums; 64 &B_read_sums;
69 } 65 }
70--
711.7.9.5
72