summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2022-07-31 10:59:45 -0700
committerArmin Kuster <akuster808@gmail.com>2022-08-02 13:45:26 -0700
commit4e0ba84530922aa1a4f0d8ac3e313950ac40e152 (patch)
tree8f5267e1fcec3b592e35b540ff389968ddadb856 /recipes-kernel
parent8a90b05e727ff4e248a87621c5f6a7a44047f1d4 (diff)
downloadmeta-security-4e0ba84530922aa1a4f0d8ac3e313950ac40e152.tar.gz
lkrg: update to 0.9.4
drop Makefile fixup patch. Use sed instead LIC_FILES_CHKSUM update do to yr update Signed-off-by: Armin Kuster <akuster808@gmail.com> --- V2] Add LIC_FILES_CHKSUM change reason
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/lkrg/files/makefile_cleanup.patch53
-rw-r--r--recipes-kernel/lkrg/lkrg-module_0.9.4.bb (renamed from recipes-kernel/lkrg/lkrg-module_0.9.3.bb)16
2 files changed, 10 insertions, 59 deletions
diff --git a/recipes-kernel/lkrg/files/makefile_cleanup.patch b/recipes-kernel/lkrg/files/makefile_cleanup.patch
deleted file mode 100644
index f29afbe..0000000
--- a/recipes-kernel/lkrg/files/makefile_cleanup.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3Signed-off-by: Armin Kuster <akuster808@gmail.com>
4
5
6Index: git/Makefile
7===================================================================
8--- git.orig/Makefile
9+++ git/Makefile
10@@ -7,15 +7,8 @@
11
12 P_OUTPUT = output
13 P_PWD ?= $(shell pwd)
14-P_KVER ?= $(shell uname -r)
15 P_BOOTUP_SCRIPT ?= scripts/bootup/lkrg-bootup.sh
16 TARGET := p_lkrg
17-ifneq ($(KERNELRELEASE),)
18- KERNEL := /lib/modules/$(KERNELRELEASE)/build
19-else
20- ## KERNELRELEASE not set.
21- KERNEL := /lib/modules/$(P_KVER)/build
22-endif
23
24 #
25 # Use DEBUG=on for debug build.
26@@ -94,14 +87,13 @@ $(TARGET)-objs += src/modules/ksyms/p_re
27 src/p_lkrg_main.o
28
29
30-all:
31-# $(MAKE) -C $(KERNEL) M=$(P_PWD) modules CONFIG_DEBUG_SECTION_MISMATCH=y
32- $(MAKE) -C $(KERNEL) M=$(P_PWD) modules
33+modules:
34+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) modules
35 mkdir -p $(P_OUTPUT)
36 cp $(P_PWD)/$(TARGET).ko $(P_OUTPUT)
37
38-install:
39- $(MAKE) -C $(KERNEL) M=$(P_PWD) modules_install
40+moduled_install:
41+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) modules_install
42 depmod -a
43 $(P_PWD)/$(P_BOOTUP_SCRIPT) install
44
45@@ -109,7 +101,7 @@ uninstall:
46 $(P_PWD)/$(P_BOOTUP_SCRIPT) uninstall
47
48 clean:
49- $(MAKE) -C $(KERNEL) M=$(P_PWD) clean
50+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) clean
51 $(RM) Module.markers modules.order
52 $(RM) $(P_PWD)/src/modules/kmod/client/kmod/Module.markers
53 $(RM) $(P_PWD)/src/modules/kmod/client/kmod/modules.order
diff --git a/recipes-kernel/lkrg/lkrg-module_0.9.3.bb b/recipes-kernel/lkrg/lkrg-module_0.9.4.bb
index 2553974..fa46cb6 100644
--- a/recipes-kernel/lkrg/lkrg-module_0.9.3.bb
+++ b/recipes-kernel/lkrg/lkrg-module_0.9.4.bb
@@ -5,15 +5,13 @@ SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/" 5HOMEPAGE = "https://www.openwall.com/lkrg/"
6LICENSE = "GPL-2.0-only" 6LICENSE = "GPL-2.0-only"
7 7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=3f3e5dd56319d33a1944d635c1c86c6f"
9 9
10DEPENDS = "virtual/kernel elfutils" 10DEPENDS = "virtual/kernel elfutils"
11 11
12SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main \ 12SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main"
13 file://makefile_cleanup.patch \
14"
15 13
16SRCREV = "c578e9f786299b67ffd62057b4534b0bf4fb7ece" 14SRCREV = "c58cb52145b8e8ccc6bd19079f5c835933281cdc"
17 15
18S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
19 17
@@ -21,7 +19,13 @@ inherit module kernel-module-split
21 19
22MAKE_TARGETS = "modules" 20MAKE_TARGETS = "modules"
23 21
24MODULE_NAME = "p_lkrg" 22MODULE_NAME = "lkrg"
23
24do_configure:append () {
25 sed -i -e 's/^all/modules/' ${S}/Makefile
26 sed -i -e 's/^install/modules_install/' ${S}/Makefile
27 sed -i -e 's/KERNEL/KERNEL_SRC/g' ${S}/Makefile
28}
25 29
26module_do_install() { 30module_do_install() {
27 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME} 31 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}