summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/lkrg/files/makefile_cleanup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/lkrg/files/makefile_cleanup.patch')
-rw-r--r--recipes-kernel/lkrg/files/makefile_cleanup.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/recipes-kernel/lkrg/files/makefile_cleanup.patch b/recipes-kernel/lkrg/files/makefile_cleanup.patch
deleted file mode 100644
index f29afbe..0000000
--- a/recipes-kernel/lkrg/files/makefile_cleanup.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1Upstream-Status: Inappropriate [embedded specific]
2
3Signed-off-by: Armin Kuster <akuster808@gmail.com>
4
5
6Index: git/Makefile
7===================================================================
8--- git.orig/Makefile
9+++ git/Makefile
10@@ -7,15 +7,8 @@
11
12 P_OUTPUT = output
13 P_PWD ?= $(shell pwd)
14-P_KVER ?= $(shell uname -r)
15 P_BOOTUP_SCRIPT ?= scripts/bootup/lkrg-bootup.sh
16 TARGET := p_lkrg
17-ifneq ($(KERNELRELEASE),)
18- KERNEL := /lib/modules/$(KERNELRELEASE)/build
19-else
20- ## KERNELRELEASE not set.
21- KERNEL := /lib/modules/$(P_KVER)/build
22-endif
23
24 #
25 # Use DEBUG=on for debug build.
26@@ -94,14 +87,13 @@ $(TARGET)-objs += src/modules/ksyms/p_re
27 src/p_lkrg_main.o
28
29
30-all:
31-# $(MAKE) -C $(KERNEL) M=$(P_PWD) modules CONFIG_DEBUG_SECTION_MISMATCH=y
32- $(MAKE) -C $(KERNEL) M=$(P_PWD) modules
33+modules:
34+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) modules
35 mkdir -p $(P_OUTPUT)
36 cp $(P_PWD)/$(TARGET).ko $(P_OUTPUT)
37
38-install:
39- $(MAKE) -C $(KERNEL) M=$(P_PWD) modules_install
40+moduled_install:
41+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) modules_install
42 depmod -a
43 $(P_PWD)/$(P_BOOTUP_SCRIPT) install
44
45@@ -109,7 +101,7 @@ uninstall:
46 $(P_PWD)/$(P_BOOTUP_SCRIPT) uninstall
47
48 clean:
49- $(MAKE) -C $(KERNEL) M=$(P_PWD) clean
50+ $(MAKE) -C $(KERNEL_SRC) M=$(P_PWD) clean
51 $(RM) Module.markers modules.order
52 $(RM) $(P_PWD)/src/modules/kmod/client/kmod/Module.markers
53 $(RM) $(P_PWD)/src/modules/kmod/client/kmod/modules.order