summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-07-26 12:49:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-27 10:56:34 +0200
commit56d0bdb5fe818858a152a793a363bbe86d46d430 (patch)
tree0906bfeb86ed3d9bf23a2a226bf3593452e67554 /recipes-devtools
parentab4006bb2e6f51ea49c074fc0e9b1a50c96c01e1 (diff)
downloadmeta-raspberrypi-56d0bdb5fe818858a152a793a363bbe86d46d430.tar.gz
recipe: anchor regexps in COMPATIBLE_MACHINE
* bitbake is using re.match, so raspberrypi actually matches with anything ^raspberrypi.* which currently works, but it will also match with hypothetical raspberrypi-is-no-more-this-is-banana-now MACHINE which isn't intended by this COMPATIBLE_MACHINE. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.52.bb2
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster.inc2
-rw-r--r--recipes-devtools/python/rpi-gpio_0.6.2.bb2
-rw-r--r--recipes-devtools/python/rpio_0.10.0.bb2
-rw-r--r--recipes-devtools/wiringPi/wiringpi_git.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/bcm2835/bcm2835_1.52.bb b/recipes-devtools/bcm2835/bcm2835_1.52.bb
index 8e41c61..eef6afd 100644
--- a/recipes-devtools/bcm2835/bcm2835_1.52.bb
+++ b/recipes-devtools/bcm2835/bcm2835_1.52.bb
@@ -8,7 +8,7 @@ AUTHOR = "Mike McCauley (mikem@open.com.au)"
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10 10
11COMPATIBLE_MACHINE = "raspberrypi" 11COMPATIBLE_MACHINE = "^rpi$"
12 12
13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz" 13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
14 14
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc
index a548957..6ea4fa3 100644
--- a/recipes-devtools/pi-blaster/pi-blaster.inc
+++ b/recipes-devtools/pi-blaster/pi-blaster.inc
@@ -16,6 +16,6 @@ INITSCRIPT_PACKAGES = "${PN}"
16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh" 16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
17INITSCRIPT_PARAMS_${PN} = "defaults 15 85" 17INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
18 18
19COMPATIBLE_MACHINE = "raspberrypi" 19COMPATIBLE_MACHINE = "^rpi$"
20 20
21PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-devtools/python/rpi-gpio_0.6.2.bb b/recipes-devtools/python/rpi-gpio_0.6.2.bb
index a08ea98..9c72168 100644
--- a/recipes-devtools/python/rpi-gpio_0.6.2.bb
+++ b/recipes-devtools/python/rpi-gpio_0.6.2.bb
@@ -17,5 +17,5 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
17 17
18inherit distutils 18inherit distutils
19 19
20COMPATIBLE_MACHINE = "raspberrypi" 20COMPATIBLE_MACHINE = "^rpi$"
21 21
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb
index 1a6cee7..998fdb3 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.0.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
14 14
15inherit setuptools 15inherit setuptools
16 16
17COMPATIBLE_MACHINE = "raspberrypi" 17COMPATIBLE_MACHINE = "^rpi$"
18 18
19RDEPENDS_${PN} = "\ 19RDEPENDS_${PN} = "\
20 python-logging \ 20 python-logging \
diff --git a/recipes-devtools/wiringPi/wiringpi_git.bb b/recipes-devtools/wiringPi/wiringpi_git.bb
index 7953a55..f1b01db 100644
--- a/recipes-devtools/wiringPi/wiringpi_git.bb
+++ b/recipes-devtools/wiringPi/wiringpi_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://git.drogon.net/wiringPi \
13 file://0001-Add-initial-cross-compile-support.patch \ 13 file://0001-Add-initial-cross-compile-support.patch \
14 " 14 "
15 15
16COMPATIBLE_MACHINE = "raspberrypi" 16COMPATIBLE_MACHINE = "^rpi$"
17 17
18CFLAGS_prepend = "-I${S}/wiringPi -I${S}/devLib " 18CFLAGS_prepend = "-I${S}/wiringPi -I${S}/devLib "
19 19