summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-07-26 12:49:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-27 10:56:34 +0200
commit56d0bdb5fe818858a152a793a363bbe86d46d430 (patch)
tree0906bfeb86ed3d9bf23a2a226bf3593452e67554
parentab4006bb2e6f51ea49c074fc0e9b1a50c96c01e1 (diff)
downloadmeta-raspberrypi-56d0bdb5fe818858a152a793a363bbe86d46d430.tar.gz
recipe: anchor regexps in COMPATIBLE_MACHINE
* bitbake is using re.match, so raspberrypi actually matches with anything ^raspberrypi.* which currently works, but it will also match with hypothetical raspberrypi-is-no-more-this-is-banana-now MACHINE which isn't intended by this COMPATIBLE_MACHINE. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bb2
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb2
-rw-r--r--recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb2
-rw-r--r--recipes-devtools/bcm2835/bcm2835_1.52.bb2
-rw-r--r--recipes-devtools/pi-blaster/pi-blaster.inc2
-rw-r--r--recipes-devtools/python/rpi-gpio_0.6.2.bb2
-rw-r--r--recipes-devtools/python/rpio_0.10.0.bb2
-rw-r--r--recipes-devtools/wiringPi/wiringpi_git.bb2
-rw-r--r--recipes-graphics/userland/userland_git.bb2
-rw-r--r--recipes-graphics/vc-graphics/vc-graphics.inc2
-rw-r--r--recipes-kernel/linux/linux-raspberrypi.inc2
11 files changed, 11 insertions, 11 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
index b279e15..a115037 100644
--- a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -9,7 +9,7 @@ include recipes-bsp/common/firmware.inc
9 9
10RDEPENDS_${PN} = "rpi-config" 10RDEPENDS_${PN} = "rpi-config"
11 11
12COMPATIBLE_MACHINE = "raspberrypi" 12COMPATIBLE_MACHINE = "^rpi$"
13 13
14S = "${RPIFW_S}/boot" 14S = "${RPIFW_S}/boot"
15 15
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index b3c5084..38a1237 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7 7
8COMPATIBLE_MACHINE = "raspberrypi" 8COMPATIBLE_MACHINE = "^rpi$"
9 9
10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" 10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \ 11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \
diff --git a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 4936dcf..c938c3b 100644
--- a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -1,7 +1,7 @@
1SUMMARY = "U-boot boot scripts for Raspberry Pi" 1SUMMARY = "U-boot boot scripts for Raspberry Pi"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4COMPATIBLE_MACHINE = "rpi" 4COMPATIBLE_MACHINE = "^rpi$"
5 5
6DEPENDS = "u-boot-mkimage-native" 6DEPENDS = "u-boot-mkimage-native"
7 7
diff --git a/recipes-devtools/bcm2835/bcm2835_1.52.bb b/recipes-devtools/bcm2835/bcm2835_1.52.bb
index 8e41c61..eef6afd 100644
--- a/recipes-devtools/bcm2835/bcm2835_1.52.bb
+++ b/recipes-devtools/bcm2835/bcm2835_1.52.bb
@@ -8,7 +8,7 @@ AUTHOR = "Mike McCauley (mikem@open.com.au)"
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10 10
11COMPATIBLE_MACHINE = "raspberrypi" 11COMPATIBLE_MACHINE = "^rpi$"
12 12
13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz" 13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
14 14
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc
index a548957..6ea4fa3 100644
--- a/recipes-devtools/pi-blaster/pi-blaster.inc
+++ b/recipes-devtools/pi-blaster/pi-blaster.inc
@@ -16,6 +16,6 @@ INITSCRIPT_PACKAGES = "${PN}"
16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh" 16INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
17INITSCRIPT_PARAMS_${PN} = "defaults 15 85" 17INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
18 18
19COMPATIBLE_MACHINE = "raspberrypi" 19COMPATIBLE_MACHINE = "^rpi$"
20 20
21PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-devtools/python/rpi-gpio_0.6.2.bb b/recipes-devtools/python/rpi-gpio_0.6.2.bb
index a08ea98..9c72168 100644
--- a/recipes-devtools/python/rpi-gpio_0.6.2.bb
+++ b/recipes-devtools/python/rpi-gpio_0.6.2.bb
@@ -17,5 +17,5 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
17 17
18inherit distutils 18inherit distutils
19 19
20COMPATIBLE_MACHINE = "raspberrypi" 20COMPATIBLE_MACHINE = "^rpi$"
21 21
diff --git a/recipes-devtools/python/rpio_0.10.0.bb b/recipes-devtools/python/rpio_0.10.0.bb
index 1a6cee7..998fdb3 100644
--- a/recipes-devtools/python/rpio_0.10.0.bb
+++ b/recipes-devtools/python/rpio_0.10.0.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
14 14
15inherit setuptools 15inherit setuptools
16 16
17COMPATIBLE_MACHINE = "raspberrypi" 17COMPATIBLE_MACHINE = "^rpi$"
18 18
19RDEPENDS_${PN} = "\ 19RDEPENDS_${PN} = "\
20 python-logging \ 20 python-logging \
diff --git a/recipes-devtools/wiringPi/wiringpi_git.bb b/recipes-devtools/wiringPi/wiringpi_git.bb
index 7953a55..f1b01db 100644
--- a/recipes-devtools/wiringPi/wiringpi_git.bb
+++ b/recipes-devtools/wiringPi/wiringpi_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://git.drogon.net/wiringPi \
13 file://0001-Add-initial-cross-compile-support.patch \ 13 file://0001-Add-initial-cross-compile-support.patch \
14 " 14 "
15 15
16COMPATIBLE_MACHINE = "raspberrypi" 16COMPATIBLE_MACHINE = "^rpi$"
17 17
18CFLAGS_prepend = "-I${S}/wiringPi -I${S}/devLib " 18CFLAGS_prepend = "-I${S}/wiringPi -I${S}/devLib "
19 19
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 893fcba..8ff1411 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -12,7 +12,7 @@ PROVIDES = "virtual/libgles2 \
12 12
13RPROVIDES_${PN} += "libgles2 egl" 13RPROVIDES_${PN} += "libgles2 egl"
14 14
15COMPATIBLE_MACHINE = "raspberrypi" 15COMPATIBLE_MACHINE = "^rpi$"
16 16
17SRCBRANCH = "master" 17SRCBRANCH = "master"
18SRCFORK = "raspberrypi" 18SRCFORK = "raspberrypi"
diff --git a/recipes-graphics/vc-graphics/vc-graphics.inc b/recipes-graphics/vc-graphics/vc-graphics.inc
index a1c8d29..668c5ce 100644
--- a/recipes-graphics/vc-graphics/vc-graphics.inc
+++ b/recipes-graphics/vc-graphics/vc-graphics.inc
@@ -4,7 +4,7 @@ LICENSE = "Proprietary"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=86e53f5f5909ee66900418028de11780" 4LIC_FILES_CHKSUM = "file://LICENCE;md5=86e53f5f5909ee66900418028de11780"
5 5
6PROVIDES = "virtual/libgles2 virtual/egl" 6PROVIDES = "virtual/libgles2 virtual/egl"
7COMPATIBLE_MACHINE = "raspberrypi" 7COMPATIBLE_MACHINE = "^rpi$"
8 8
9include recipes-bsp/common/firmware.inc 9include recipes-bsp/common/firmware.inc
10 10
diff --git a/recipes-kernel/linux/linux-raspberrypi.inc b/recipes-kernel/linux/linux-raspberrypi.inc
index 9265d55..4f5999d 100644
--- a/recipes-kernel/linux/linux-raspberrypi.inc
+++ b/recipes-kernel/linux/linux-raspberrypi.inc
@@ -10,7 +10,7 @@ SRC_URI += " \
10 file://defconfig \ 10 file://defconfig \
11 " 11 "
12 12
13COMPATIBLE_MACHINE = "raspberrypi" 13COMPATIBLE_MACHINE = "^rpi$"
14 14
15PE = "1" 15PE = "1"
16PV = "${LINUX_VERSION}+git${SRCPV}" 16PV = "${LINUX_VERSION}+git${SRCPV}"