diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-26 12:49:51 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-27 10:56:34 +0200 |
commit | 56d0bdb5fe818858a152a793a363bbe86d46d430 (patch) | |
tree | 0906bfeb86ed3d9bf23a2a226bf3593452e67554 /recipes-bsp | |
parent | ab4006bb2e6f51ea49c074fc0e9b1a50c96c01e1 (diff) | |
download | meta-raspberrypi-56d0bdb5fe818858a152a793a363bbe86d46d430.tar.gz |
recipe: anchor regexps in COMPATIBLE_MACHINE
* bitbake is using re.match, so raspberrypi actually matches with anything
^raspberrypi.* which currently works, but it will also match with hypothetical
raspberrypi-is-no-more-this-is-banana-now MACHINE which isn't intended by
this COMPATIBLE_MACHINE.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/bootfiles/bcm2835-bootfiles.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/bootfiles/rpi-config_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb index b279e15..a115037 100644 --- a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb +++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb | |||
@@ -9,7 +9,7 @@ include recipes-bsp/common/firmware.inc | |||
9 | 9 | ||
10 | RDEPENDS_${PN} = "rpi-config" | 10 | RDEPENDS_${PN} = "rpi-config" |
11 | 11 | ||
12 | COMPATIBLE_MACHINE = "raspberrypi" | 12 | COMPATIBLE_MACHINE = "^rpi$" |
13 | 13 | ||
14 | S = "${RPIFW_S}/boot" | 14 | S = "${RPIFW_S}/boot" |
15 | 15 | ||
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb index b3c5084..38a1237 100644 --- a/recipes-bsp/bootfiles/rpi-config_git.bb +++ b/recipes-bsp/bootfiles/rpi-config_git.bb | |||
@@ -5,7 +5,7 @@ DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \ | |||
5 | LICENSE = "MIT" | 5 | LICENSE = "MIT" |
6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
7 | 7 | ||
8 | COMPATIBLE_MACHINE = "raspberrypi" | 8 | COMPATIBLE_MACHINE = "^rpi$" |
9 | 9 | ||
10 | SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" | 10 | SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" |
11 | SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \ | 11 | SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \ |
diff --git a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb index 4936dcf..c938c3b 100644 --- a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb +++ b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | SUMMARY = "U-boot boot scripts for Raspberry Pi" | 1 | SUMMARY = "U-boot boot scripts for Raspberry Pi" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
4 | COMPATIBLE_MACHINE = "rpi" | 4 | COMPATIBLE_MACHINE = "^rpi$" |
5 | 5 | ||
6 | DEPENDS = "u-boot-mkimage-native" | 6 | DEPENDS = "u-boot-mkimage-native" |
7 | 7 | ||