summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-07-26 12:49:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-27 10:56:34 +0200
commit56d0bdb5fe818858a152a793a363bbe86d46d430 (patch)
tree0906bfeb86ed3d9bf23a2a226bf3593452e67554 /recipes-bsp
parentab4006bb2e6f51ea49c074fc0e9b1a50c96c01e1 (diff)
downloadmeta-raspberrypi-56d0bdb5fe818858a152a793a363bbe86d46d430.tar.gz
recipe: anchor regexps in COMPATIBLE_MACHINE
* bitbake is using re.match, so raspberrypi actually matches with anything ^raspberrypi.* which currently works, but it will also match with hypothetical raspberrypi-is-no-more-this-is-banana-now MACHINE which isn't intended by this COMPATIBLE_MACHINE. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/bootfiles/bcm2835-bootfiles.bb2
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb2
-rw-r--r--recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
index b279e15..a115037 100644
--- a/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
+++ b/recipes-bsp/bootfiles/bcm2835-bootfiles.bb
@@ -9,7 +9,7 @@ include recipes-bsp/common/firmware.inc
9 9
10RDEPENDS_${PN} = "rpi-config" 10RDEPENDS_${PN} = "rpi-config"
11 11
12COMPATIBLE_MACHINE = "raspberrypi" 12COMPATIBLE_MACHINE = "^rpi$"
13 13
14S = "${RPIFW_S}/boot" 14S = "${RPIFW_S}/boot"
15 15
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index b3c5084..38a1237 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
5LICENSE = "MIT" 5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7 7
8COMPATIBLE_MACHINE = "raspberrypi" 8COMPATIBLE_MACHINE = "^rpi$"
9 9
10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f" 10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \ 11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \
diff --git a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
index 4936dcf..c938c3b 100644
--- a/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
+++ b/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bb
@@ -1,7 +1,7 @@
1SUMMARY = "U-boot boot scripts for Raspberry Pi" 1SUMMARY = "U-boot boot scripts for Raspberry Pi"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4COMPATIBLE_MACHINE = "rpi" 4COMPATIBLE_MACHINE = "^rpi$"
5 5
6DEPENDS = "u-boot-mkimage-native" 6DEPENDS = "u-boot-mkimage-native"
7 7