summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-17 12:44:15 -0800
committerAndrei Gherzan <andrei@gherzan.com>2021-11-18 09:17:24 +0000
commit4c76dab6f04efcb97a6923b0587d56343912f5b5 (patch)
tree983281baf602e1c371b2d4fe8dca5f8ac3dddea0
parent7413c72dd538d3956600211326a1c2ef01b8e057 (diff)
downloadmeta-raspberrypi-4c76dab6f04efcb97a6923b0587d56343912f5b5.tar.gz
linux-firmware-rpidistro: Use bullseye branch
Switch to using bullseye release 20210315-3+rpt3 License is pointed in different location in new repo structure WHENCE file is gone too. Fixes https://github.com/YoeDistro/yoe-distro/issues/617 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb42
1 files changed, 18 insertions, 24 deletions
diff --git a/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb b/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
index 45ed78c..95cd9c1 100644
--- a/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
+++ b/recipes-kernel/linux-firmware-rpidistro/linux-firmware-rpidistro_git.bb
@@ -6,12 +6,12 @@ HOMEPAGE = "https://github.com/RPi-Distro/firmware-nonfree"
6SECTION = "kernel" 6SECTION = "kernel"
7 7
8# In maintained upstream linux-firmware: 8# In maintained upstream linux-firmware:
9# * brcmfmac43430-sdio falls under LICENCE.cypress 9# * brcmfmac43430-sdio falls under LICENSE.cypress
10# * brcmfmac43455-sdio falls under LICENCE.broadcom_bcm43xx 10# * brcmfmac43455-sdio falls under LICENSE.broadcom_bcm43xx
11# * brcmfmac43456-sdio falls under LICENCE.broadcom_bcm43xx 11# * brcmfmac43456-sdio falls under LICENSE.broadcom_bcm43xx
12# 12#
13# It is likely[^1] that both of these should be under LICENCE.cypress. 13# It is likely[^1] that both of these should be under LICENSE.cypress.
14# Further, at this time the text of LICENCE.broadcom_bcm43xx is the same 14# Further, at this time the text of LICENSE.broadcom_bcm43xx is the same
15# in linux-firmware and RPi-Distro/firmware-nonfree, but this may 15# in linux-firmware and RPi-Distro/firmware-nonfree, but this may
16# change. 16# change.
17# 17#
@@ -22,22 +22,19 @@ SECTION = "kernel"
22# [^1]: https://github.com/RPi-Distro/bluez-firmware/issues/1 22# [^1]: https://github.com/RPi-Distro/bluez-firmware/issues/1
23LICENSE = "\ 23LICENSE = "\
24 Firmware-broadcom_bcm43xx-rpidistro \ 24 Firmware-broadcom_bcm43xx-rpidistro \
25 & WHENCE \
26" 25"
27LIC_FILES_CHKSUM = "\ 26LIC_FILES_CHKSUM = "\
28 file://LICENCE.broadcom_bcm43xx;md5=3160c14df7228891b868060e1951dfbc \ 27 file://debian/config/brcm80211/LICENSE;md5=8cba1397cda6386db37210439a0da3eb \
29 file://WHENCE;md5=7b12b2224438186e4c97c4c7f3a5cc28 \
30" 28"
31 29
32# These are not common licenses, set NO_GENERIC_LICENSE for them 30# These are not common licenses, set NO_GENERIC_LICENSE for them
33# so that the license files will be copied from fetched source 31# so that the license files will be copied from fetched source
34NO_GENERIC_LICENSE[Firmware-broadcom_bcm43xx-rpidistro] = "LICENCE.broadcom_bcm43xx" 32NO_GENERIC_LICENSE[Firmware-broadcom_bcm43xx-rpidistro] = "debian/config/brcm80211/LICENSE"
35NO_GENERIC_LICENSE[WHENCE] = "WHENCE"
36 33
37SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree;branch=master;protocol=https" 34SRC_URI = "git://github.com/RPi-Distro/firmware-nonfree;branch=bullseye;protocol=https"
38 35
39SRCREV = "54ffdd6e2ea6055d46656b78e148fe7def3ec9d8" 36SRCREV = "b3eec612566ca08913f0830d299f4df70297428f"
40PV = "20190114-2+rpt4" 37PV = "20210315-3+rpt3"
41 38
42S = "${WORKDIR}/git" 39S = "${WORKDIR}/git"
43 40
@@ -50,23 +47,20 @@ do_compile() {
50} 47}
51 48
52do_install() { 49do_install() {
53 install -d ${D}${nonarch_base_libdir}/firmware/brcm 50 install -d ${D}${nonarch_base_libdir}/firmware/brcm ${D}${nonarch_base_libdir}/firmware/cypress
54 51
55 cp ./LICENCE.broadcom_bcm43xx ${D}${nonarch_base_libdir}/firmware/LICENCE.broadcom_bcm43xx-rpidistro 52 cp debian/config/brcm80211/LICENSE ${D}${nonarch_base_libdir}/firmware/LICENSE.broadcom_bcm43xx-rpidistro
56 53
57 # Replace outdated linux-firmware files with updated ones from 54 # Replace outdated linux-firmware files with updated ones from
58 # raspbian firmware-nonfree. Raspbian adds blobs and nvram 55 # raspbian firmware-nonfree. Raspbian adds blobs and nvram
59 # definitions that are also necessary so copy those too. 56 # definitions that are also necessary so copy those too.
60 for fw in brcmfmac43430-sdio brcmfmac43436-sdio brcmfmac43436s-sdio brcmfmac43455-sdio brcmfmac43456-sdio ; do 57 for fw in brcmfmac43430-sdio brcmfmac43436-sdio brcmfmac43436s-sdio brcmfmac43455-sdio brcmfmac43456-sdio ; do
61 install -m 0644 brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/ 58 cp -R --no-dereference --preserve=mode,links -v debian/config/brcm80211/brcm/${fw}.* ${D}${nonarch_base_libdir}/firmware/brcm/
62 done 59 done
60 cp -R --no-dereference --preserve=mode,links -v debian/config/brcm80211/cypress/* ${D}${nonarch_base_libdir}/firmware/cypress/
63 # add compat links. Fixes errors like 61 # add compat links. Fixes errors like
64 # brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2 62 # brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-compute-module.txt failed with error -2
65 ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
66 ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-compute-module.txt 63 ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-compute-module.txt
67 ln -s brcmfmac43455-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
68 ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
69 ln -s brcmfmac43430-sdio.txt ${D}${nonarch_base_libdir}/firmware/brcm/brcmfmac43430-sdio.raspberrypi,model-zero-w.txt
70} 64}
71 65
72PACKAGES = "\ 66PACKAGES = "\
@@ -84,11 +78,11 @@ LICENSE:${PN}-bcm43436s = "Firmware-broadcom_bcm43xx-rpidistro"
84LICENSE:${PN}-bcm43455 = "Firmware-broadcom_bcm43xx-rpidistro" 78LICENSE:${PN}-bcm43455 = "Firmware-broadcom_bcm43xx-rpidistro"
85LICENSE:${PN}-bcm43456 = "Firmware-broadcom_bcm43xx-rpidistro" 79LICENSE:${PN}-bcm43456 = "Firmware-broadcom_bcm43xx-rpidistro"
86LICENSE:${PN}-broadcom-license = "Firmware-broadcom_bcm43xx-rpidistro" 80LICENSE:${PN}-broadcom-license = "Firmware-broadcom_bcm43xx-rpidistro"
87FILES:${PN}-broadcom-license = "${nonarch_base_libdir}/firmware/LICENCE.broadcom_bcm43xx-rpidistro" 81FILES:${PN}-broadcom-license = "${nonarch_base_libdir}/firmware/LICENSE.broadcom_bcm43xx-rpidistro"
88FILES:${PN}-bcm43430 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43430*" 82FILES:${PN}-bcm43430 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43430* ${nonarch_base_libdir}/firmware/cypress/cyfmac43430-sdio.bin"
89FILES:${PN}-bcm43436 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43436-*" 83FILES:${PN}-bcm43436 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43436-*"
90FILES:${PN}-bcm43436s = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43436s*" 84FILES:${PN}-bcm43436s = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43436s*"
91FILES:${PN}-bcm43455 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43455*" 85FILES:${PN}-bcm43455 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43455* ${nonarch_base_libdir}/firmware/cypress/cyfmac43455-sdio.*"
92FILES:${PN}-bcm43456 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43456*" 86FILES:${PN}-bcm43456 = "${nonarch_base_libdir}/firmware/brcm/brcmfmac43456*"
93RDEPENDS:${PN}-bcm43430 += "${PN}-broadcom-license" 87RDEPENDS:${PN}-bcm43430 += "${PN}-broadcom-license"
94RDEPENDS:${PN}-bcm43436 += "${PN}-broadcom-license" 88RDEPENDS:${PN}-bcm43436 += "${PN}-broadcom-license"