summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-11-16 18:34:22 +0100
committerAndrei Gherzan <andrei@gherzan.com>2021-11-17 11:08:55 +0000
commit7413c72dd538d3956600211326a1c2ef01b8e057 (patch)
tree5f9fac35b2c18b2ac8c8a8cd90dde82e5a15434f
parentc0dd1c9129076d89263aa67a312c5c3de68a67ab (diff)
downloadmeta-raspberrypi-7413c72dd538d3956600211326a1c2ef01b8e057.tar.gz
rpi-config: don't trigger bbfatal for empty ENABLE_UART
Fixes https://github.com/agherzan/meta-raspberrypi/pull/941 not to show fatal error for default configuration with ENABLE_UART being empty. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-bsp/bootfiles/rpi-config_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/bootfiles/rpi-config_git.bb b/recipes-bsp/bootfiles/rpi-config_git.bb
index fe18884..f78c6d7 100644
--- a/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -30,6 +30,8 @@ GPIO_IR_TX ?= "17"
30 30
31CAN_OSCILLATOR ?= "16000000" 31CAN_OSCILLATOR ?= "16000000"
32 32
33ENABLE_UART ??= ""
34
33WM8960="${@bb.utils.contains("MACHINE_FEATURES", "wm8960", "1", "0", d)}" 35WM8960="${@bb.utils.contains("MACHINE_FEATURES", "wm8960", "1", "0", d)}"
34 36
35inherit deploy nopackages 37inherit deploy nopackages
@@ -177,7 +179,7 @@ do_deploy() {
177 if [ "${ENABLE_UART}" = "1" ] || [ "${ENABLE_UART}" = "0" ] ; then 179 if [ "${ENABLE_UART}" = "1" ] || [ "${ENABLE_UART}" = "0" ] ; then
178 echo "# Enable UART" >>$CONFIG 180 echo "# Enable UART" >>$CONFIG
179 echo "enable_uart=${ENABLE_UART}" >>$CONFIG 181 echo "enable_uart=${ENABLE_UART}" >>$CONFIG
180 else 182 elif [ -n "${ENABLE_UART}" ]; then
181 bbfatal "Invalid value for ENABLE_UART [${ENABLE_UART}]. The value for ENABLE_UART can be 0 or 1." 183 bbfatal "Invalid value for ENABLE_UART [${ENABLE_UART}]. The value for ENABLE_UART can be 0 or 1."
182 fi 184 fi
183 185