summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-23 16:58:04 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-24 07:18:56 +0000
commitf69fc4063ccbc3774df6f73fa59f9558eede8128 (patch)
tree47dbb273d3a4a315e102c3d76f9838172aa9283b
parent7cc177d116ad98d0c922f98aa7f02c2cc655c0ec (diff)
downloadmeta-qt5-f69fc4063ccbc3774df6f73fa59f9558eede8128.tar.gz
qtwebengine: Fix build with musl/gcc9
Provide couple of patches to fix build with x86_64/musl and a new bug found lss via gcc9 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0004-chromium-stack-pointer-clobber.patch67
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-include-fcntl.h-for-loff_t.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-use-off64_t-instead-of-the-internal-__.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-linux-glibc-make-the-distinction.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Use-correct-member-name-__si_fields-fr.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Do-not-define-__sbrk-on-musl.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Adjust-default-pthread-stack-size.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch (renamed from recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch31
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb30
16 files changed, 127 insertions, 27 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-stack-pointer-clobber.patch b/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-stack-pointer-clobber.patch
new file mode 100644
index 00000000..7716a76f
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-stack-pointer-clobber.patch
@@ -0,0 +1,67 @@
1From d517836886eee72503aecc3e866fb7f08e6b0c49 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 23 Dec 2018 16:58:04 -0800
4Subject: [PATCH] chromium: stack pointer clobber
5
6Do not add stack pointer to clobber list
7
8it was being ignored until gcc 9.0 became capable
9of flagging this silent ignoring via [1]
10
11[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=52813<Paste>
12
13Upstream-Status: Submitted [https://chromium-review.googlesource.com/c/linux-syscall-support/+/1390160]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 chromium/third_party/lss/linux_syscall_support.h | 10 +++++-----
17 1 file changed, 5 insertions(+), 5 deletions(-)
18
19diff --git a/chromium/third_party/lss/linux_syscall_support.h b/chromium/third_party/lss/linux_syscall_support.h
20index 5d9c2e8582f..e19e51dd304 100644
21--- a/chromium/third_party/lss/linux_syscall_support.h
22+++ b/chromium/third_party/lss/linux_syscall_support.h
23@@ -1964,7 +1964,7 @@ struct kernel_statfs {
24 __asm__ volatile(LSS_ENTRYPOINT \
25 : "=a" (__res) \
26 : "0" (__NR_##name) \
27- : "esp", "memory"); \
28+ : "memory"); \
29 LSS_RETURN(type,__res); \
30 }
31 #undef _syscall1
32@@ -2012,7 +2012,7 @@ struct kernel_statfs {
33 : "i" (__NR_##name), "ri" ((long)(arg1)), \
34 "c" ((long)(arg2)), "d" ((long)(arg3)), \
35 "S" ((long)(arg4)), "D" ((long)(arg5)) \
36- : "esp", "memory"); \
37+ : "memory"); \
38 LSS_RETURN(type,__res); \
39 }
40 #undef _syscall6
41@@ -2034,7 +2034,7 @@ struct kernel_statfs {
42 : "i" (__NR_##name), "0" ((long)(&__s)), \
43 "c" ((long)(arg2)), "d" ((long)(arg3)), \
44 "S" ((long)(arg4)), "D" ((long)(arg5)) \
45- : "esp", "memory"); \
46+ : "memory"); \
47 LSS_RETURN(type,__res); \
48 }
49 LSS_INLINE int LSS_NAME(clone)(int (*fn)(void *), void *child_stack,
50@@ -2120,7 +2120,7 @@ struct kernel_statfs {
51 : "0"(-EINVAL), "i"(__NR_clone),
52 "m"(fn), "m"(child_stack), "m"(flags), "m"(arg),
53 "m"(parent_tidptr), "m"(newtls), "m"(child_tidptr)
54- : "esp", "memory", "ecx", "edx", "esi", "edi");
55+ : "memory", "ecx", "edx", "esi", "edi");
56 LSS_RETURN(int, __res);
57 }
58
59@@ -2405,7 +2405,7 @@ struct kernel_statfs {
60 "d"(LSS_SYSCALL_ARG(parent_tidptr)),
61 "r"(LSS_SYSCALL_ARG(newtls)),
62 "r"(LSS_SYSCALL_ARG(child_tidptr))
63- : "rsp", "memory", "r8", "r10", "r11", "rcx");
64+ : "memory", "r8", "r10", "r11", "rcx");
65 }
66 LSS_RETURN(int, __res);
67 }
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch b/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
index fb95640a..0340d995 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
@@ -1,4 +1,4 @@
1From 4d4bc57f9ac9769ef8d7fb4b73889f36ae078bf2 Mon Sep 17 00:00:00 2001 1From 3386b5df27ec6dfd42fa5bc30b5e307b293a0a5f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:01:12 -0700 3Date: Fri, 7 Jul 2017 14:01:12 -0700
4Subject: [PATCH] chromium: musl: sandbox: Define TEMP_FAILURE_RETRY if not 4Subject: [PATCH] chromium: musl: sandbox: Define TEMP_FAILURE_RETRY if not
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch b/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
index 8b55196a..3d1c7ff0 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
@@ -1,4 +1,4 @@
1From 3b0cfcacac04a47778d6af6088073bb49bd9b2d9 Mon Sep 17 00:00:00 2001 1From 8a99b4662109d03502baa1578d5484bfdd399caf Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:09:06 -0700 3Date: Fri, 7 Jul 2017 14:09:06 -0700
4Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux 4Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-include-fcntl.h-for-loff_t.patch
index 650e5093..05a8ac33 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-include-fcntl.h-for-loff_t.patch
@@ -1,4 +1,4 @@
1From 6bd670aee3ce52e9a546fd680753b66cba1d05fe Mon Sep 17 00:00:00 2001 1From f451b8f55b6258a725a2ba470ca8feaa600f621e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:37:49 -0700 3Date: Fri, 7 Jul 2017 14:37:49 -0700
4Subject: [PATCH] chromium: musl: include fcntl.h for loff_t 4Subject: [PATCH] chromium: musl: include fcntl.h for loff_t
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch b/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
index c690dda0..1acfd7be 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
@@ -1,4 +1,4 @@
1From 83295f6b1b72683ffe042d362a36f9c8482e64e2 Mon Sep 17 00:00:00 2001 1From 36d8ce0f390678080a670d1c48340c341d33bfad Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:38:37 -0700 3Date: Fri, 7 Jul 2017 14:38:37 -0700
4Subject: [PATCH] chromium: musl: use off64_t instead of the internal __off64_t 4Subject: [PATCH] chromium: musl: use off64_t instead of the internal __off64_t
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-linux-glibc-make-the-distinction.patch
index 07e42f06..7a6636fe 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-linux-glibc-make-the-distinction.patch
@@ -1,4 +1,4 @@
1From 4710eba530c905803965811071aced2e793fedad Mon Sep 17 00:00:00 2001 1From 606a0f86fdfb600ab43221e079483d5de5db39bb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:54:38 -0700 3Date: Fri, 7 Jul 2017 14:54:38 -0700
4Subject: [PATCH] chromium: musl: linux != glibc, make the distinction 4Subject: [PATCH] chromium: musl: linux != glibc, make the distinction
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch b/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
index a8856573..82ac109d 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
@@ -1,4 +1,4 @@
1From da9611b55a773e1193af56d4391bf8a0fb83b02b Mon Sep 17 00:00:00 2001 1From 418261c2f6f4c5ec81e390af265aa22b7adba272 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:09:02 -0700 3Date: Fri, 7 Jul 2017 15:09:02 -0700
4Subject: [PATCH] chromium: musl: allocator: Do not include glibc_weak_symbols 4Subject: [PATCH] chromium: musl: allocator: Do not include glibc_weak_symbols
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
index 75b68e6c..2916dbd3 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
@@ -1,4 +1,4 @@
1From bd65922ed04167888d751f438457d1c33081b8f4 Mon Sep 17 00:00:00 2001 1From 69d01ff29ba4e338c9d13369a511e90ab0168afa Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:12:39 -0700 3Date: Fri, 7 Jul 2017 15:12:39 -0700
4Subject: [PATCH] chromium: musl: Use correct member name __si_fields from 4Subject: [PATCH] chromium: musl: Use correct member name __si_fields from
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
index e107604f..6abab3ea 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
@@ -1,4 +1,4 @@
1From 3f7f5a5ad9e3f3c5fa998bf6a905b6759e028dbc Mon Sep 17 00:00:00 2001 1From ad6c7f73c56dc465b0554437da971adf763c4032 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:27:50 -0700 3Date: Fri, 7 Jul 2017 15:27:50 -0700
4Subject: [PATCH] chromium: musl: Define res_ninit and res_nclose for non-glibc 4Subject: [PATCH] chromium: musl: Define res_ninit and res_nclose for non-glibc
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch b/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Do-not-define-__sbrk-on-musl.patch
index 0414a905..8f3463de 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Do-not-define-__sbrk-on-musl.patch
@@ -1,4 +1,4 @@
1From 18cc6e16f45eafb89f19d507c02d573ab5429246 Mon Sep 17 00:00:00 2001 1From f1060910189ba7760b7285a4b221065c1d677241 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 15:39:57 -0700 3Date: Fri, 7 Jul 2017 15:39:57 -0700
4Subject: [PATCH] chromium: musl: Do not define __sbrk on musl 4Subject: [PATCH] chromium: musl: Do not define __sbrk on musl
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch b/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
index 90e24aa4..a3b34b22 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Adjust-default-pthread-stack-size.patch
@@ -1,4 +1,4 @@
1From 2da25a561f24b3a759c1c26e98b252e47aea19c9 Mon Sep 17 00:00:00 2001 1From 7f95397de67e00390fd90ed6b2f70dcfde8d7285 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 16:41:23 -0700 3Date: Fri, 7 Jul 2017 16:41:23 -0700
4Subject: [PATCH] chromium: musl: Adjust default pthread stack size 4Subject: [PATCH] chromium: musl: Adjust default pthread stack size
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
index 9146716c..5595c777 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
@@ -1,4 +1,4 @@
1From 72f0f29fa6372a1b45f33f04e61968dd21870d64 Mon Sep 17 00:00:00 2001 1From 010cff20ca97bba43ed9d6332bd3e9b0198c97a4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 17:15:34 -0700 3Date: Fri, 7 Jul 2017 17:15:34 -0700
4Subject: [PATCH] chromium: musl: include asm-generic/ioctl.h for TCGETS2 4Subject: [PATCH] chromium: musl: include asm-generic/ioctl.h for TCGETS2
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch b/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch
index 11418cbe..fc9eef80 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch
@@ -1,4 +1,4 @@
1From e38a35fcad87a4c8279138d4ee6eaadac297548a Mon Sep 17 00:00:00 2001 1From 7bc63fb1e62c906db5be40acd1d10095461cd4bd Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Sep 2018 12:35:07 -0700 3Date: Tue, 25 Sep 2018 12:35:07 -0700
4Subject: [PATCH] chromium: musl: Use _fpstate instead of _libc_fpstate on 4Subject: [PATCH] chromium: musl: Use _fpstate instead of _libc_fpstate on
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch b/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
index 59923abb..51e852ce 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch
@@ -1,4 +1,4 @@
1From 26fdb49d41d1a5474c1fcfce9d60eda8191bdab7 Mon Sep 17 00:00:00 2001 1From 7652de3ab9dbc9eacf73a3fe16559a1651a48b1a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Sep 2018 12:59:05 -0700 3Date: Tue, 25 Sep 2018 12:59:05 -0700
4Subject: [PATCH] chromium: musl: elf_reader.cc: include <sys/reg.h> to get 4Subject: [PATCH] chromium: musl: elf_reader.cc: include <sys/reg.h> to get
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch b/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch
new file mode 100644
index 00000000..fd6ed6ad
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-pread-pwrite.patch
@@ -0,0 +1,31 @@
1From b8d97e253b4df62b2ab8b313a34d69d29c63b24c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 23 Dec 2018 16:58:04 -0800
4Subject: [PATCH] chromium: musl: pread pwrite
5
6Redefine pread/pwrite in terms of 64bit variants on musl
7since 32bit variants don't exist and aliases are not defined in
8libc either
9
10Upstream-Status: Submitted [https://codereview.chromium.org/1743093002/]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 chromium/third_party/lss/linux_syscall_support.h | 5 +++++
14 1 file changed, 5 insertions(+)
15
16diff --git a/chromium/third_party/lss/linux_syscall_support.h b/chromium/third_party/lss/linux_syscall_support.h
17index e19e51dd304..5c661949d1e 100644
18--- a/chromium/third_party/lss/linux_syscall_support.h
19+++ b/chromium/third_party/lss/linux_syscall_support.h
20@@ -1239,6 +1239,11 @@ struct kernel_statfs {
21 #ifndef __NR_fallocate
22 #define __NR_fallocate 285
23 #endif
24+#undef __NR_pread
25+#define __NR_pread __NR_pread64
26+#undef __NR_pwrite
27+#define __NR_pwrite __NR_pwrite64
28+
29 /* End of x86-64 definitions */
30 #elif defined(__mips__)
31 #if _MIPS_SIM == _MIPS_SIM_ABI32
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 7d5c80bf..b64965de 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -147,27 +147,29 @@ SRC_URI_append_libc-musl = "\
147" 147"
148 148
149# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/69-based 149# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/69-based
150# 69-based.meta-qt5.2 150# 69-based.meta-qt5.3
151SRC_URI += " \ 151SRC_URI += " \
152 file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \ 152 file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
153 file://chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \ 153 file://chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
154 file://chromium/0003-chromium-Fix-build-with-gcc8.patch;patchdir=src/3rdparty \ 154 file://chromium/0003-chromium-Fix-build-with-gcc8.patch;patchdir=src/3rdparty \
155 file://chromium/0004-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \
155" 156"
156 157
157SRC_URI_append_libc-musl = "\ 158SRC_URI_append_libc-musl = "\
158 file://chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 159 file://chromium/0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
159 file://chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 160 file://chromium/0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
160 file://chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 161 file://chromium/0007-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
161 file://chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 162 file://chromium/0008-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
162 file://chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 163 file://chromium/0009-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
163 file://chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 164 file://chromium/0010-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
164 file://chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \ 165 file://chromium/0011-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
165 file://chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 166 file://chromium/0012-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
166 file://chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 167 file://chromium/0013-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
167 file://chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 168 file://chromium/0014-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
168 file://chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \ 169 file://chromium/0015-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
169 file://chromium/0015-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \ 170 file://chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \
170 file://chromium/0016-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \ 171 file://chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
172 file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
171" 173"
172 174
173SRCREV_qtwebengine = "4f1e0003d98116e33a847360e0e95c46daae25fc" 175SRCREV_qtwebengine = "4f1e0003d98116e33a847360e0e95c46daae25fc"