summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-12-23 08:02:55 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-23 19:40:35 +0000
commit7cc177d116ad98d0c922f98aa7f02c2cc655c0ec (patch)
tree74648680f212b80885716af4cbfa851b97974cd4
parent1b755b2e05a95a8c1d74f131d211b814109e3a32 (diff)
downloadmeta-qt5-7cc177d116ad98d0c922f98aa7f02c2cc655c0ec.tar.gz
qtwebkit-examples: drop recipe
* it's not supported by upstream * it's broken again with 5.12.0: http://errors.yoctoproject.org/Errors/Build/74151/ make[3]: Entering directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/simpleselector' make[3]: *** No rule to make target 'QtWebKit/QWebView', needed by '.uic/ui_window.h'. Stop. make[3]: Leaving directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/simpleselector' ... make[3]: Entering directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/domtraversal' make[3]: *** No rule to make target 'QtWebKitWidgets/QWebView', needed by '.uic/ui_window.h'. Stop. make[3]: Leaving directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/domtraversal' ... make[3]: Entering directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/formextractor' make[3]: *** No rule to make target 'QtWebKit/QWebView', needed by '.uic/ui_formextractor.h'. Stop. make[3]: Leaving directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/formextractor' ... make[3]: Entering directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/previewer' make[3]: *** No rule to make target 'QtWebKit/QWebView', needed by '.uic/ui_previewer.h'. Stop. make[3]: Leaving directory 'TOPDIR/tmp-glibc/work/core2-64-oe-linux/qtwebkit-examples/5.12.0+gitAUTOINC+2d68492004-r0/build/examples/webkitwidgets/previewer' * nobody was interested in fixing it last time it got broken with 5.11 upgrade: https://patchwork.openembedded.org/patch/151399/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch48
-rw-r--r--recipes-qt/qt5/qtwebkit-examples_git.bb24
2 files changed, 0 insertions, 72 deletions
diff --git a/recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch b/recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch
deleted file mode 100644
index 57e318b0..00000000
--- a/recipes-qt/qt5/qtwebkit-examples/0001-Fix-build-with-qt-5.11.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From e07f1fcba5a291ef0ab31fd85fbc4836eda19a66 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 24 Sep 2018 03:14:29 -0700
4Subject: [PATCH] Fix build with qt 5.11
5
6Fixes
7
8examples/webkitwidgets/scroller/wheel/main.cpp:93:84: error: cannot call
9member function 'int QRandomGenerator::bounded(int)' without object
10 m_wheel1->scrollTo(m_wheel1->currentIndex() +
11QRandomGenerator::bounded(200));
12
13Upstream-Status: Pending
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 examples/webkitwidgets/scroller/wheel/main.cpp | 8 ++++----
18 1 file changed, 4 insertions(+), 4 deletions(-)
19
20diff --git a/examples/webkitwidgets/scroller/wheel/main.cpp b/examples/webkitwidgets/scroller/wheel/main.cpp
21index 11fad08..9a6a225 100644
22--- a/examples/webkitwidgets/scroller/wheel/main.cpp
23+++ b/examples/webkitwidgets/scroller/wheel/main.cpp
24@@ -40,7 +40,7 @@
25
26 #include <QtWidgets>
27 #include <qmath.h>
28-
29+#include <QRandomGenerator>
30 #include "wheelwidget.h"
31
32 class MainWindow : public QMainWindow
33@@ -90,9 +90,9 @@ public:
34 private slots:
35 void rotateRandom()
36 {
37- m_wheel1->scrollTo(m_wheel1->currentIndex() + QRandomGenerator::bounded(200));
38- m_wheel2->scrollTo(m_wheel2->currentIndex() + QRandomGenerator::bounded(200));
39- m_wheel3->scrollTo(m_wheel3->currentIndex() + QRandomGenerator::bounded(200));
40+ m_wheel1->scrollTo(m_wheel1->currentIndex() + QRandomGenerator::global()->bounded(200));
41+ m_wheel2->scrollTo(m_wheel2->currentIndex() + QRandomGenerator::global()->bounded(200));
42+ m_wheel3->scrollTo(m_wheel3->currentIndex() + QRandomGenerator::global()->bounded(200));
43 }
44
45 private:
46--
472.19.0
48
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb
deleted file mode 100644
index 4b635bdf..00000000
--- a/recipes-qt/qt5/qtwebkit-examples_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1require qt5.inc
2require qt5-git.inc
3
4LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
5LIC_FILES_CHKSUM = " \
6 file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \
7 file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \
8 file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \
9 file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \
10 file://examples/webkitwidgets/scroller/wheel/main.cpp;endline=39;md5=b0739af76072fbe303dc04b6941e054f \
11 file://examples/webkitwidgets/imageanalyzer/imageanalyzer.cpp;endline=39;md5=b0739af76072fbe303dc04b6941e054f \
12"
13
14SRC_URI += "file://0001-Fix-build-with-qt-5.11.patch"
15
16PACKAGECONFIG ?= "examples"
17
18DEPENDS += "qtwebkit qtxmlpatterns"
19RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"
20RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}"
21
22QT_MODULE_BRANCH = "dev"
23
24SRCREV = "2d68492004bf4ba49cf58c9bd72706cb282cf59b"