summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-12-22 18:05:22 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-23 19:40:35 +0000
commit5443af98f1eb8a8726a0f833c578729e721ac80e (patch)
tree70eebb88901e11b857a59f9366e3504dd46361b2
parentbd9d830eb1eef7a8e9c41cba43723b46bb20e7bf (diff)
downloadmeta-qt5-5443af98f1eb8a8726a0f833c578729e721ac80e.tar.gz
qtwayland: revert one patch from 5.12 branch to make it compatible with 5.12.0 qtbase
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwayland/0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch560
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
2 files changed, 562 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch b/recipes-qt/qt5/qtwayland/0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch
new file mode 100644
index 00000000..2938fb2e
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch
@@ -0,0 +1,560 @@
1From 6a3be262635cff2811e6da6799c17980a0f67bef Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 22 Dec 2018 18:03:56 +0000
4Subject: [PATCH] Revert "use new feature name xkbcommon_evdev -> xkbcommon"
5
6This reverts commit a8fed20181729cae70de43079c4a34ad1780cfd7.
7
8To be compatible with qtbase 5.12.0, remove this patch when upgrading
9qtbase to 5.12.1
10---
11 README | 4 ++--
12 src/client/client.pro | 4 ++--
13 src/client/qwaylandinputdevice.cpp | 22 +++++++++----------
14 src/client/qwaylandinputdevice_p.h | 10 ++++-----
15 .../compositor_api/qwaylandcompositor.cpp | 2 +-
16 .../compositor_api/qwaylandkeyboard.cpp | 22 +++++++++----------
17 .../compositor_api/qwaylandkeyboard_p.h | 8 +++----
18 .../wayland_wrapper/wayland_wrapper.pri | 4 ++--
19 .../shellintegration/ivi-shell/ivi-shell.pro | 4 ++--
20 .../shellintegration/wl-shell/wl-shell.pro | 4 ++--
21 .../xdg-shell-v5/xdg-shell-v5.pro | 4 ++--
22 .../xdg-shell-v6/xdg-shell-v6.pro | 4 ++--
23 .../shellintegration/xdg-shell/xdg-shell.pro | 4 ++--
24 src/shared/qwaylandxkb.cpp | 10 ++++-----
25 src/shared/qwaylandxkb_p.h | 2 +-
26 .../auto/compositor/compositor/compositor.pro | 4 ++--
27 .../compositor/compositor/tst_compositor.cpp | 6 ++---
28 17 files changed, 59 insertions(+), 59 deletions(-)
29
30diff --git a/README b/README
31index bc6569ef..4fd99495 100644
32--- a/README
33+++ b/README
34@@ -9,8 +9,8 @@ QtWaylandCompositor API:
35 Enables the creation of Wayland compositors using Qt and QtQuick.
36
37 To build the QtWayland module you need the external dependencies:
38-xkbcommon - http://xkbcommon.org/
39-wayland - http://wayland.freedesktop.org/
40+xkbcommon 0.2.0 - http://xkbcommon.org/
41+wayland 1.6.0 - http://wayland.freedesktop.org/
42
43 QtWaylandCompositor supports loading client buffer integrations that don't use
44 the wayland-egl interfaces. These client buffer integrations are picked up by
45diff --git a/src/client/client.pro b/src/client/client.pro
46index 30f32dd7..45bbb976 100644
47--- a/src/client/client.pro
48+++ b/src/client/client.pro
49@@ -15,8 +15,8 @@ use_gold_linker: CONFIG += no_linker_version_script
50 CONFIG -= precompile_header
51 CONFIG += link_pkgconfig wayland-scanner
52
53-qtConfig(xkbcommon): \
54- QMAKE_USE_PRIVATE += xkbcommon
55+qtConfig(xkbcommon-evdev): \
56+ QMAKE_USE_PRIVATE += xkbcommon_evdev
57
58 QMAKE_USE += wayland-client
59
60diff --git a/src/client/qwaylandinputdevice.cpp b/src/client/qwaylandinputdevice.cpp
61index ba55e6e1..9d675ae2 100644
62--- a/src/client/qwaylandinputdevice.cpp
63+++ b/src/client/qwaylandinputdevice.cpp
64@@ -70,7 +70,7 @@
65
66 #include <QtGui/QGuiApplication>
67
68-#if QT_CONFIG(xkbcommon)
69+#if QT_CONFIG(xkbcommon_evdev)
70 #include <xkbcommon/xkbcommon-compose.h>
71 #endif
72
73@@ -84,7 +84,7 @@ QWaylandInputDevice::Keyboard::Keyboard(QWaylandInputDevice *p)
74 connect(&mRepeatTimer, SIGNAL(timeout()), this, SLOT(repeatKey()));
75 }
76
77-#if QT_CONFIG(xkbcommon)
78+#if QT_CONFIG(xkbcommon_evdev)
79 bool QWaylandInputDevice::Keyboard::createDefaultKeyMap()
80 {
81 if (mXkbContext && mXkbMap && mXkbState) {
82@@ -156,7 +156,7 @@ void QWaylandInputDevice::Keyboard::releaseComposeState()
83
84 QWaylandInputDevice::Keyboard::~Keyboard()
85 {
86-#if QT_CONFIG(xkbcommon)
87+#if QT_CONFIG(xkbcommon_evdev)
88 releaseComposeState();
89 releaseKeyMap();
90 #endif
91@@ -344,7 +344,7 @@ Qt::KeyboardModifiers QWaylandInputDevice::Keyboard::modifiers() const
92 {
93 Qt::KeyboardModifiers ret = Qt::NoModifier;
94
95-#if QT_CONFIG(xkbcommon)
96+#if QT_CONFIG(xkbcommon_evdev)
97 if (!mXkbState)
98 return ret;
99
100@@ -625,7 +625,7 @@ void QWaylandInputDevice::Pointer::pointer_axis(uint32_t time, uint32_t axis, in
101
102 void QWaylandInputDevice::Keyboard::keyboard_keymap(uint32_t format, int32_t fd, uint32_t size)
103 {
104-#if QT_CONFIG(xkbcommon)
105+#if QT_CONFIG(xkbcommon_evdev)
106 if (format != WL_KEYBOARD_KEYMAP_FORMAT_XKB_V1) {
107 close(fd);
108 return;
109@@ -728,7 +728,7 @@ void QWaylandInputDevice::Keyboard::keyboard_key(uint32_t serial, uint32_t time,
110 if (isDown)
111 mParent->mQDisplay->setLastInputDevice(mParent, serial, window);
112
113-#if QT_CONFIG(xkbcommon)
114+#if QT_CONFIG(xkbcommon_evdev)
115 if (!createDefaultKeyMap()) {
116 return;
117 }
118@@ -771,7 +771,7 @@ void QWaylandInputDevice::Keyboard::keyboard_key(uint32_t serial, uint32_t time,
119 #endif
120
121 if (state == WL_KEYBOARD_KEY_STATE_PRESSED
122-#if QT_CONFIG(xkbcommon)
123+#if QT_CONFIG(xkbcommon_evdev)
124 && xkb_keymap_key_repeats(mXkbMap, code)
125 #endif
126 ) {
127@@ -779,7 +779,7 @@ void QWaylandInputDevice::Keyboard::keyboard_key(uint32_t serial, uint32_t time,
128 mRepeatCode = code;
129 mRepeatTime = time;
130 mRepeatText = text;
131-#if QT_CONFIG(xkbcommon)
132+#if QT_CONFIG(xkbcommon_evdev)
133 mRepeatSym = sym;
134 #endif
135 mRepeatTimer.setInterval(400);
136@@ -793,7 +793,7 @@ void QWaylandInputDevice::Keyboard::repeatKey()
137 {
138 mRepeatTimer.setInterval(25);
139 sendKey(mFocus->window(), mRepeatTime, QEvent::KeyRelease, mRepeatKey, modifiers(), mRepeatCode,
140-#if QT_CONFIG(xkbcommon)
141+#if QT_CONFIG(xkbcommon_evdev)
142 mRepeatSym, mNativeModifiers,
143 #else
144 0, 0,
145@@ -801,7 +801,7 @@ void QWaylandInputDevice::Keyboard::repeatKey()
146 mRepeatText, true);
147
148 sendKey(mFocus->window(), mRepeatTime, QEvent::KeyPress, mRepeatKey, modifiers(), mRepeatCode,
149-#if QT_CONFIG(xkbcommon)
150+#if QT_CONFIG(xkbcommon_evdev)
151 mRepeatSym, mNativeModifiers,
152 #else
153 0, 0,
154@@ -816,7 +816,7 @@ void QWaylandInputDevice::Keyboard::keyboard_modifiers(uint32_t serial,
155 uint32_t group)
156 {
157 Q_UNUSED(serial);
158-#if QT_CONFIG(xkbcommon)
159+#if QT_CONFIG(xkbcommon_evdev)
160 if (mXkbState)
161 xkb_state_update_mask(mXkbState,
162 mods_depressed, mods_latched, mods_locked,
163diff --git a/src/client/qwaylandinputdevice_p.h b/src/client/qwaylandinputdevice_p.h
164index 7aa86539..4b12cc08 100644
165--- a/src/client/qwaylandinputdevice_p.h
166+++ b/src/client/qwaylandinputdevice_p.h
167@@ -65,7 +65,7 @@
168
169 #include <QtWaylandClient/private/qwayland-wayland.h>
170
171-#if QT_CONFIG(xkbcommon)
172+#if QT_CONFIG(xkbcommon_evdev)
173 #include <xkbcommon/xkbcommon.h>
174 #include <xkbcommon/xkbcommon-keysyms.h>
175 #endif
176@@ -77,7 +77,7 @@
177 struct wl_cursor_image;
178 #endif
179
180-#if QT_CONFIG(xkbcommon)
181+#if QT_CONFIG(xkbcommon_evdev)
182 struct xkb_compose_state;
183 struct xkb_compose_table;
184 #endif
185@@ -209,7 +209,7 @@ public:
186
187 QWaylandInputDevice *mParent = nullptr;
188 QPointer<QWaylandWindow> mFocus;
189-#if QT_CONFIG(xkbcommon)
190+#if QT_CONFIG(xkbcommon_evdev)
191 xkb_context *mXkbContext = nullptr;
192 xkb_keymap *mXkbMap = nullptr;
193 xkb_state *mXkbState = nullptr;
194@@ -222,7 +222,7 @@ public:
195 uint32_t mRepeatCode;
196 uint32_t mRepeatTime;
197 QString mRepeatText;
198-#if QT_CONFIG(xkbcommon)
199+#if QT_CONFIG(xkbcommon_evdev)
200 xkb_keysym_t mRepeatSym;
201 #endif
202 QTimer mRepeatTimer;
203@@ -233,7 +233,7 @@ private slots:
204 void repeatKey();
205
206 private:
207-#if QT_CONFIG(xkbcommon)
208+#if QT_CONFIG(xkbcommon_evdev)
209 bool createDefaultKeyMap();
210 void releaseKeyMap();
211 void createComposeState();
212diff --git a/src/compositor/compositor_api/qwaylandcompositor.cpp b/src/compositor/compositor_api/qwaylandcompositor.cpp
213index 173b50ce..c782304e 100644
214--- a/src/compositor/compositor_api/qwaylandcompositor.cpp
215+++ b/src/compositor/compositor_api/qwaylandcompositor.cpp
216@@ -128,7 +128,7 @@ public:
217 uint32_t code = ke->nativeScanCode;
218 bool isDown = ke->keyType == QEvent::KeyPress;
219
220-#if QT_CONFIG(xkbcommon)
221+#if QT_CONFIG(xkbcommon_evdev)
222 QString text;
223 Qt::KeyboardModifiers modifiers = QWaylandXkb::modifiers(keyb->xkbState());
224
225diff --git a/src/compositor/compositor_api/qwaylandkeyboard.cpp b/src/compositor/compositor_api/qwaylandkeyboard.cpp
226index 68d855a6..e067eeaf 100644
227--- a/src/compositor/compositor_api/qwaylandkeyboard.cpp
228+++ b/src/compositor/compositor_api/qwaylandkeyboard.cpp
229@@ -51,7 +51,7 @@
230
231 #include <fcntl.h>
232 #include <unistd.h>
233-#if QT_CONFIG(xkbcommon)
234+#if QT_CONFIG(xkbcommon_evdev)
235 #include <sys/mman.h>
236 #include <sys/types.h>
237 #include <qwaylandxkb_p.h>
238@@ -66,7 +66,7 @@ QWaylandKeyboardPrivate::QWaylandKeyboardPrivate(QWaylandSeat *seat)
239
240 QWaylandKeyboardPrivate::~QWaylandKeyboardPrivate()
241 {
242-#if QT_CONFIG(xkbcommon)
243+#if QT_CONFIG(xkbcommon_evdev)
244 if (xkb_context) {
245 if (keymap_area)
246 munmap(keymap_area, keymap_size);
247@@ -136,7 +136,7 @@ void QWaylandKeyboardPrivate::keyboard_bind_resource(wl_keyboard::Resource *reso
248 if (resource->version() >= WL_KEYBOARD_REPEAT_INFO_SINCE_VERSION)
249 send_repeat_info(resource->handle, repeatRate, repeatDelay);
250
251-#if QT_CONFIG(xkbcommon)
252+#if QT_CONFIG(xkbcommon_evdev)
253 if (xkb_context) {
254 send_keymap(resource->handle, WL_KEYBOARD_KEYMAP_FORMAT_XKB_V1,
255 keymap_fd, keymap_size);
256@@ -164,7 +164,7 @@ void QWaylandKeyboardPrivate::keyboard_release(wl_keyboard::Resource *resource)
257
258 void QWaylandKeyboardPrivate::keyEvent(uint code, uint32_t state)
259 {
260-#if QT_CONFIG(xkbcommon)
261+#if QT_CONFIG(xkbcommon_evdev)
262 uint key = toWaylandXkbV1Key(code);
263 #else
264 uint key = code;
265@@ -180,7 +180,7 @@ void QWaylandKeyboardPrivate::sendKeyEvent(uint code, uint32_t state)
266 {
267 uint32_t time = compositor()->currentTimeMsecs();
268 uint32_t serial = compositor()->nextSerial();
269-#if QT_CONFIG(xkbcommon)
270+#if QT_CONFIG(xkbcommon_evdev)
271 uint key = toWaylandXkbV1Key(code);
272 #else
273 uint key = code;
274@@ -197,7 +197,7 @@ void QWaylandKeyboardPrivate::modifiers(uint32_t serial, uint32_t mods_depressed
275 }
276 }
277
278-#if QT_CONFIG(xkbcommon)
279+#if QT_CONFIG(xkbcommon_evdev)
280 void QWaylandKeyboardPrivate::maybeUpdateXkbScanCodeTable()
281 {
282 if (!scanCodesByQtKey.isEmpty() || !xkbState())
283@@ -225,7 +225,7 @@ void QWaylandKeyboardPrivate::maybeUpdateXkbScanCodeTable()
284
285 void QWaylandKeyboardPrivate::updateModifierState(uint code, uint32_t state)
286 {
287-#if QT_CONFIG(xkbcommon)
288+#if QT_CONFIG(xkbcommon_evdev)
289 if (!xkb_context)
290 return;
291
292@@ -265,7 +265,7 @@ void QWaylandKeyboardPrivate::maybeUpdateKeymap()
293 return;
294
295 pendingKeymap = false;
296-#if QT_CONFIG(xkbcommon)
297+#if QT_CONFIG(xkbcommon_evdev)
298 if (!xkb_context)
299 return;
300
301@@ -285,7 +285,7 @@ void QWaylandKeyboardPrivate::maybeUpdateKeymap()
302 #endif
303 }
304
305-#if QT_CONFIG(xkbcommon)
306+#if QT_CONFIG(xkbcommon_evdev)
307 static int createAnonymousFile(size_t size)
308 {
309 QString path = QStandardPaths::writableLocation(QStandardPaths::RuntimeLocation);
310@@ -429,7 +429,7 @@ QWaylandKeyboard::QWaylandKeyboard(QWaylandSeat *seat, QObject *parent)
311 connect(keymap, &QWaylandKeymap::optionsChanged, this, &QWaylandKeyboard::updateKeymap);
312 connect(keymap, &QWaylandKeymap::rulesChanged, this, &QWaylandKeyboard::updateKeymap);
313 connect(keymap, &QWaylandKeymap::modelChanged, this, &QWaylandKeyboard::updateKeymap);
314-#if QT_CONFIG(xkbcommon)
315+#if QT_CONFIG(xkbcommon_evdev)
316 d->initXKB();
317 #endif
318 }
319@@ -592,7 +592,7 @@ void QWaylandKeyboard::addClient(QWaylandClient *client, uint32_t id, uint32_t v
320 uint QWaylandKeyboard::keyToScanCode(int qtKey) const
321 {
322 uint scanCode = 0;
323-#if QT_CONFIG(xkbcommon)
324+#if QT_CONFIG(xkbcommon_evdev)
325 Q_D(const QWaylandKeyboard);
326 const_cast<QWaylandKeyboardPrivate *>(d)->maybeUpdateXkbScanCodeTable();
327 scanCode = d->scanCodesByQtKey.value({d->group, qtKey}, 0);
328diff --git a/src/compositor/compositor_api/qwaylandkeyboard_p.h b/src/compositor/compositor_api/qwaylandkeyboard_p.h
329index 87e89e85..cd1f2795 100644
330--- a/src/compositor/compositor_api/qwaylandkeyboard_p.h
331+++ b/src/compositor/compositor_api/qwaylandkeyboard_p.h
332@@ -62,7 +62,7 @@
333
334 #include <QtCore/QVector>
335
336-#if QT_CONFIG(xkbcommon)
337+#if QT_CONFIG(xkbcommon_evdev)
338 #include <xkbcommon/xkbcommon.h>
339 #endif
340
341@@ -86,7 +86,7 @@ public:
342 void modifiers(uint32_t serial, uint32_t mods_depressed,
343 uint32_t mods_latched, uint32_t mods_locked, uint32_t group);
344
345-#if QT_CONFIG(xkbcommon)
346+#if QT_CONFIG(xkbcommon_evdev)
347 struct xkb_state *xkbState() const { return xkb_state; }
348 uint32_t xkbModsMask() const { return modsDepressed | modsLatched | modsLocked; }
349 void maybeUpdateXkbScanCodeTable();
350@@ -106,7 +106,7 @@ protected:
351 void keyboard_release(Resource *resource) override;
352
353 private:
354-#if QT_CONFIG(xkbcommon)
355+#if QT_CONFIG(xkbcommon_evdev)
356 void initXKB();
357 void createXKBKeymap();
358 void createXKBState(xkb_keymap *keymap);
359@@ -128,7 +128,7 @@ private:
360 uint32_t group = 0;
361
362 bool pendingKeymap = false;
363-#if QT_CONFIG(xkbcommon)
364+#if QT_CONFIG(xkbcommon_evdev)
365 size_t keymap_size;
366 int keymap_fd = -1;
367 char *keymap_area = nullptr;
368diff --git a/src/compositor/wayland_wrapper/wayland_wrapper.pri b/src/compositor/wayland_wrapper/wayland_wrapper.pri
369index 3041d769..e19ea253 100644
370--- a/src/compositor/wayland_wrapper/wayland_wrapper.pri
371+++ b/src/compositor/wayland_wrapper/wayland_wrapper.pri
372@@ -30,5 +30,5 @@ qtConfig(wayland-datadevice) {
373
374 INCLUDEPATH += wayland_wrapper
375
376-qtConfig(xkbcommon): \
377- QMAKE_USE += xkbcommon
378+qtConfig(xkbcommon-evdev): \
379+ QMAKE_USE += xkbcommon_evdev
380diff --git a/src/plugins/shellintegration/ivi-shell/ivi-shell.pro b/src/plugins/shellintegration/ivi-shell/ivi-shell.pro
381index 67e659ab..ba716c10 100644
382--- a/src/plugins/shellintegration/ivi-shell/ivi-shell.pro
383+++ b/src/plugins/shellintegration/ivi-shell/ivi-shell.pro
384@@ -3,8 +3,8 @@ CONFIG += wayland-scanner
385
386 QMAKE_USE += wayland-client
387
388-qtConfig(xkbcommon): \
389- QMAKE_USE += xkbcommon
390+qtConfig(xkbcommon-evdev): \
391+ QMAKE_USE += xkbcommon_evdev
392
393 WAYLANDCLIENTSOURCES += \
394 ../../../3rdparty/protocol/ivi-application.xml \
395diff --git a/src/plugins/shellintegration/wl-shell/wl-shell.pro b/src/plugins/shellintegration/wl-shell/wl-shell.pro
396index bb2c1829..fbff63c7 100644
397--- a/src/plugins/shellintegration/wl-shell/wl-shell.pro
398+++ b/src/plugins/shellintegration/wl-shell/wl-shell.pro
399@@ -2,8 +2,8 @@ QT += gui-private waylandclient-private
400 CONFIG += wayland-scanner
401
402 QMAKE_USE += wayland-client
403-qtConfig(xkbcommon): \
404- QMAKE_USE_PRIVATE += xkbcommon
405+qtConfig(xkbcommon-evdev): \
406+ QMAKE_USE_PRIVATE += xkbcommon_evdev
407
408 WAYLANDCLIENTSOURCES += \
409 ../../../3rdparty/protocol/wayland.xml
410diff --git a/src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro b/src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro
411index 4f6dde9b..bf9edba7 100644
412--- a/src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro
413+++ b/src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro
414@@ -3,8 +3,8 @@ CONFIG += wayland-scanner
415
416 QMAKE_USE += wayland-client
417
418-qtConfig(xkbcommon): \
419- QMAKE_USE += xkbcommon
420+qtConfig(xkbcommon-evdev): \
421+ QMAKE_USE += xkbcommon_evdev
422
423 HEADERS += \
424 qwaylandxdgpopupv5_p.h \
425diff --git a/src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro b/src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro
426index 3c1aaee8..5d5046f6 100644
427--- a/src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro
428+++ b/src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro
429@@ -2,8 +2,8 @@ QT += gui-private waylandclient-private
430 CONFIG += wayland-scanner
431
432 QMAKE_USE += wayland-client
433-qtConfig(xkbcommon): \
434- QMAKE_USE_PRIVATE += xkbcommon
435+qtConfig(xkbcommon-evdev): \
436+ QMAKE_USE_PRIVATE += xkbcommon_evdev
437
438 WAYLANDCLIENTSOURCES += \
439 ../../../3rdparty/protocol/xdg-shell-unstable-v6.xml
440diff --git a/src/plugins/shellintegration/xdg-shell/xdg-shell.pro b/src/plugins/shellintegration/xdg-shell/xdg-shell.pro
441index 26171584..2b1191af 100644
442--- a/src/plugins/shellintegration/xdg-shell/xdg-shell.pro
443+++ b/src/plugins/shellintegration/xdg-shell/xdg-shell.pro
444@@ -2,8 +2,8 @@ QT += gui-private waylandclient-private
445 CONFIG += wayland-scanner
446
447 QMAKE_USE += wayland-client
448-qtConfig(xkbcommon): \
449- QMAKE_USE_PRIVATE += xkbcommon
450+qtConfig(xkbcommon-evdev): \
451+ QMAKE_USE_PRIVATE += xkbcommon_evdev
452
453 WAYLANDCLIENTSOURCES += \
454 ../../../3rdparty/protocol/xdg-decoration-unstable-v1.xml \
455diff --git a/src/shared/qwaylandxkb.cpp b/src/shared/qwaylandxkb.cpp
456index 3cfc4b07..a0e388a1 100644
457--- a/src/shared/qwaylandxkb.cpp
458+++ b/src/shared/qwaylandxkb.cpp
459@@ -43,13 +43,13 @@
460 #include <QKeyEvent>
461 #include <QString>
462
463-#if QT_CONFIG(xkbcommon)
464+#if QT_CONFIG(xkbcommon_evdev)
465 #include <xkbcommon/xkbcommon-keysyms.h>
466 #endif
467
468 QT_BEGIN_NAMESPACE
469
470-#if QT_CONFIG(xkbcommon)
471+#if QT_CONFIG(xkbcommon_evdev)
472 static const uint32_t KeyTbl[] = {
473 XKB_KEY_Escape, Qt::Key_Escape,
474 XKB_KEY_Tab, Qt::Key_Tab,
475@@ -297,7 +297,7 @@ static xkb_keysym_t toKeysymFromTable(uint32_t key)
476
477 std::pair<int, QString> QWaylandXkb::keysymToQtKey(xkb_keysym_t keysym, Qt::KeyboardModifiers &modifiers)
478 {
479-#if QT_CONFIG(xkbcommon)
480+#if QT_CONFIG(xkbcommon_evdev)
481 QString text;
482 uint utf32 = xkb_keysym_to_utf32(keysym);
483 if (utf32)
484@@ -339,7 +339,7 @@ std::pair<int, QString> QWaylandXkb::keysymToQtKey(xkb_keysym_t keysym, Qt::Keyb
485
486 Qt::KeyboardModifiers QWaylandXkb::modifiers(struct xkb_state *state)
487 {
488-#if QT_CONFIG(xkbcommon)
489+#if QT_CONFIG(xkbcommon_evdev)
490 Qt::KeyboardModifiers modifiers = Qt::NoModifier;
491
492 xkb_state_component cstate = static_cast<xkb_state_component>(XKB_STATE_DEPRESSED | XKB_STATE_LATCHED | XKB_STATE_LOCKED);
493@@ -367,7 +367,7 @@ QEvent::Type QWaylandXkb::toQtEventType(uint32_t state)
494
495 QVector<xkb_keysym_t> QWaylandXkb::toKeysym(QKeyEvent *event)
496 {
497-#if QT_CONFIG(xkbcommon)
498+#if QT_CONFIG(xkbcommon_evdev)
499 QVector<xkb_keysym_t> keysyms;
500 if (event->key() >= Qt::Key_F1 && event->key() <= Qt::Key_F35) {
501 keysyms.append(XKB_KEY_F1 + (event->key() - Qt::Key_F1));
502diff --git a/src/shared/qwaylandxkb_p.h b/src/shared/qwaylandxkb_p.h
503index 4820d94b..6fa1ea45 100644
504--- a/src/shared/qwaylandxkb_p.h
505+++ b/src/shared/qwaylandxkb_p.h
506@@ -45,7 +45,7 @@
507 #include <Qt>
508 #include <QEvent>
509
510-#if QT_CONFIG(xkbcommon)
511+#if QT_CONFIG(xkbcommon_evdev)
512 #include <xkbcommon/xkbcommon.h>
513 #else
514 typedef quint32 xkb_keysym_t;
515diff --git a/tests/auto/compositor/compositor/compositor.pro b/tests/auto/compositor/compositor/compositor.pro
516index 0ce2c6be..d69db4ca 100644
517--- a/tests/auto/compositor/compositor/compositor.pro
518+++ b/tests/auto/compositor/compositor/compositor.pro
519@@ -7,8 +7,8 @@ QT += core-private gui-private waylandcompositor waylandcompositor-private
520
521 QMAKE_USE += wayland-client wayland-server
522
523-qtConfig(xkbcommon): \
524- QMAKE_USE += xkbcommon
525+qtConfig(xkbcommon-evdev): \
526+ QMAKE_USE += xkbcommon_evdev
527
528 WAYLANDCLIENTSOURCES += \
529 ../../../../src/3rdparty/protocol/xdg-shell-unstable-v5.xml \
530diff --git a/tests/auto/compositor/compositor/tst_compositor.cpp b/tests/auto/compositor/compositor/tst_compositor.cpp
531index 97e650d9..a8af4c39 100644
532--- a/tests/auto/compositor/compositor/tst_compositor.cpp
533+++ b/tests/auto/compositor/compositor/tst_compositor.cpp
534@@ -58,7 +58,7 @@ class tst_WaylandCompositor : public QObject
535 private slots:
536 void init();
537 void seatCapabilities();
538-#if QT_CONFIG(xkbcommon)
539+#if QT_CONFIG(xkbcommon_evdev)
540 void simpleKeyboard();
541 void keyboardKeymaps();
542 void keyboardLayoutSwitching();
543@@ -170,7 +170,7 @@ void tst_WaylandCompositor::multipleClients()
544 QTRY_COMPARE(compositor.surfaces.size(), 0);
545 }
546
547-#if QT_CONFIG(xkbcommon)
548+#if QT_CONFIG(xkbcommon_evdev)
549
550 void tst_WaylandCompositor::simpleKeyboard()
551 {
552@@ -283,7 +283,7 @@ void tst_WaylandCompositor::keyboardLayoutSwitching()
553 QTRY_COMPARE(mockKeyboard->m_lastKeyCode, 44u);
554 }
555
556-#endif // QT_CONFIG(xkbcommon)
557+#endif // QT_CONFIG(xkbcommon_evdev)
558
559 void tst_WaylandCompositor::keyboardGrab()
560 {
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 56c6444e..a1b38de2 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,3 +44,5 @@ BBCLASSEXTEND =+ "native nativesdk"
44# The same issue as in qtbase: 44# The same issue as in qtbase:
45# http://errors.yoctoproject.org/Errors/Details/152641/ 45# http://errors.yoctoproject.org/Errors/Details/152641/
46LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 46LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
47
48SRC_URI += "file://0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch"