summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-12-22 16:50:47 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-23 19:40:35 +0000
commitbd9d830eb1eef7a8e9c41cba43723b46bb20e7bf (patch)
tree9d7f6ff1a82489be15c3642e6533555a25690196
parent44f4fc3a07d810a227249307e38acff7fba059c4 (diff)
downloadmeta-qt5-bd9d830eb1eef7a8e9c41cba43723b46bb20e7bf.tar.gz
qt3d-runtime: drop patch resolved upstream
* resolved in upstream commit: commit 5651638d8a9d45af8ea6cdc71dc9b8b843103d2b Author: Samuli Piippo <samuli.piippo@qt.io> Date: Fri Oct 19 12:11:02 2018 +0300 Add missing include header Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch29
-rw-r--r--recipes-qt/qt5/qt3d-runtime_git.bb2
2 files changed, 0 insertions, 31 deletions
diff --git a/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch b/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch
deleted file mode 100644
index bc61e538..00000000
--- a/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From e6247a6823d372cc779934cf6c74d65bae9652b5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 23 Aug 2018 03:23:20 +0000
4Subject: [PATCH] runtime: Include missing <QCoreApplication> header
5
6Fixes following errors seen on mips
7
8q3dsengine.cpp:1327:9: error: 'QCoreApplication' has not been declared
9 QCoreApplication::sendEvent(&m_profileUiEventSource, e);
10 ^~~~~~~~~~~~~~~~
11
12Upstream-Status: Pending
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/runtime/q3dsengine.cpp | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/src/runtime/q3dsengine.cpp b/src/runtime/q3dsengine.cpp
19index 1a438f0..d6d4eb5 100644
20--- a/src/runtime/q3dsengine.cpp
21+++ b/src/runtime/q3dsengine.cpp
22@@ -36,6 +36,7 @@
23 #include "q3dsinlineqmlsubpresentation_p.h"
24 #include "q3dsviewersettings.h"
25
26+#include <QCoreApplication>
27 #include <QLoggingCategory>
28 #include <QKeyEvent>
29 #include <QMouseEvent>
diff --git a/recipes-qt/qt5/qt3d-runtime_git.bb b/recipes-qt/qt5/qt3d-runtime_git.bb
index 2b017106..8df143ae 100644
--- a/recipes-qt/qt5/qt3d-runtime_git.bb
+++ b/recipes-qt/qt5/qt3d-runtime_git.bb
@@ -7,8 +7,6 @@ LIC_FILES_CHKSUM = " \
7 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \ 7 file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
8" 8"
9 9
10SRC_URI += "file://0001-runtime-Include-missing-QCoreApplication-header.patch"
11
12DEPENDS += "qtbase qtdeclarative qt3d" 10DEPENDS += "qtbase qtdeclarative qt3d"
13 11
14QT_MODULE_BRANCH = "2.2" 12QT_MODULE_BRANCH = "2.2"