summaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2-native_2.4.3.bb36
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb126
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb2
-rw-r--r--meta-webserver/recipes-php/modphp/modphp5.inc56
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_3.5.2.2.bb8
-rw-r--r--meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb14
-rw-r--r--meta-webserver/recipes-webadmin/ajenti/ajenti_git.bb30
7 files changed, 136 insertions, 136 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.3.bb b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.3.bb
index 230510c05..064e6bdb4 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.3.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.3.bb
@@ -18,26 +18,26 @@ SRC_URI[md5sum] = "87aaf7bc7e8715f0455997bb8c6791aa"
18SRC_URI[sha256sum] = "d82102b9c111f1892fb20a2bccf4370de579c6521b2f172ed0b36f2759fb249e" 18SRC_URI[sha256sum] = "d82102b9c111f1892fb20a2bccf4370de579c6521b2f172ed0b36f2759fb249e"
19 19
20do_configure () { 20do_configure () {
21 ./configure --with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ 21 ./configure --with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
22 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \ 22 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \
23 --prefix=${prefix} --datadir=${datadir}/apache2 23 --prefix=${prefix} --datadir=${datadir}/apache2
24} 24}
25 25
26do_install () { 26do_install () {
27 install -d ${D}${bindir} ${D}${libdir} 27 install -d ${D}${bindir} ${D}${libdir}
28 cp server/gen_test_char ${D}${bindir} 28 cp server/gen_test_char ${D}${bindir}
29 install -m 755 support/apxs ${D}${bindir}/ 29 install -m 755 support/apxs ${D}${bindir}/
30 install -m 755 httpd ${D}${bindir}/ 30 install -m 755 httpd ${D}${bindir}/
31 install -d ${D}${datadir}/apache2/build 31 install -d ${D}${datadir}/apache2/build
32 cp build/*.mk ${D}${datadir}/apache2/build 32 cp build/*.mk ${D}${datadir}/apache2/build
33 cp build/instdso.sh ${D}${datadir}/apache2/build 33 cp build/instdso.sh ${D}${datadir}/apache2/build
34 34
35 install -d ${D}${includedir}/apache2 35 install -d ${D}${includedir}/apache2
36 cp include/* ${D}${includedir}/apache2 36 cp include/* ${D}${includedir}/apache2
37 cp os/unix/os.h ${D}${includedir}/apache2 37 cp os/unix/os.h ${D}${includedir}/apache2
38 cp os/unix/unixd.h ${D}${includedir}/apache2 38 cp os/unix/unixd.h ${D}${includedir}/apache2
39 39
40 cp support/envvars-std ${D}${bindir}/envvars 40 cp support/envvars-std ${D}${bindir}/envvars
41 chmod 755 ${D}${bindir}/envvars 41 chmod 755 ${D}${bindir}/envvars
42} 42}
43 43
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
index a221e1da7..a7f358666 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.3.bb
@@ -30,67 +30,67 @@ inherit autotools update-rc.d
30CFLAGS_append = " -DPATH_MAX=4096" 30CFLAGS_append = " -DPATH_MAX=4096"
31CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl " 31CFLAGS_prepend = "-I${STAGING_INCDIR}/openssl "
32EXTRA_OECONF = "--enable-ssl \ 32EXTRA_OECONF = "--enable-ssl \
33 --with-ssl=${STAGING_LIBDIR}/.. \ 33 --with-ssl=${STAGING_LIBDIR}/.. \
34 --with-expat=${STAGING_LIBDIR}/.. \ 34 --with-expat=${STAGING_LIBDIR}/.. \
35 --with-apr=${WORKDIR}/apr-1-config \ 35 --with-apr=${WORKDIR}/apr-1-config \
36 --with-apr-util=${WORKDIR}/apu-1-config \ 36 --with-apr-util=${WORKDIR}/apu-1-config \
37 --enable-info \ 37 --enable-info \
38 --enable-rewrite \ 38 --enable-rewrite \
39 --with-dbm=sdbm \ 39 --with-dbm=sdbm \
40 --with-berkeley-db=no \ 40 --with-berkeley-db=no \
41 --localstatedir=/var/${PN} \ 41 --localstatedir=/var/${PN} \
42 --with-gdbm=no \ 42 --with-gdbm=no \
43 --with-ndbm=no \ 43 --with-ndbm=no \
44 --includedir=${includedir}/${PN} \ 44 --includedir=${includedir}/${PN} \
45 --datadir=${datadir}/${PN} \ 45 --datadir=${datadir}/${PN} \
46 --sysconfdir=${sysconfdir}/${PN} \ 46 --sysconfdir=${sysconfdir}/${PN} \
47 --libexecdir=${libdir}/${PN}/modules \ 47 --libexecdir=${libdir}/${PN}/modules \
48 ap_cv_void_ptr_lt_long=no \ 48 ap_cv_void_ptr_lt_long=no \
49 --enable-mpms-shared \ 49 --enable-mpms-shared \
50 ac_cv_have_threadsafe_pollset=no" 50 ac_cv_have_threadsafe_pollset=no"
51 51
52do_configure_prepend() { 52do_configure_prepend() {
53 # FIXME: this hack is required to work around an issue with apr/apr-util 53 # FIXME: this hack is required to work around an issue with apr/apr-util
54 # Can be removed when fixed in OE-Core (also revert --with-* options above) 54 # Can be removed when fixed in OE-Core (also revert --with-* options above)
55 # see http://bugzilla.yoctoproject.org/show_bug.cgi?id=3267 55 # see http://bugzilla.yoctoproject.org/show_bug.cgi?id=3267
56 cp ${STAGING_BINDIR_CROSS}/apr-1-config ${STAGING_BINDIR_CROSS}/apu-1-config ${WORKDIR} 56 cp ${STAGING_BINDIR_CROSS}/apr-1-config ${STAGING_BINDIR_CROSS}/apu-1-config ${WORKDIR}
57 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apr-1-config 57 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apr-1-config
58 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apu-1-config 58 sed -i -e 's:location=source:location=installed:' ${WORKDIR}/apu-1-config
59} 59}
60 60
61do_install_append() { 61do_install_append() {
62 install -d ${D}/${sysconfdir}/init.d 62 install -d ${D}/${sysconfdir}/init.d
63 cat ${WORKDIR}/init | \ 63 cat ${WORKDIR}/init | \
64 sed -e 's,/usr/sbin/,${sbindir}/,g' \ 64 sed -e 's,/usr/sbin/,${sbindir}/,g' \
65 -e 's,/usr/bin/,${bindir}/,g' \ 65 -e 's,/usr/bin/,${bindir}/,g' \
66 -e 's,/usr/lib,${libdir}/,g' \ 66 -e 's,/usr/lib,${libdir}/,g' \
67 -e 's,/etc/,${sysconfdir}/,g' \ 67 -e 's,/etc/,${sysconfdir}/,g' \
68 -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/${PN} 68 -e 's,/usr/,${prefix}/,g' > ${D}/${sysconfdir}/init.d/${PN}
69 chmod 755 ${D}/${sysconfdir}/init.d/${PN} 69 chmod 755 ${D}/${sysconfdir}/init.d/${PN}
70 # remove the goofy original files... 70 # remove the goofy original files...
71 rm -rf ${D}/${sysconfdir}/${PN}/original 71 rm -rf ${D}/${sysconfdir}/${PN}/original
72 # Expat should be found in the staging area via DEPENDS... 72 # Expat should be found in the staging area via DEPENDS...
73 rm -f ${D}/${libdir}/libexpat.* 73 rm -f ${D}/${libdir}/libexpat.*
74 74
75 install -d ${D}${sysconfdir}/${PN}/conf.d 75 install -d ${D}${sysconfdir}/${PN}/conf.d
76 install -d ${D}${sysconfdir}/${PN}/modules.d 76 install -d ${D}${sysconfdir}/${PN}/modules.d
77 77
78 # Ensure configuration file pulls in conf.d and modules.d 78 # Ensure configuration file pulls in conf.d and modules.d
79 printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf 79 printf "\nIncludeOptional ${sysconfdir}/${PN}/conf.d/*.conf" >> ${D}/${sysconfdir}/${PN}/httpd.conf
80 printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf 80 printf "\nIncludeOptional ${sysconfdir}/${PN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${PN}/httpd.conf
81} 81}
82 82
83SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess" 83SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess"
84 84
85apache_sysroot_preprocess () { 85apache_sysroot_preprocess () {
86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
87 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 87 install -m 755 ${D}${bindir}/apxs ${SYSROOT_DESTDIR}${bindir_crossscripts}/
88 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${PN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 88 sed -i 's!my $installbuilddir = .*!my $installbuilddir = "${STAGING_DIR_HOST}/${datadir}/${PN}/build";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
89 sed -i 's!my $libtool = .*!my $libtool = "${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs 89 sed -i 's!my $libtool = .*!my $libtool = "${STAGING_BINDIR_CROSS}/${TARGET_PREFIX}libtool";!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/apxs
90 90
91 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 91 sed -i 's!^APR_CONFIG = .*!APR_CONFIG = ${STAGING_BINDIR_CROSS}/apr-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
92 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 92 sed -i 's!^APU_CONFIG = .*!APU_CONFIG = ${STAGING_BINDIR_CROSS}/apu-1-config!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
93 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk 93 sed -i 's!^includedir = .*!includedir = ${STAGING_INCDIR}/apache2!' ${SYSROOT_DESTDIR}${datadir}/${PN}/build/config_vars.mk
94} 94}
95 95
96# 96#
@@ -103,21 +103,21 @@ LEAD_SONAME = "libapr-1.so.0"
103PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}" 103PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
104 104
105CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \ 105CONFFILES_${PN} = "${sysconfdir}/${PN}/httpd.conf \
106 ${sysconfdir}/${PN}/magic \ 106 ${sysconfdir}/${PN}/magic \
107 ${sysconfdir}/${PN}/mime.types \ 107 ${sysconfdir}/${PN}/mime.types \
108 ${sysconfdir}/init.d/${PN} " 108 ${sysconfdir}/init.d/${PN} "
109 109
110# we override here rather than append so that .so links are 110# we override here rather than append so that .so links are
111# included in the runtime package rather than here (-dev) 111# included in the runtime package rather than here (-dev)
112# and to get build, icons, error into the -dev package 112# and to get build, icons, error into the -dev package
113FILES_${PN}-dev = "${datadir}/${PN}/build \ 113FILES_${PN}-dev = "${datadir}/${PN}/build \
114 ${datadir}/${PN}/icons \ 114 ${datadir}/${PN}/icons \
115 ${datadir}/${PN}/error \ 115 ${datadir}/${PN}/error \
116 ${bindir}/apr-config ${bindir}/apu-config \ 116 ${bindir}/apr-config ${bindir}/apu-config \
117 ${libdir}/apr*.exp \ 117 ${libdir}/apr*.exp \
118 ${includedir}/${PN} \ 118 ${includedir}/${PN} \
119 ${libdir}/*.la \ 119 ${libdir}/*.la \
120 ${libdir}/*.a" 120 ${libdir}/*.a"
121 121
122# manual to manual 122# manual to manual
123FILES_${PN}-doc += " ${datadir}/${PN}/manual" 123FILES_${PN}-doc += " ${datadir}/${PN}/manual"
@@ -126,8 +126,8 @@ FILES_${PN}-doc += " ${datadir}/${PN}/manual"
126# override this too - here is the default, less datadir 126# override this too - here is the default, less datadir
127# 127#
128FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* ${sysconfdir} \ 128FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* ${sysconfdir} \
129 ${sharedstatedir} ${localstatedir} /bin /sbin /lib/*.so* \ 129 ${sharedstatedir} ${localstatedir} /bin /sbin /lib/*.so* \
130 ${libdir}/${PN}" 130 ${libdir}/${PN}"
131 131
132# we want htdocs and cgi-bin to go with the binary 132# we want htdocs and cgi-bin to go with the binary
133FILES_${PN} += "${datadir}/${PN}/htdocs ${datadir}/${PN}/cgi-bin" 133FILES_${PN} += "${datadir}/${PN}/htdocs ${datadir}/${PN}/cgi-bin"
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb
index 9e4f11982..a7299708d 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb
@@ -52,4 +52,4 @@ CONFFILES_${PN} = " \
52 ${sysconfdir}/hiawatha/index.xslt \ 52 ${sysconfdir}/hiawatha/index.xslt \
53 ${sysconfdir}/hiawatha/mimetype.conf \ 53 ${sysconfdir}/hiawatha/mimetype.conf \
54 ${sysconfdir}/hiawatha/php-fcgi.conf \ 54 ${sysconfdir}/hiawatha/php-fcgi.conf \
55 " 55"
diff --git a/meta-webserver/recipes-php/modphp/modphp5.inc b/meta-webserver/recipes-php/modphp/modphp5.inc
index fdf7b1857..a49dc7523 100644
--- a/meta-webserver/recipes-php/modphp/modphp5.inc
+++ b/meta-webserver/recipes-php/modphp/modphp5.inc
@@ -9,7 +9,7 @@ SRC_URI = "http://www.php.net/distributions/php-${PV}.tar.bz2 \
9 file://pthread-check-threads-m4.patch \ 9 file://pthread-check-threads-m4.patch \
10 file://70_mod_php5.conf \ 10 file://70_mod_php5.conf \
11 file://php-5.3.14-aconf259.patch \ 11 file://php-5.3.14-aconf259.patch \
12 " 12"
13 13
14S = "${WORKDIR}/php-${PV}" 14S = "${WORKDIR}/php-${PV}"
15 15
@@ -50,45 +50,45 @@ PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--witho
50acpaths = "" 50acpaths = ""
51 51
52do_configure_prepend () { 52do_configure_prepend () {
53 rm -f build/libtool.m4 ltmain.sh aclocal.m4 53 rm -f build/libtool.m4 ltmain.sh aclocal.m4
54 find . -name config.m4 | xargs -n1 sed -i 's!APXS_HTTPD=.*!APXS_HTTPD=${STAGING_BINDIR_NATIVE}/httpd!' 54 find . -name config.m4 | xargs -n1 sed -i 's!APXS_HTTPD=.*!APXS_HTTPD=${STAGING_BINDIR_NATIVE}/httpd!'
55} 55}
56 56
57do_configure_append() { 57do_configure_append() {
58 # No libtool, we really don't want rpath set... 58 # No libtool, we really don't want rpath set...
59 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${HOST_SYS}-libtool 59 sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' ${HOST_SYS}-libtool
60 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${HOST_SYS}-libtool 60 sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' ${HOST_SYS}-libtool
61} 61}
62 62
63do_install () { 63do_install () {
64 install -d ${D}${libdir}/apache2/modules 64 install -d ${D}${libdir}/apache2/modules
65 install -d ${D}${sysconfdir}/apache2/modules.d 65 install -d ${D}${sysconfdir}/apache2/modules.d
66 install -d ${D}${sysconfdir}/php/apache2-php5 66 install -d ${D}${sysconfdir}/php/apache2-php5
67 install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules 67 install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules
68 sed -i s,lib/,${libdir}/, ${WORKDIR}/70_mod_php5.conf 68 sed -i s,lib/,${libdir}/, ${WORKDIR}/70_mod_php5.conf
69 install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d 69 install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d
70 cat ${S}/php.ini-production | \ 70 cat ${S}/php.ini-production | \
71 sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \ 71 sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \
72 > ${D}${sysconfdir}/php/apache2-php5/php.ini 72 > ${D}${sysconfdir}/php/apache2-php5/php.ini
73 73
74 install -d ${D}${bindir} 74 install -d ${D}${bindir}
75 install -m 755 scripts/phpize ${D}${bindir} 75 install -m 755 scripts/phpize ${D}${bindir}
76 install -m 755 scripts/php-config ${D}${bindir} 76 install -m 755 scripts/php-config ${D}${bindir}
77 cat aclocal-copy/libtool.m4 aclocal-copy/lt~obsolete.m4 aclocal-copy/ltoptions.m4 \ 77 cat aclocal-copy/libtool.m4 aclocal-copy/lt~obsolete.m4 aclocal-copy/ltoptions.m4 \
78 aclocal-copy/ltsugar.m4 aclocal-copy/ltversion.m4 > build/libtool.m4 78 aclocal-copy/ltsugar.m4 aclocal-copy/ltversion.m4 > build/libtool.m4
79 79
80 oe_runmake install-build install-headers INSTALL_ROOT=${D} 80 oe_runmake install-build install-headers INSTALL_ROOT=${D}
81} 81}
82 82
83SYSROOT_PREPROCESS_FUNCS += "php_sysroot_preprocess" 83SYSROOT_PREPROCESS_FUNCS += "php_sysroot_preprocess"
84 84
85php_sysroot_preprocess () { 85php_sysroot_preprocess () {
86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 86 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
87 install -m 755 ${D}${bindir}/phpize ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 87 install -m 755 ${D}${bindir}/phpize ${SYSROOT_DESTDIR}${bindir_crossscripts}/
88 install -m 755 ${D}${bindir}/php-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/ 88 install -m 755 ${D}${bindir}/php-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
89 89
90 sed -i 's!eval echo /!eval echo ${STAGING_DIR_HOST}/!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/phpize 90 sed -i 's!eval echo /!eval echo ${STAGING_DIR_HOST}/!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/phpize
91 sed -i 's!^include_dir=.*!include_dir=${STAGING_INCDIR}/php!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/php-config 91 sed -i 's!^include_dir=.*!include_dir=${STAGING_INCDIR}/php!' ${SYSROOT_DESTDIR}${bindir_crossscripts}/php-config
92} 92}
93 93
94RDEPENDS_${PN} = "apache2" 94RDEPENDS_${PN} = "apache2"
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_3.5.2.2.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_3.5.2.2.bb
index 1118e2371..996aa6363 100644
--- a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_3.5.2.2.bb
+++ b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_3.5.2.2.bb
@@ -18,11 +18,11 @@ S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
18inherit allarch 18inherit allarch
19 19
20do_install() { 20do_install() {
21 install -d ${D}${datadir}/${BPN} 21 install -d ${D}${datadir}/${BPN}
22 cp -a * ${D}${datadir}/${BPN} 22 cp -a * ${D}${datadir}/${BPN}
23 23
24 install -d ${D}${sysconfdir}/apache2/conf.d 24 install -d ${D}${sysconfdir}/apache2/conf.d
25 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf 25 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
26} 26}
27 27
28FILES_${PN} = "${datadir}/${BPN} \ 28FILES_${PN} = "${datadir}/${BPN} \
diff --git a/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb b/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb
index 48e1f8e58..d09473c9c 100644
--- a/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb
+++ b/meta-webserver/recipes-php/xdebug/xdebug_2.2.1.bb
@@ -16,17 +16,17 @@ inherit autotools
16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" 16EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
17 17
18do_configure() { 18do_configure() {
19 ${STAGING_BINDIR_CROSS}/phpize 19 ${STAGING_BINDIR_CROSS}/phpize
20 20
21 # Running autoreconf as autotools_do_configure would do here 21 # Running autoreconf as autotools_do_configure would do here
22 # breaks the libtool configuration resulting in a failure later 22 # breaks the libtool configuration resulting in a failure later
23 # in do_compile. It's possible this may be fixable, however the 23 # in do_compile. It's possible this may be fixable, however the
24 # easiest course of action for the moment is to avoid doing that. 24 # easiest course of action for the moment is to avoid doing that.
25 oe_runconf 25 oe_runconf
26} 26}
27 27
28do_install() { 28do_install() {
29 oe_runmake install INSTALL_ROOT=${D} 29 oe_runmake install INSTALL_ROOT=${D}
30} 30}
31 31
32FILES_${PN} += "${libdir}/php5/extensions/*/*.so" 32FILES_${PN} += "${libdir}/php5/extensions/*/*.so"
diff --git a/meta-webserver/recipes-webadmin/ajenti/ajenti_git.bb b/meta-webserver/recipes-webadmin/ajenti/ajenti_git.bb
index dc1508eba..83e92f6ae 100644
--- a/meta-webserver/recipes-webadmin/ajenti/ajenti_git.bb
+++ b/meta-webserver/recipes-webadmin/ajenti/ajenti_git.bb
@@ -36,22 +36,22 @@ do_configure_prepend() {
36} 36}
37 37
38do_install_append() { 38do_install_append() {
39 install -d ${D}${sysconfdir} 39 install -d ${D}${sysconfdir}
40 install -d ${D}${sysconfdir}/ajenti 40 install -d ${D}${sysconfdir}/ajenti
41 install -m 0644 packaging/files/ajenti.conf ${D}${sysconfdir}/ajenti/ 41 install -m 0644 packaging/files/ajenti.conf ${D}${sysconfdir}/ajenti/
42 install -d ${D}${sysconfdir}/ajenti/users 42 install -d ${D}${sysconfdir}/ajenti/users
43 install -m 0644 packaging/files/admin.conf ${D}${sysconfdir}/ajenti/users/ 43 install -m 0644 packaging/files/admin.conf ${D}${sysconfdir}/ajenti/users/
44 install -d ${D}${sysconfdir}/init.d 44 install -d ${D}${sysconfdir}/init.d
45 install -m 0755 packaging/files/ajenti ${D}${sysconfdir}/init.d/ 45 install -m 0755 packaging/files/ajenti ${D}${sysconfdir}/init.d/
46 install -d ${D}${localstatedir} 46 install -d ${D}${localstatedir}
47 install -d ${D}${localstatedir}/lib 47 install -d ${D}${localstatedir}/lib
48 install -d ${D}${localstatedir}/lib/ajenti 48 install -d ${D}${localstatedir}/lib/ajenti
49 install -d ${D}${localstatedir}/lib/ajenti/plugins 49 install -d ${D}${localstatedir}/lib/ajenti/plugins
50 install -m 0644 packaging/files/.placeholder ${D}${localstatedir}/lib/ajenti/plugins 50 install -m 0644 packaging/files/.placeholder ${D}${localstatedir}/lib/ajenti/plugins
51 51
52 for plugin in plugins/* ; do 52 for plugin in plugins/* ; do
53 cp -r $plugin ${D}${localstatedir}/lib/ajenti/plugins/ 53 cp -r $plugin ${D}${localstatedir}/lib/ajenti/plugins/
54 done 54 done
55} 55}
56 56
57INITSCRIPT_NAME = "ajenti" 57INITSCRIPT_NAME = "ajenti"