summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-parse.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-parse_1.8.4.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.8.4.bb2
3 files changed, 18 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-parse.inc b/meta-python/recipes-devtools/python/python-parse.inc
new file mode 100644
index 0000000000..fa55a93c5d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-parse.inc
@@ -0,0 +1,14 @@
1SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1"
5
6SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b"
7SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939"
8
9inherit pypi
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 "
diff --git a/meta-python/recipes-devtools/python/python-parse_1.8.4.bb b/meta-python/recipes-devtools/python/python-parse_1.8.4.bb
index c66d4c8a21..d31ccc72a1 100644
--- a/meta-python/recipes-devtools/python/python-parse_1.8.4.bb
+++ b/meta-python/recipes-devtools/python/python-parse_1.8.4.bb
@@ -1,13 +1,2 @@
1SUMMARY = "Parse strings using a specification based on the Python format() syntax" 1inherit setuptools
2LICENSE = "BSD" 2require python-parse.inc
3LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1"
4
5SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b"
6SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939"
7
8inherit pypi setuptools
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-logging \
13 "
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb b/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb
new file mode 100644
index 0000000000..b1242545cc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-parse.inc