diff options
author | Robert Joslyn <robert.joslyn@redrectangle.org> | 2018-08-02 20:27:02 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-03 09:34:29 -0700 |
commit | 4f39906e1c40cff080dae42abed8631b155e42c7 (patch) | |
tree | 971de567f02b5f9aea2e4b12a090d7587e0db55e /meta-python | |
parent | edc253a4d2d5e6e6e52ff9aff2a1bb023cf7e449 (diff) | |
download | meta-openembedded-4f39906e1c40cff080dae42abed8631b155e42c7.tar.gz |
python3-parse: Add recipe
Correct the license to MIT. The PyPI metadata says BSD, but the license
text in the code is actually MIT.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
3 files changed, 18 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-parse.inc b/meta-python/recipes-devtools/python/python-parse.inc new file mode 100644 index 0000000000..fa55a93c5d --- /dev/null +++ b/meta-python/recipes-devtools/python/python-parse.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "Parse strings using a specification based on the Python format() syntax" | ||
2 | HOMEPAGE = "https://github.com/r1chardj0n3s/parse" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1" | ||
5 | |||
6 | SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b" | ||
7 | SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939" | ||
8 | |||
9 | inherit pypi | ||
10 | |||
11 | RDEPENDS_${PN} += "\ | ||
12 | ${PYTHON_PN}-datetime \ | ||
13 | ${PYTHON_PN}-logging \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-parse_1.8.4.bb b/meta-python/recipes-devtools/python/python-parse_1.8.4.bb index c66d4c8a21..d31ccc72a1 100644 --- a/meta-python/recipes-devtools/python/python-parse_1.8.4.bb +++ b/meta-python/recipes-devtools/python/python-parse_1.8.4.bb | |||
@@ -1,13 +1,2 @@ | |||
1 | SUMMARY = "Parse strings using a specification based on the Python format() syntax" | 1 | inherit setuptools |
2 | LICENSE = "BSD" | 2 | require python-parse.inc |
3 | LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1" | ||
4 | |||
5 | SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b" | ||
6 | SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939" | ||
7 | |||
8 | inherit pypi setuptools | ||
9 | |||
10 | RDEPENDS_${PN} += "\ | ||
11 | ${PYTHON_PN}-datetime \ | ||
12 | ${PYTHON_PN}-logging \ | ||
13 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb b/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb new file mode 100644 index 0000000000..b1242545cc --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-parse.inc | ||