summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-08-02 20:27:02 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commit4f39906e1c40cff080dae42abed8631b155e42c7 (patch)
tree971de567f02b5f9aea2e4b12a090d7587e0db55e /meta-python
parentedc253a4d2d5e6e6e52ff9aff2a1bb023cf7e449 (diff)
downloadmeta-openembedded-4f39906e1c40cff080dae42abed8631b155e42c7.tar.gz
python3-parse: Add recipe
Correct the license to MIT. The PyPI metadata says BSD, but the license text in the code is actually MIT. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-parse.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-parse_1.8.4.bb15
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.8.4.bb2
3 files changed, 18 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-parse.inc b/meta-python/recipes-devtools/python/python-parse.inc
new file mode 100644
index 000000000..fa55a93c5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-parse.inc
@@ -0,0 +1,14 @@
1SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1"
5
6SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b"
7SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939"
8
9inherit pypi
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 "
diff --git a/meta-python/recipes-devtools/python/python-parse_1.8.4.bb b/meta-python/recipes-devtools/python/python-parse_1.8.4.bb
index c66d4c8a2..d31ccc72a 100644
--- a/meta-python/recipes-devtools/python/python-parse_1.8.4.bb
+++ b/meta-python/recipes-devtools/python/python-parse_1.8.4.bb
@@ -1,13 +1,2 @@
1SUMMARY = "Parse strings using a specification based on the Python format() syntax" 1inherit setuptools
2LICENSE = "BSD" 2require python-parse.inc
3LIC_FILES_CHKSUM = "file://parse.py;beginline=1273;endline=1291;md5=5147afdd9b3615290ad8733f0137a1a1"
4
5SRC_URI[md5sum] = "fa69ab2fe846f9b183411391f7c6897b"
6SRC_URI[sha256sum] = "c3cdf6206f22aeebfa00e5b954fcfea13d1b2dc271c75806b6025b94fb490939"
7
8inherit pypi setuptools
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-logging \
13 "
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb b/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb
new file mode 100644
index 000000000..b1242545c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parse_1.8.4.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-parse.inc