summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
new file mode 100644
index 000000000..761bab273
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Style preserving TOML library"
2HOMEPAGE = "https://pypi.org/project/tomlkit/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5
6SRC_URI[sha256sum] = "08ad192699734149f5b97b45f1f18dad7eb1b6d16bc72ad0c2335772650d7b72"
7
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN} += " \
15 python3-datetime \
16 python3-profile \
17 python3-stringold \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-poetry-core \
22 python3-pytest \
23 python3-pyyaml \
24 python3-unittest-automake-output \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32BBCLASSEXTEND = "native nativesdk"