summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-07-15 17:02:21 +0800
committerKhem Raj <raj.khem@gmail.com>2024-07-15 16:36:14 -0700
commit812d2aa3c5d8ffa25204150e3e937334c225d580 (patch)
tree8af95d3f8745936b799b3f4d4b0e36441653fc36 /meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
parentcb3693b46e72a98d65d81f8c09a9c9e2e08fbe1a (diff)
downloadmeta-openembedded-812d2aa3c5d8ffa25204150e3e937334c225d580.tar.gz
python3-tomlkit: upgrade 0.12.5 -> 0.13.0
Changelog: ============= - fix: Test failures with Python 3.13.0a4: test_dates_behave_like_dates and test_times_behave_like_times - [pre-commit.ci] pre-commit autoupdate - fix: Revert "fix: Construction of OutOfOrderTableProxy can cause newlines to be inserted (#347)" - Update tests action - fix: tomlkit 0.12.5 : Encoder contract interferes with external TypeErrors raised in encoders - chore(deps-dev): bump certifi from 2024.2.2 to 2024.7.4 - chore(deps-dev): bump urllib3 from 2.0.7 to 2.2.2 - chore(deps-dev): bump requests from 2.31.0 to 2.32.2 - chore(deps-dev): bump zipp from 3.15.0 to 3.19.1 - fix: keep the nested out of order table Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
new file mode 100644
index 000000000..761bab273
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.13.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Style preserving TOML library"
2HOMEPAGE = "https://pypi.org/project/tomlkit/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5
6SRC_URI[sha256sum] = "08ad192699734149f5b97b45f1f18dad7eb1b6d16bc72ad0c2335772650d7b72"
7
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN} += " \
15 python3-datetime \
16 python3-profile \
17 python3-stringold \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-poetry-core \
22 python3-pytest \
23 python3-pyyaml \
24 python3-unittest-automake-output \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32BBCLASSEXTEND = "native nativesdk"