summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flexparser_0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flexparser_0.3.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
index fb94235f0..e45175f5a 100644
--- a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
@@ -6,6 +6,26 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
6DEPENDS += "python3-setuptools-scm-native" 6DEPENDS += "python3-setuptools-scm-native"
7SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a" 7SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
8 8
9inherit pypi python_setuptools_build_meta 9inherit pypi python_setuptools_build_meta ptest
10 10
11PYPI_PACKAGE = "flexparser" 11PYPI_PACKAGE = "flexparser"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-unittest-automake-output \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/testsuite
24 cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/
25}
26
27RDEPENDS:${PN} += " \
28 python3-compression \
29 python3-email \
30 python3-logging \
31"