summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-flexparser/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-flexparser_0.3.bb22
3 files changed, 25 insertions, 1 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index acb09aaca..6bd48156d 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -20,6 +20,7 @@ PTESTS_FAST_META_PYTHON = "\
20 python3-dominate \ 20 python3-dominate \
21 python3-execnet \ 21 python3-execnet \
22 python3-flexcache \ 22 python3-flexcache \
23 python3-flexparser \
23 python3-freezegun \ 24 python3-freezegun \
24 python3-geojson \ 25 python3-geojson \
25 python3-google-auth-oauthlib \ 26 python3-google-auth-oauthlib \
diff --git a/meta-python/recipes-devtools/python/python3-flexparser/run-ptest b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
new file mode 100644
index 000000000..8d2017d39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flexparser/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
index fb94235f0..e45175f5a 100644
--- a/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flexparser_0.3.bb
@@ -6,6 +6,26 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
6DEPENDS += "python3-setuptools-scm-native" 6DEPENDS += "python3-setuptools-scm-native"
7SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a" 7SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a"
8 8
9inherit pypi python_setuptools_build_meta 9inherit pypi python_setuptools_build_meta ptest
10 10
11PYPI_PACKAGE = "flexparser" 11PYPI_PACKAGE = "flexparser"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-unittest-automake-output \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/testsuite
24 cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/
25}
26
27RDEPENDS:${PN} += " \
28 python3-compression \
29 python3-email \
30 python3-logging \
31"