summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb')
-rw-r--r--meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
new file mode 100644
index 000000000..3a306ad95
--- /dev/null
+++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
@@ -0,0 +1,31 @@
1SUMMARY = "dnfdragora is a DNF frontend, based on rpmdragora from Mageia (originally rpmdrake) Perl code."
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
4 "
5
6SRC_URI = "git://github.com/manatools/dnfdragora.git;branch=master;protocol=https \
7 file://0001-disable-build-manpages.patch \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-To-fix-error-when-do_package.patch \
10 "
11
12SRCREV = "5b0f4c38efb92c9dac1d39fade5b9a3c30f20ec4"
13
14S = "${WORKDIR}/git"
15
16inherit cmake gettext pkgconfig python3-dir python3native setuptools3-base mime-xdg
17
18DEPENDS += "dnf python3 "
19#DEPENDS:class-nativesdk += "nativesdk-python3"
20
21RDEPENDS:${PN}:class-target = " python3-core libyui libyui-ncurses "
22
23# manpages generation requires http://www.sphinx-doc.org/
24EXTRA_OECMAKE = " -DWITH_MAN=OFF -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
25
26BBCLASSEXTEND = "nativesdk"
27
28FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/ ${datadir}/ ${bindir}/ ${sysconfdir}/dnfdragora ${sysconfdir}/xdg"
29
30SKIP_RECIPE[dnfdragora] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build correctly without package_rpm in PACKAGE_CLASSES', d)}"
31