summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-10-08 15:52:12 +0800
committerKhem Raj <raj.khem@gmail.com>2022-10-08 11:36:57 -0700
commitee1cd3189677becd7407d399e4cd7237fb043935 (patch)
tree71404a668074480b8ebdf599ec578964f0f3d3b4 /meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
parent6beace44e7070c9f2ea778d6a4fcf1be5b6c2e45 (diff)
downloadmeta-openembedded-ee1cd3189677becd7407d399e4cd7237fb043935.tar.gz
dnfdragora: upgrade 2.1.2 -> 2.1.3
Changelog: =========== This is a bug fixing release that contains the following changes Changed widget weight to avoid wrong behavior and resizing limitations (see issue #206, issue #207 and libyui/libyui-gtk#83) Added logging info if metadata have to be downloaded (expiration time). Note that MetaData update_interval <= 0 means that tha check is disabled as well as if dnf-makecache.timer is enabled Fixed clicking to the right of checkboxes wrong behaviour (issue #203) Performed an "escape" on description text before showing it as package information (issue #191) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb')
-rw-r--r--meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
new file mode 100644
index 000000000..3a306ad95
--- /dev/null
+++ b/meta-oe/recipes-graphics/dnfdragora/dnfdragora_2.1.3.bb
@@ -0,0 +1,31 @@
1SUMMARY = "dnfdragora is a DNF frontend, based on rpmdragora from Mageia (originally rpmdrake) Perl code."
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
4 "
5
6SRC_URI = "git://github.com/manatools/dnfdragora.git;branch=master;protocol=https \
7 file://0001-disable-build-manpages.patch \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-To-fix-error-when-do_package.patch \
10 "
11
12SRCREV = "5b0f4c38efb92c9dac1d39fade5b9a3c30f20ec4"
13
14S = "${WORKDIR}/git"
15
16inherit cmake gettext pkgconfig python3-dir python3native setuptools3-base mime-xdg
17
18DEPENDS += "dnf python3 "
19#DEPENDS:class-nativesdk += "nativesdk-python3"
20
21RDEPENDS:${PN}:class-target = " python3-core libyui libyui-ncurses "
22
23# manpages generation requires http://www.sphinx-doc.org/
24EXTRA_OECMAKE = " -DWITH_MAN=OFF -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
25
26BBCLASSEXTEND = "nativesdk"
27
28FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/ ${datadir}/ ${bindir}/ ${sysconfdir}/dnfdragora ${sysconfdir}/xdg"
29
30SKIP_RECIPE[dnfdragora] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build correctly without package_rpm in PACKAGE_CLASSES', d)}"
31