summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch36
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb3
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb (renamed from meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.19.bb)14
-rw-r--r--meta-networking/recipes-support/mctp/mctp_2.0.bb (renamed from meta-networking/recipes-support/mctp/mctp_1.1.bb)6
-rw-r--r--meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.1.bb2
-rw-r--r--meta-networking/recipes-support/ndisc6/ndisc6/0001-Remove-use-of-variables-indicating-buildtime-informa.patch85
-rw-r--r--meta-networking/recipes-support/ndisc6/ndisc6_1.0.8.bb1
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb (renamed from meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.4.5.bb)4
-rw-r--r--meta-networking/recipes-support/stunnel/stunnel/fix-openssl-no-des.patch19
-rw-r--r--meta-networking/recipes-support/stunnel/stunnel_5.73.bb (renamed from meta-networking/recipes-support/stunnel/stunnel_5.72.bb)2
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpslice_1.8.bb (renamed from meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb)2
-rw-r--r--meta-networking/recipes-support/traceroute/traceroute_2.1.6.bb (renamed from meta-networking/recipes-support/traceroute/traceroute_2.1.5.bb)2
-rw-r--r--meta-networking/recipes-support/unbound/unbound_1.22.0.bb (renamed from meta-networking/recipes-support/unbound/unbound_1.21.0.bb)10
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_4.2.7.bb2
14 files changed, 155 insertions, 33 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch b/meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch
new file mode 100644
index 000000000..1712a5346
--- /dev/null
+++ b/meta-networking/recipes-support/curlpp/curlpp/0002-fix-invalid-conversion-from-int-to-CURLoption.patch
@@ -0,0 +1,36 @@
1From ebe9144fdfdc8154661b93322cec4a1c43aa75ff Mon Sep 17 00:00:00 2001
2From: alperak <alperyasinak1@gmail.com>
3Date: Tue, 1 Oct 2024 19:45:38 +0300
4Subject: [PATCH] Fix invalid conversion from int to CURLoption
5
6Options.hpp:281:74: error: invalid conversion from 'int' to 'CURLoption' [-fpermissive]
7 281 | typedef curlpp::OptionTrait<curl_closepolicy, CURLOPT_CLOSEPOLICY> ClosePolicy;
8 | ^
9 | |
10 | int
11
12Fix invalid conversion by adding explicit cast to CURLoption
13
14Upstream-Status: Pending
15
16Signed-off-by: alperak <alperyasinak1@gmail.com>
17---
18 include/curlpp/Options.hpp | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/include/curlpp/Options.hpp b/include/curlpp/Options.hpp
22index c705c9d..7c9a501 100644
23--- a/include/curlpp/Options.hpp
24+++ b/include/curlpp/Options.hpp
25@@ -278,7 +278,7 @@ namespace options
26 typedef curlpp::OptionTrait<long, CURLOPT_LOW_SPEED_LIMIT> LowSpeedLimit;
27 typedef curlpp::OptionTrait<long, CURLOPT_LOW_SPEED_TIME> LowSpeedTime;
28 typedef curlpp::OptionTrait<long, CURLOPT_MAXCONNECTS> MaxConnects;
29- typedef curlpp::OptionTrait<curl_closepolicy, CURLOPT_CLOSEPOLICY> ClosePolicy;
30+ typedef curlpp::OptionTrait<curl_closepolicy, (CURLoption)CURLOPT_CLOSEPOLICY> ClosePolicy;
31 typedef curlpp::OptionTrait<bool, CURLOPT_FRESH_CONNECT> FreshConnect;
32 typedef curlpp::OptionTrait<bool, CURLOPT_FORBID_REUSE> ForbidReuse;
33 typedef curlpp::OptionTrait<long, CURLOPT_CONNECTTIMEOUT> ConnectTimeout;
34--
352.25.1
36
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 131f1873a..cacdc9773 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -8,7 +8,8 @@ DEPENDS = "curl"
8DEPENDS:class-native = "curl-native" 8DEPENDS:class-native = "curl-native"
9 9
10SRC_URI = "git://github.com/jpbarrette/curlpp.git;branch=master;protocol=https \ 10SRC_URI = "git://github.com/jpbarrette/curlpp.git;branch=master;protocol=https \
11 file://0001-curlpp-config.in-Remove-references-to-absolute-build.patch" 11 file://0001-curlpp-config.in-Remove-references-to-absolute-build.patch \
12 file://0002-fix-invalid-conversion-from-int-to-CURLoption.patch"
12 13
13SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f" 14SRCREV = "592552a165cc569dac7674cb7fc9de3dc829906f"
14 15
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.19.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb
index 0243f2a1d..1300fc658 100644
--- a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.19.bb
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb
@@ -8,10 +8,7 @@ LIC_FILES_CHKSUM = " \
8 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \ 8 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
9" 9"
10 10
11SRCREV = "05b50d379ff0037de4957bb2a1befcce88b70225" 11SRCREV = "37d5f1225573b91d706a5e547d081f79963a9deb"
12
13PV .= "+git"
14LK_REL = "1.0.19"
15 12
16SRC_URI = " \ 13SRC_URI = " \
17 git://github.com/sctp/lksctp-tools.git;branch=master;protocol=https \ 14 git://github.com/sctp/lksctp-tools.git;branch=master;protocol=https \
@@ -34,19 +31,14 @@ do_install_ptest () {
34 done 31 done
35} 32}
36 33
37SOLIBVERSION="${LK_REL}"
38SOLIBMAJORVERSION="1"
39
40PACKAGES =+ "${PN}-withsctp ${PN}-utils" 34PACKAGES =+ "${PN}-withsctp ${PN}-utils"
41 35
42FILES:${PN} = " \ 36FILES:${PN} = " \
43 ${libdir}/libsctp.so.${SOLIBVERSION} \ 37 ${libdir}/libsctp.so.* \
44 ${libdir}/libsctp.so.${SOLIBMAJORVERSION} \
45" 38"
46 39
47FILES:${PN}-withsctp = " \ 40FILES:${PN}-withsctp = " \
48 ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBVERSION} \ 41 ${libdir}/lksctp-tools/libwithsctp.so.* \
49 ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBMAJORVERSION} \
50" 42"
51 43
52FILES:${PN}-dev += " \ 44FILES:${PN}-dev += " \
diff --git a/meta-networking/recipes-support/mctp/mctp_1.1.bb b/meta-networking/recipes-support/mctp/mctp_2.0.bb
index bf3961be4..24f974774 100644
--- a/meta-networking/recipes-support/mctp/mctp_1.1.bb
+++ b/meta-networking/recipes-support/mctp/mctp_2.0.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL-2.0-only"
5 5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21"
7 7
8SRCREV = "a591ad885aa28f113cb45870b2fd5bce48378d6f" 8SRCREV = "089dc53fa7387cca517cd713061c323ca06fb6dd"
9 9
10SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main;protocol=https" 10SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main;protocol=https"
11 11
@@ -13,6 +13,10 @@ S = "${WORKDIR}/git"
13 13
14inherit meson pkgconfig systemd 14inherit meson pkgconfig systemd
15 15
16EXTRA_OEMESON = " \
17 -Dtests=false \
18"
19
16PACKAGECONFIG ??= " \ 20PACKAGECONFIG ??= " \
17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ 21 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
18" 22"
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.1.bb b/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.1.bb
index 0c64889bc..457064c01 100644
--- a/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.1.bb
+++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.1.bb
@@ -6,4 +6,4 @@ S = "${WORKDIR}/git"
6 6
7inherit pkgconfig autotools 7inherit pkgconfig autotools
8 8
9RDEPENDS:${PN} = "kernel-module-mdio-netlink" 9RRECOMMENDS:${PN} = "kernel-module-mdio-netlink"
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6/0001-Remove-use-of-variables-indicating-buildtime-informa.patch b/meta-networking/recipes-support/ndisc6/ndisc6/0001-Remove-use-of-variables-indicating-buildtime-informa.patch
new file mode 100644
index 000000000..7bfb17bf0
--- /dev/null
+++ b/meta-networking/recipes-support/ndisc6/ndisc6/0001-Remove-use-of-variables-indicating-buildtime-informa.patch
@@ -0,0 +1,85 @@
1From 7b3e78cf0348ea737609a2ace07c7c55aae36bcb Mon Sep 17 00:00:00 2001
2From: Santiago Vila <sanvila@debian.org>
3Date: Wed, 9 Oct 2024 22:05:09 -0700
4Subject: [PATCH] Remove use of variables indicating buildtime information
5
6We should not really care about the build date or the build host
7
8Sourced From: https://salsa.debian.org/debian/ndisc6/-/blob/master/debian/patches/reproducible-build.patch?ref_type=heads
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 rdnss/rdnssd.c | 2 --
14 src/addrinfo.c | 2 --
15 src/ndisc.c | 2 --
16 src/tcpspray.c | 2 --
17 src/traceroute.c | 2 --
18 5 files changed, 10 deletions(-)
19
20diff --git a/rdnss/rdnssd.c b/rdnss/rdnssd.c
21index b87edb2..7201525 100644
22--- a/rdnss/rdnssd.c
23+++ b/rdnss/rdnssd.c
24@@ -741,8 +741,6 @@ version (void)
25 {
26 printf (_("rdnssd: IPv6 Recursive DNS Server discovery Daemon %s (%s)\n"),
27 VERSION, "$Rev$");
28- printf (_(" built %s on %s\n"), __DATE__, PACKAGE_BUILD_HOSTNAME);
29- printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
30 puts (_("Written by Pierre Ynard and Remi Denis-Courmont\n"));
31
32 printf (_("Copyright (C) %u-%u Pierre Ynard, Remi Denis-Courmont\n"),
33diff --git a/src/addrinfo.c b/src/addrinfo.c
34index cd73722..6316abd 100644
35--- a/src/addrinfo.c
36+++ b/src/addrinfo.c
37@@ -148,8 +148,6 @@ static int quick_usage (const char *path)
38 static int version (void)
39 {
40 printf (_("addrinfo %s (%s)\n"), VERSION, "$Rev$");
41- printf (_(" built %s on %s\n"), __DATE__, PACKAGE_BUILD_HOSTNAME);
42- printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
43 puts (_("Written by Remi Denis-Courmont\n"));
44
45 printf (_("Copyright (C) %u-%u Remi Denis-Courmont\n"), 2002, 2007);
46diff --git a/src/ndisc.c b/src/ndisc.c
47index b190b18..6e222a0 100644
48--- a/src/ndisc.c
49+++ b/src/ndisc.c
50@@ -920,9 +920,7 @@ version (void)
51 {
52 printf (_(
53 "ndisc6: IPv6 Neighbor/Router Discovery userland tool %s (%s)\n"), VERSION, "$Rev$");
54- printf (_(" built %s on %s\n"), __DATE__, PACKAGE_BUILD_HOSTNAME);
55
56- printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
57 puts (_("Written by Remi Denis-Courmont\n"));
58
59 printf (_("Copyright (C) %u-%u Remi Denis-Courmont\n"), 2004, 2007);
60diff --git a/src/tcpspray.c b/src/tcpspray.c
61index 39d8939..6347795 100644
62--- a/src/tcpspray.c
63+++ b/src/tcpspray.c
64@@ -302,8 +302,6 @@ version (void)
65 {
66 printf (_(
67 "tcpspray6: TCP/IP bandwidth tester %s (%s)\n"), VERSION, "$Rev$");
68- printf (_(" built %s on %s\n"), __DATE__, PACKAGE_BUILD_HOSTNAME);
69- printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
70 puts (_("Written by Remi Denis-Courmont\n"));
71
72 printf (_("Copyright (C) %u-%u Remi Denis-Courmont\n"), 2005, 2007);
73diff --git a/src/traceroute.c b/src/traceroute.c
74index 489bc55..604b6af 100644
75--- a/src/traceroute.c
76+++ b/src/traceroute.c
77@@ -1251,8 +1251,6 @@ version (void)
78 {
79 printf (_(
80 "traceroute6: TCP & UDP IPv6 traceroute tool %s (%s)\n"), VERSION, "$Rev$");
81- printf (_(" built %s on %s\n"), __DATE__, PACKAGE_BUILD_HOSTNAME);
82- printf (_("Configured with: %s\n"), PACKAGE_CONFIGURE_INVOCATION);
83 puts (_("Written by Remi Denis-Courmont\n"));
84
85 printf (_("Copyright (C) %u-%u Remi Denis-Courmont\n"), 2005, 2007);
diff --git a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.8.bb b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.8.bb
index fb00b8351..21579d64c 100644
--- a/meta-networking/recipes-support/ndisc6/ndisc6_1.0.8.bb
+++ b/meta-networking/recipes-support/ndisc6/ndisc6_1.0.8.bb
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8SRCREV = "92e5d1cf6547fe40316b2a6ca2f7b8195ae0cbe5" 8SRCREV = "92e5d1cf6547fe40316b2a6ca2f7b8195ae0cbe5"
9SRC_URI = "git://git.remlab.net/git/ndisc6.git;protocol=http;branch=master \ 9SRC_URI = "git://git.remlab.net/git/ndisc6.git;protocol=http;branch=master \
10 file://0001-autogen-Do-not-symlink-gettext.h-from-build-host.patch \ 10 file://0001-autogen-Do-not-symlink-gettext.h-from-build-host.patch \
11 file://0001-Remove-use-of-variables-indicating-buildtime-informa.patch \
11 " 12 "
12 13
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.4.5.bb b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb
index 217829193..d44709a64 100644
--- a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.4.5.bb
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb
@@ -25,7 +25,7 @@ LICENSE:modules/freebsd/vmxnet = "GPL-2.0-only"
25LICENSE:modules/linux = "GPL-2.0-only" 25LICENSE:modules/linux = "GPL-2.0-only"
26LICENSE:modules/solaris = "CDDL-1.0" 26LICENSE:modules/solaris = "CDDL-1.0"
27 27
28SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=stable-12.4.x \ 28SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=stable-12.5.x \
29 file://tools.conf \ 29 file://tools.conf \
30 file://vmtoolsd.service \ 30 file://vmtoolsd.service \
31 file://vmtoolsd.init \ 31 file://vmtoolsd.init \
@@ -50,7 +50,7 @@ UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)"
50SRC_URI:append:libc-musl = " file://0001-Add-resolv_compat.h-for-musl-builds.patch;patchdir=.. \ 50SRC_URI:append:libc-musl = " file://0001-Add-resolv_compat.h-for-musl-builds.patch;patchdir=.. \
51" 51"
52 52
53SRCREV = "9b94132f54fbed0b86dce04ff4402d1d8fd059c3" 53SRCREV = "f2ca37ef3510543172657b82493d1eceefa9a134"
54 54
55S = "${WORKDIR}/git/open-vm-tools" 55S = "${WORKDIR}/git/open-vm-tools"
56 56
diff --git a/meta-networking/recipes-support/stunnel/stunnel/fix-openssl-no-des.patch b/meta-networking/recipes-support/stunnel/stunnel/fix-openssl-no-des.patch
index 82d355101..8c4ca55fb 100644
--- a/meta-networking/recipes-support/stunnel/stunnel/fix-openssl-no-des.patch
+++ b/meta-networking/recipes-support/stunnel/stunnel/fix-openssl-no-des.patch
@@ -1,4 +1,4 @@
1From 7ff4eba20b5c4fc7365e5ee0dfb775ed29bdd5ce Mon Sep 17 00:00:00 2001 1From c815368a3e41dd3f639eb8fd82d21bc0bab55d1e Mon Sep 17 00:00:00 2001
2From: Kai Kang <kai.kang@windriver.com> 2From: Kai Kang <kai.kang@windriver.com>
3Date: Wed, 1 Nov 2017 09:23:41 -0400 3Date: Wed, 1 Nov 2017 09:23:41 -0400
4Subject: [PATCH] stunnel: fix compile error when openssl disable des support 4Subject: [PATCH] stunnel: fix compile error when openssl disable des support
@@ -17,10 +17,10 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
17 2 files changed, 5 insertions(+), 3 deletions(-) 17 2 files changed, 5 insertions(+), 3 deletions(-)
18 18
19diff --git a/src/common.h b/src/common.h 19diff --git a/src/common.h b/src/common.h
20index 2b4869f..180d31a 100644 20index f112cf9..8d4be01 100644
21--- a/src/common.h 21--- a/src/common.h
22+++ b/src/common.h 22+++ b/src/common.h
23@@ -492,7 +492,9 @@ extern char *sys_errlist[]; 23@@ -496,7 +496,9 @@ extern char *sys_errlist[];
24 #ifndef OPENSSL_NO_MD4 24 #ifndef OPENSSL_NO_MD4
25 #include <openssl/md4.h> 25 #include <openssl/md4.h>
26 #endif /* !defined(OPENSSL_NO_MD4) */ 26 #endif /* !defined(OPENSSL_NO_MD4) */
@@ -31,19 +31,19 @@ index 2b4869f..180d31a 100644
31 #include <openssl/dh.h> 31 #include <openssl/dh.h>
32 #if OPENSSL_VERSION_NUMBER<0x10100000L 32 #if OPENSSL_VERSION_NUMBER<0x10100000L
33diff --git a/src/protocol.c b/src/protocol.c 33diff --git a/src/protocol.c b/src/protocol.c
34index cfe6d3b..3936aea 100644 34index c8c65ea..b071b06 100644
35--- a/src/protocol.c 35--- a/src/protocol.c
36+++ b/src/protocol.c 36+++ b/src/protocol.c
37@@ -81,7 +81,7 @@ NOEXPORT void ldap_client_middle(CLI *); 37@@ -82,7 +82,7 @@ NOEXPORT void ldap_client_middle(CLI *);
38
39 NOEXPORT void connect_server_early(CLI *); 38 NOEXPORT void connect_server_early(CLI *);
39 NOEXPORT const char *connect_client_init(SERVICE_OPTIONS *);
40 NOEXPORT void connect_client_middle(CLI *); 40 NOEXPORT void connect_client_middle(CLI *);
41-#ifndef OPENSSL_NO_MD4 41-#ifndef OPENSSL_NO_MD4
42+#if !defined(OPENSSL_NO_MD4) && !defined(OPENSSL_NO_DES) 42+#if !defined(OPENSSL_NO_MD4) && !defined(OPENSSL_NO_DES)
43 NOEXPORT void ntlm(CLI *); 43 NOEXPORT void ntlm(CLI *);
44 NOEXPORT char *ntlm1(void); 44 NOEXPORT char *ntlm1(void);
45 NOEXPORT char *ntlm3(char *, char *, char *, char *); 45 NOEXPORT char *ntlm3(char *, char *, char *, char *);
46@@ -1331,7 +1331,7 @@ NOEXPORT void connect_client_middle(CLI *c) { 46@@ -1334,7 +1334,7 @@ NOEXPORT void connect_client_middle(CLI *c) {
47 fd_printf(c, c->remote_fd.fd, "Host: %s", c->opt->protocol_host); 47 fd_printf(c, c->remote_fd.fd, "Host: %s", c->opt->protocol_host);
48 if(c->opt->protocol_username && c->opt->protocol_password) { 48 if(c->opt->protocol_username && c->opt->protocol_password) {
49 if(!strcasecmp(c->opt->protocol_authentication, "ntlm")) { 49 if(!strcasecmp(c->opt->protocol_authentication, "ntlm")) {
@@ -52,7 +52,7 @@ index cfe6d3b..3936aea 100644
52 ntlm(c); 52 ntlm(c);
53 #else 53 #else
54 s_log(LOG_ERR, "NTLM authentication is not available"); 54 s_log(LOG_ERR, "NTLM authentication is not available");
55@@ -1374,7 +1374,7 @@ NOEXPORT void connect_client_middle(CLI *c) { 55@@ -1377,7 +1377,7 @@ NOEXPORT void connect_client_middle(CLI *c) {
56 str_free(line); 56 str_free(line);
57 } 57 }
58 58
@@ -61,6 +61,3 @@ index cfe6d3b..3936aea 100644
61 61
62 /* 62 /*
63 * NTLM code is based on the following documentation: 63 * NTLM code is based on the following documentation:
64--
652.34.1
66
diff --git a/meta-networking/recipes-support/stunnel/stunnel_5.72.bb b/meta-networking/recipes-support/stunnel/stunnel_5.73.bb
index 6d21027a1..e13b7871c 100644
--- a/meta-networking/recipes-support/stunnel/stunnel_5.72.bb
+++ b/meta-networking/recipes-support/stunnel/stunnel_5.73.bb
@@ -11,7 +11,7 @@ SRC_URI = "https://stunnel.org/archive/5.x/${BP}.tar.gz \
11 file://fix-openssl-no-des.patch \ 11 file://fix-openssl-no-des.patch \
12" 12"
13 13
14SRC_URI[sha256sum] = "3d532941281ae353319735144e4adb9ae489a10b7e309c58a48157f08f42e949" 14SRC_URI[sha256sum] = "bc917c3bcd943a4d632360c067977a31e85e385f5f4845f69749bce88183cb38"
15 15
16inherit autotools bash-completion pkgconfig 16inherit autotools bash-completion pkgconfig
17 17
diff --git a/meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb b/meta-networking/recipes-support/tcpdump/tcpslice_1.8.bb
index 93197dc3b..3d61160bb 100644
--- a/meta-networking/recipes-support/tcpdump/tcpslice_1.7.bb
+++ b/meta-networking/recipes-support/tcpdump/tcpslice_1.8.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://tcpslice.c;endline=20;md5=99519e2e5234d1662a4ce16baa6
8 8
9SRC_URI = "http://www.tcpdump.org/release/${BP}.tar.gz \ 9SRC_URI = "http://www.tcpdump.org/release/${BP}.tar.gz \
10 " 10 "
11SRC_URI[sha256sum] = "e513f0710c4ab45ec627e5df6f7b80d12e488146e1bd500c92247e20ca608903" 11SRC_URI[sha256sum] = "082967d6bf793499d3d655cea2149e07c0da97287f1877a6eab88d17cb703d0d"
12 12
13UPSTREAM_CHECK_REGEX = "tcpslice-(?P<pver>\d+(\.\d+)+)\.tar" 13UPSTREAM_CHECK_REGEX = "tcpslice-(?P<pver>\d+(\.\d+)+)\.tar"
14 14
diff --git a/meta-networking/recipes-support/traceroute/traceroute_2.1.5.bb b/meta-networking/recipes-support/traceroute/traceroute_2.1.6.bb
index 862cba91e..b72c37540 100644
--- a/meta-networking/recipes-support/traceroute/traceroute_2.1.5.bb
+++ b/meta-networking/recipes-support/traceroute/traceroute_2.1.6.bb
@@ -17,7 +17,7 @@ UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/traceroute/files/tracerou
17 17
18SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \ 18SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
19" 19"
20SRC_URI[sha256sum] = "9c6c260d96eaab51e3ce461b0a84fe87123ebc6dd6c9a59fab803f95b35a859e" 20SRC_URI[sha256sum] = "9ccef9cdb9d7a98ff7fbf93f79ebd0e48881664b525c4b232a0fcec7dcb9db5e"
21 21
22EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}" 22EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
23LTOEXTRA += "-flto-partition=none" 23LTOEXTRA += "-flto-partition=none"
diff --git a/meta-networking/recipes-support/unbound/unbound_1.21.0.bb b/meta-networking/recipes-support/unbound/unbound_1.22.0.bb
index 8c042dc5f..2f0c92dd9 100644
--- a/meta-networking/recipes-support/unbound/unbound_1.21.0.bb
+++ b/meta-networking/recipes-support/unbound/unbound_1.22.0.bb
@@ -12,7 +12,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5308494bc0590c0cb036afd781d78f06"
12SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=https;branch=master \ 12SRC_URI = "git://github.com/NLnetLabs/unbound.git;protocol=https;branch=master \
13 file://run-ptest \ 13 file://run-ptest \
14 " 14 "
15SRCREV = "79e4c578518886a32475cfbb0de383ff3a905033" 15
16# 17 commits after 1.22.0 tag:
17# https://github.com/NLnetLabs/unbound/compare/release-1.22.0...7985d17b57d25be262de56c29a43ae4b61c1b896
18# to include fix for occasional build failure:
19# https://github.com/NLnetLabs/unbound/commit/46cfbf313d812a6e50614a691e162b171dc91d7b
20PV .= "+git"
21SRCREV = "7985d17b57d25be262de56c29a43ae4b61c1b896"
16 22
17inherit autotools pkgconfig systemd update-rc.d ptest 23inherit autotools pkgconfig systemd update-rc.d ptest
18 24
@@ -22,7 +28,7 @@ RDEPENDS:${PN} = "bash openssl-bin daemonize"
22S = "${WORKDIR}/git" 28S = "${WORKDIR}/git"
23 29
24EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \ 30EXTRA_OECONF = "--with-libexpat=${STAGING_EXECPREFIXDIR} \
25 --with-ssl=${STAGING_EXECPREFIXDIR} \ 31 --disable-rpath --with-ssl=${STAGING_EXECPREFIXDIR} \
26 --enable-largefile" 32 --enable-largefile"
27 33
28PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 34PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
diff --git a/meta-networking/recipes-support/wireshark/wireshark_4.2.7.bb b/meta-networking/recipes-support/wireshark/wireshark_4.2.7.bb
index b80710683..3fa293d0c 100644
--- a/meta-networking/recipes-support/wireshark/wireshark_4.2.7.bb
+++ b/meta-networking/recipes-support/wireshark/wireshark_4.2.7.bb
@@ -42,7 +42,7 @@ PACKAGECONFIG[plugins] = "-DENABLE_PLUGINS=ON,-DENABLE_PLUGINS=OFF"
42PACKAGECONFIG[sbc] = "-DENABLE_SBC=ON,-DENABLE_SBC=OFF, sbc" 42PACKAGECONFIG[sbc] = "-DENABLE_SBC=ON,-DENABLE_SBC=OFF, sbc"
43PACKAGECONFIG[libssh] = "-DENABLE_LIBSSH=ON,-DENABLE_LIBSSH=OFF, libssh2" 43PACKAGECONFIG[libssh] = "-DENABLE_LIBSSH=ON,-DENABLE_LIBSSH=OFF, libssh2"
44PACKAGECONFIG[lz4] = "-DENABLE_LZ4=ON,-DENABLE_LZ4=OFF, lz4" 44PACKAGECONFIG[lz4] = "-DENABLE_LZ4=ON,-DENABLE_LZ4=OFF, lz4"
45PACKAGECONFIG[zstd] = "-DENABLE_STTD=ON,-DENABLE_ZSTD=OFF, zstd" 45PACKAGECONFIG[zstd] = "-DENABLE_ZSTD=ON,-DENABLE_ZSTD=OFF, zstd"
46PACKAGECONFIG[nghttp2] = "-DENABLE_NGHTTP2=ON,-DENABLE_NGHTTP2=OFF, nghttp2" 46PACKAGECONFIG[nghttp2] = "-DENABLE_NGHTTP2=ON,-DENABLE_NGHTTP2=OFF, nghttp2"
47 47
48# these next two options require addional layers 48# these next two options require addional layers