summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb')
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb
new file mode 100644
index 000000000..1300fc658
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.21.bb
@@ -0,0 +1,55 @@
1SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project"
2HOMEPAGE = "http://lksctp.org"
3SECTION = "net"
4LICENSE = "LGPL-2.1-only & GPL-2.0-only"
5
6LIC_FILES_CHKSUM = " \
7 file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \
8 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
9"
10
11SRCREV = "37d5f1225573b91d706a5e547d081f79963a9deb"
12
13SRC_URI = " \
14 git://github.com/sctp/lksctp-tools.git;branch=master;protocol=https \
15 file://run-ptest \
16 file://v4test.sh \
17 file://v6test.sh \
18"
19
20S = "${WORKDIR}/git"
21
22BBCLASSEXTEND = "native"
23
24inherit autotools-brokensep pkgconfig binconfig ptest
25
26do_install_ptest () {
27 install -m 0755 ${UNPACKDIR}/v4test.sh ${D}${PTEST_PATH}
28 install -m 0755 ${UNPACKDIR}/v6test.sh ${D}${PTEST_PATH}
29 for testcase in `find ${B}/src/apps/.libs ${B}/src/func_tests/.libs -maxdepth 1 -type f -executable`; do
30 install $testcase ${D}${PTEST_PATH}
31 done
32}
33
34PACKAGES =+ "${PN}-withsctp ${PN}-utils"
35
36FILES:${PN} = " \
37 ${libdir}/libsctp.so.* \
38"
39
40FILES:${PN}-withsctp = " \
41 ${libdir}/lksctp-tools/libwithsctp.so.* \
42"
43
44FILES:${PN}-dev += " \
45 ${libdir}/libsctp.so \
46 ${libdir}/lksctp-tools/libwithsctp.so \
47 ${datadir}/lksctp-tools/*.c \
48 ${datadir}/lksctp-tools/*.h \
49"
50
51FILES:${PN}-utils = "${bindir}/*"
52
53RRECOMMENDS:${PN} += "kernel-module-sctp"
54RRECOMMENDS:${PN}-utils += "kernel-module-sctp"
55RRECOMMENDS:${PN}-ptest += "kernel-module-sctp"