diff options
4 files changed, 104 insertions, 34 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch new file mode 100644 index 0000000000..ee172c3a69 --- /dev/null +++ b/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From 44516eee75696c84849c0f7aa632e2456b101813 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 26 Mar 2022 00:57:03 -0700 | ||
4 | Subject: [PATCH] meson: Use pkg-config to detect iniparser | ||
5 | |||
6 | Add iniparser dependency to util subdir | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | meson.build | 2 +- | ||
12 | util/meson.build | 1 + | ||
13 | 2 files changed, 2 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/meson.build b/meson.build | ||
16 | index 42e11aa..4209320 100644 | ||
17 | --- a/meson.build | ||
18 | +++ b/meson.build | ||
19 | @@ -160,7 +160,7 @@ cc = meson.get_compiler('c') | ||
20 | |||
21 | # keyutils and iniparser lack pkgconfig | ||
22 | keyutils = cc.find_library('keyutils', required : get_option('keyutils')) | ||
23 | -iniparser = cc.find_library('iniparser', required : true) | ||
24 | +iniparser = dependency('iniparser', required : true) | ||
25 | |||
26 | conf = configuration_data() | ||
27 | check_headers = [ | ||
28 | diff --git a/util/meson.build b/util/meson.build | ||
29 | index 784b279..8e9ae9a 100644 | ||
30 | --- a/util/meson.build | ||
31 | +++ b/util/meson.build | ||
32 | @@ -12,5 +12,6 @@ util = static_library('util', [ | ||
33 | 'iomem.c', | ||
34 | ], | ||
35 | include_directories : root_inc, | ||
36 | + dependencies : iniparser, | ||
37 | ) | ||
38 | util_dep = declare_dependency(link_with : util) | ||
39 | -- | ||
40 | 2.35.1 | ||
41 | |||
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch new file mode 100644 index 0000000000..fe2612ce94 --- /dev/null +++ b/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From c212d228c25cb583f52a6d31e9f0ec7bc1f9c506 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 26 Mar 2022 01:10:02 -0700 | ||
4 | Subject: [PATCH] util: Correct path to iniparser.h | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | util/parse-configs.c | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/util/parse-configs.c b/util/parse-configs.c | ||
14 | index c834a07..1b7ffa6 100644 | ||
15 | --- a/util/parse-configs.c | ||
16 | +++ b/util/parse-configs.c | ||
17 | @@ -4,7 +4,7 @@ | ||
18 | #include <dirent.h> | ||
19 | #include <errno.h> | ||
20 | #include <fcntl.h> | ||
21 | -#include <iniparser.h> | ||
22 | +#include <iniparser/iniparser.h> | ||
23 | #include <sys/stat.h> | ||
24 | #include <util/parse-configs.h> | ||
25 | #include <util/strbuf.h> | ||
26 | -- | ||
27 | 2.35.1 | ||
28 | |||
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v69.bb b/meta-oe/recipes-core/ndctl/ndctl_v69.bb deleted file mode 100644 index 5f119c6b7d..0000000000 --- a/meta-oe/recipes-core/ndctl/ndctl_v69.bb +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | SUMMARY = "libnvdimm utility library" | ||
2 | DESCRIPTION = "Utility library for managing the libnvdimm \ | ||
3 | (non-volatile memory device) sub-system in the Linux kernel. \ | ||
4 | The LIBNVDIMM subsystem provides support for three types of \ | ||
5 | NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \ | ||
6 | simultaneously support both PMEM and BLK mode access." | ||
7 | HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next" | ||
8 | LICENSE = "GPL-2.0-or-later" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08" | ||
10 | |||
11 | inherit autotools-brokensep pkgconfig bash-completion systemd | ||
12 | |||
13 | SRCREV = "ea62d6d53bf6f806c4841e97a370201e18446860" | ||
14 | SRC_URI = "git://github.com/pmem/ndctl.git;branch=master;protocol=https" | ||
15 | |||
16 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)" | ||
17 | |||
18 | DEPENDS = "kmod udev json-c keyutils" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs" | ||
23 | |||
24 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}" | ||
25 | PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd" | ||
26 | |||
27 | do_configure:prepend() { | ||
28 | ${S}/autogen.sh | ||
29 | } | ||
30 | |||
31 | SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service" | ||
32 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | ||
33 | |||
34 | FILES:${PN} += "${datadir}/daxctl/daxctl.conf" | ||
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v73.bb b/meta-oe/recipes-core/ndctl/ndctl_v73.bb new file mode 100644 index 0000000000..c88d392970 --- /dev/null +++ b/meta-oe/recipes-core/ndctl/ndctl_v73.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "libnvdimm utility library" | ||
2 | DESCRIPTION = "Utility library for managing the libnvdimm \ | ||
3 | (non-volatile memory device) sub-system in the Linux kernel. \ | ||
4 | The LIBNVDIMM subsystem provides support for three types of \ | ||
5 | NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \ | ||
6 | simultaneously support both PMEM and BLK mode access." | ||
7 | HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next" | ||
8 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & MIT & CC0-1.0" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=74a614eac8b2657a4b8e6607421a0883" | ||
10 | |||
11 | inherit meson pkgconfig bash-completion systemd | ||
12 | |||
13 | SRCREV = "dd58d43458943d20ff063850670bf54a5242c9c5" | ||
14 | SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https \ | ||
15 | file://0001-util-Correct-path-to-iniparser.h.patch \ | ||
16 | file://0001-meson-Use-pkg-config-to-detect-iniparser.patch" | ||
17 | |||
18 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)" | ||
19 | |||
20 | DEPENDS = "kmod udev json-c keyutils iniparser" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | EXTRA_OECONF += "-Ddestructive=enabled" | ||
25 | |||
26 | PACKAGECONFIG ??= "tests ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}" | ||
27 | PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd" | ||
28 | PACKAGECONFIG[tests] = "-Dtest=enabled, -Dtest=disabled," | ||
29 | PACKAGECONFIG[docs] = "-Ddocs=enabled -Dasciidoctor=enabled,-Ddocs=disabled -Dasciidoctor=disabled, asciidoc-native" | ||
30 | |||
31 | SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" | ||
32 | SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service daxdev-reconfigure@.service" | ||
33 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | ||
34 | |||
35 | FILES:${PN} += "${datadir}/daxctl/daxctl.conf " | ||