summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-26 01:13:02 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-26 18:15:11 -0700
commit0aed3f603ebd743aa5defa7fd3bfa4a41e42b278 (patch)
treeaa3d9af64503ff3b3324ba8a379988c17717243f
parent36883aece976682bfa8c24a4de0d0a0966e9559a (diff)
downloadmeta-openembedded-0aed3f603ebd743aa5defa7fd3bfa4a41e42b278.tar.gz
ndctl: Upgrade to v73
Add iniparser dependency to util subdir Correct path to iniparser.h Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch41
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch28
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_v69.bb34
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_v73.bb35
4 files changed, 104 insertions, 34 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch
new file mode 100644
index 000000000..ee172c3a6
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch
@@ -0,0 +1,41 @@
1From 44516eee75696c84849c0f7aa632e2456b101813 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Mar 2022 00:57:03 -0700
4Subject: [PATCH] meson: Use pkg-config to detect iniparser
5
6Add iniparser dependency to util subdir
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 meson.build | 2 +-
12 util/meson.build | 1 +
13 2 files changed, 2 insertions(+), 1 deletion(-)
14
15diff --git a/meson.build b/meson.build
16index 42e11aa..4209320 100644
17--- a/meson.build
18+++ b/meson.build
19@@ -160,7 +160,7 @@ cc = meson.get_compiler('c')
20
21 # keyutils and iniparser lack pkgconfig
22 keyutils = cc.find_library('keyutils', required : get_option('keyutils'))
23-iniparser = cc.find_library('iniparser', required : true)
24+iniparser = dependency('iniparser', required : true)
25
26 conf = configuration_data()
27 check_headers = [
28diff --git a/util/meson.build b/util/meson.build
29index 784b279..8e9ae9a 100644
30--- a/util/meson.build
31+++ b/util/meson.build
32@@ -12,5 +12,6 @@ util = static_library('util', [
33 'iomem.c',
34 ],
35 include_directories : root_inc,
36+ dependencies : iniparser,
37 )
38 util_dep = declare_dependency(link_with : util)
39--
402.35.1
41
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch
new file mode 100644
index 000000000..fe2612ce9
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch
@@ -0,0 +1,28 @@
1From c212d228c25cb583f52a6d31e9f0ec7bc1f9c506 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Mar 2022 01:10:02 -0700
4Subject: [PATCH] util: Correct path to iniparser.h
5
6Upstream-Status: Pending
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 util/parse-configs.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/util/parse-configs.c b/util/parse-configs.c
14index c834a07..1b7ffa6 100644
15--- a/util/parse-configs.c
16+++ b/util/parse-configs.c
17@@ -4,7 +4,7 @@
18 #include <dirent.h>
19 #include <errno.h>
20 #include <fcntl.h>
21-#include <iniparser.h>
22+#include <iniparser/iniparser.h>
23 #include <sys/stat.h>
24 #include <util/parse-configs.h>
25 #include <util/strbuf.h>
26--
272.35.1
28
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v69.bb b/meta-oe/recipes-core/ndctl/ndctl_v69.bb
deleted file mode 100644
index 5f119c6b7..000000000
--- a/meta-oe/recipes-core/ndctl/ndctl_v69.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPL-2.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
10
11inherit autotools-brokensep pkgconfig bash-completion systemd
12
13SRCREV = "ea62d6d53bf6f806c4841e97a370201e18446860"
14SRC_URI = "git://github.com/pmem/ndctl.git;branch=master;protocol=https"
15
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)"
17
18DEPENDS = "kmod udev json-c keyutils"
19
20S = "${WORKDIR}/git"
21
22EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
23
24PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
25PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd"
26
27do_configure:prepend() {
28 ${S}/autogen.sh
29}
30
31SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service"
32SYSTEMD_AUTO_ENABLE:${PN} = "disable"
33
34FILES:${PN} += "${datadir}/daxctl/daxctl.conf"
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v73.bb b/meta-oe/recipes-core/ndctl/ndctl_v73.bb
new file mode 100644
index 000000000..c88d39297
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl_v73.bb
@@ -0,0 +1,35 @@
1SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & MIT & CC0-1.0"
9LIC_FILES_CHKSUM = "file://COPYING;md5=74a614eac8b2657a4b8e6607421a0883"
10
11inherit meson pkgconfig bash-completion systemd
12
13SRCREV = "dd58d43458943d20ff063850670bf54a5242c9c5"
14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https \
15 file://0001-util-Correct-path-to-iniparser.h.patch \
16 file://0001-meson-Use-pkg-config-to-detect-iniparser.patch"
17
18UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)"
19
20DEPENDS = "kmod udev json-c keyutils iniparser"
21
22S = "${WORKDIR}/git"
23
24EXTRA_OECONF += "-Ddestructive=enabled"
25
26PACKAGECONFIG ??= "tests ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
27PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
28PACKAGECONFIG[tests] = "-Dtest=enabled, -Dtest=disabled,"
29PACKAGECONFIG[docs] = "-Ddocs=enabled -Dasciidoctor=enabled,-Ddocs=disabled -Dasciidoctor=disabled, asciidoc-native"
30
31SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
32SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service daxdev-reconfigure@.service"
33SYSTEMD_AUTO_ENABLE:${PN} = "disable"
34
35FILES:${PN} += "${datadir}/daxctl/daxctl.conf "