summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-08-15 09:30:53 +0300
committerKhem Raj <raj.khem@gmail.com>2024-08-15 10:28:12 -0700
commite72396ae321609497d3329e047b21113fb11bc35 (patch)
treec61f02dea72d5660b0a199c88ab446edb8f74e8a /meta-python
parent55bfe466db4e1489968f5b4841827ba6023e052c (diff)
downloadmeta-openembedded-e72396ae321609497d3329e047b21113fb11bc35.tar.gz
python3-dirty-equals: Upgrade 0.7.1 -> 0.8.0
Upgrade to release 0.8.0: - set requires-python to 3.8 - use zoneinfo instead of pytz where possible - No need to call datetime.replace for utc_now - Patch pprint to make pytest diffs nicer for big objects - uprev test, lint and docs dependencies - Support Python 3.13 - Uprev version Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb (renamed from meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb)9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb b/meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb
index ea9303b17..584d787a7 100644
--- a/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
+++ b/meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
10LICENSE = "MIT" 10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c" 11LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
12 12
13SRC_URI[sha256sum] = "a580513f3285e93656a770a04e428f8bfc513848877bf278282dbfbb907fdbb4" 13SRC_URI[sha256sum] = "798db3b9481b9a5024c0e520946507676ed2f0c65317d3e95bdce1a01657cf60"
14 14
15S = "${WORKDIR}/dirty_equals-${PV}" 15S = "${WORKDIR}/dirty_equals-${PV}"
16 16
@@ -18,4 +18,9 @@ inherit pypi python_hatchling
18 18
19PYPI_PACKAGE = "dirty_equals" 19PYPI_PACKAGE = "dirty_equals"
20 20
21RDEPENDS:${PN} += "python3-pytz" 21RDEPENDS:${PN} += " \
22 python3-pytz \
23 python3-core \
24 python3-json \
25 python3-netclient \
26"