summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb b/meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb
new file mode 100644
index 000000000..584d787a7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dirty-equals_0.8.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Doing dirty (but extremely useful) things with equals."
2DESCRIPTION = "dirty-equals is a python library that (mis)uses the \
3__eq__ method to make python code (generally unit tests) more \
4declarative and therefore easier to read and write.\
5\
6dirty-equals can be used in whatever context you like, but it comes \
7into its own when writing unit tests for applications where you're \
8commonly checking the response to API calls and the contents of a database."
9HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
12
13SRC_URI[sha256sum] = "798db3b9481b9a5024c0e520946507676ed2f0c65317d3e95bdce1a01657cf60"
14
15S = "${WORKDIR}/dirty_equals-${PV}"
16
17inherit pypi python_hatchling
18
19PYPI_PACKAGE = "dirty_equals"
20
21RDEPENDS:${PN} += " \
22 python3-pytz \
23 python3-core \
24 python3-json \
25 python3-netclient \
26"