diff options
author | Alejandro Enedino Hernandez Samaniego <alejandro.hernandez@linux.microsoft.com> | 2022-03-13 20:03:28 -0600 |
---|---|---|
committer | tgamblin <trevor.gamblin@windriver.com> | 2022-03-16 09:25:28 -0400 |
commit | bb9d3688f1b5a5f91ee3e1675bd802c5f9c189f3 (patch) | |
tree | 9cce95f2998ab0ffffd88d8ffe67590773da0e66 /meta-python | |
parent | b2c6326c9c0b93d71a150500b304b23ea007f117 (diff) | |
download | meta-openembedded-bb9d3688f1b5a5f91ee3e1675bd802c5f9c189f3.tar.gz |
meta-python: Clean up recipes and classes that were moved to oe-core
Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro.hernandez@linux.microsoft.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: tgamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
24 files changed, 9 insertions, 406 deletions
diff --git a/meta-python/classes/poetry_core.bbclass b/meta-python/classes/poetry_core.bbclass deleted file mode 100644 index b2b80efa4f..0000000000 --- a/meta-python/classes/poetry_core.bbclass +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | inherit python_pep517 python3native setuptools3-base | ||
2 | |||
3 | DEPENDS += "python3-poetry-core-native" | ||
4 | |||
5 | poetry_core_do_configure () { | ||
6 | : | ||
7 | } | ||
8 | |||
9 | # TODO: ideally this uses pypa/build | ||
10 | poetry_core_do_compile () { | ||
11 | nativepython3 -c "from poetry.core.masonry import api; api.build_wheel('${PEP517_WHEEL_PATH}')" | ||
12 | } | ||
13 | do_compile[cleandirs] += "${PEP517_WHEEL_PATH}" | ||
14 | |||
15 | EXPORT_FUNCTIONS do_configure do_compile | ||
diff --git a/meta-python/classes/pyo3.bbclass b/meta-python/classes/pyo3.bbclass deleted file mode 100644 index 6ce21329c2..0000000000 --- a/meta-python/classes/pyo3.bbclass +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | # | ||
2 | # This class helps make sure that Python extensions built with PyO3 | ||
3 | # and setuptools_rust properly set up the environment for cross compilation | ||
4 | # | ||
5 | |||
6 | inherit cargo python3-dir siteinfo | ||
7 | |||
8 | export PYO3_CROSS="1" | ||
9 | export PYO3_CROSS_PYTHON_VERSION="${PYTHON_BASEVERSION}" | ||
10 | export PYO3_CROSS_LIB_DIR="${STAGING_LIBDIR}" | ||
11 | export CARGO_BUILD_TARGET="${HOST_SYS}" | ||
12 | export RUSTFLAGS | ||
13 | export PYO3_PYTHON="${PYTHON}" | ||
14 | export PYO3_CONFIG_FILE="${WORKDIR}/pyo3.config" | ||
15 | |||
16 | pyo3_do_configure () { | ||
17 | cat > ${WORKDIR}/pyo3.config << EOF | ||
18 | implementation=CPython | ||
19 | version=${PYTHON_BASEVERSION} | ||
20 | shared=true | ||
21 | abi3=false | ||
22 | lib_name=${PYTHON_DIR} | ||
23 | lib_dir=${STAGING_LIBDIR} | ||
24 | pointer_width=${SITEINFO_BITS} | ||
25 | build_flags=WITH_THREAD | ||
26 | suppress_build_script_link_lines=false | ||
27 | EOF | ||
28 | } | ||
29 | |||
30 | EXPORT_FUNCTIONS do_configure | ||
diff --git a/meta-python/classes/setuptools3_rust.bbclass b/meta-python/classes/setuptools3_rust.bbclass deleted file mode 100644 index fb11f08f89..0000000000 --- a/meta-python/classes/setuptools3_rust.bbclass +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | inherit pyo3 setuptools3 | ||
2 | |||
3 | DEPENDS += "python3-setuptools-rust-native" | ||
4 | |||
5 | setuptools3_rust_do_configure() { | ||
6 | pyo3_do_configure | ||
7 | cargo_common_do_configure | ||
8 | setuptools3_do_configure | ||
9 | } | ||
10 | |||
11 | EXPORT_FUNCTIONS do_configure | ||
diff --git a/meta-python/recipes-devtools/python/python3-aiofiles_0.8.0.bb b/meta-python/recipes-devtools/python/python3-aiofiles_0.8.0.bb index d3bca2c213..d50cb8e6f4 100644 --- a/meta-python/recipes-devtools/python/python3-aiofiles_0.8.0.bb +++ b/meta-python/recipes-devtools/python/python3-aiofiles_0.8.0.bb | |||
@@ -8,7 +8,7 @@ SRC_URI[sha256sum] = "8334f23235248a3b2e83b2c3a78a22674f39969b96397126cc93664d9a | |||
8 | 8 | ||
9 | PYPI_PACKAGE = "aiofiles" | 9 | PYPI_PACKAGE = "aiofiles" |
10 | 10 | ||
11 | inherit pypi poetry_core | 11 | inherit pypi python_poetry_core |
12 | 12 | ||
13 | RDEPENDS:${PN} = "\ | 13 | RDEPENDS:${PN} = "\ |
14 | ${PYTHON_PN}-asyncio \ | 14 | ${PYTHON_PN}-asyncio \ |
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb deleted file mode 100644 index c052cb8c82..0000000000 --- a/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | DESCRIPTION = "A fast, pure Python library for parsing and serializing ASN.1 structures" | ||
2 | HOMEPAGE = "https://github.com/wbond/asn1crypto" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7439e38f5e04ff62fae436184786b7ca" | ||
6 | |||
7 | PYPI_PACKAGE = "asn1crypto" | ||
8 | |||
9 | SRC_URI[md5sum] = "00bf5b72d37778e62cc73b1d8909ae27" | ||
10 | SRC_URI[sha256sum] = "f4f6e119474e58e04a2b1af817eb585b4fd72bdd89b998624712b5c99be7641c" | ||
11 | |||
12 | inherit pypi setuptools3 | ||
13 | |||
14 | RDEPENDS:${PN}:class-target += " \ | ||
15 | ${PYTHON_PN}-codecs \ | ||
16 | ${PYTHON_PN}-crypt \ | ||
17 | ${PYTHON_PN}-ctypes \ | ||
18 | ${PYTHON_PN}-datetime \ | ||
19 | ${PYTHON_PN}-io \ | ||
20 | ${PYTHON_PN}-netclient \ | ||
21 | ${PYTHON_PN}-numbers \ | ||
22 | ${PYTHON_PN}-shell \ | ||
23 | " | ||
24 | |||
25 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.15.0.bb b/meta-python/recipes-devtools/python/python3-cffi_1.15.0.bb deleted file mode 100644 index c36f23b3dd..0000000000 --- a/meta-python/recipes-devtools/python/python3-cffi_1.15.0.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Foreign Function Interface for Python calling C code" | ||
2 | HOMEPAGE = "http://cffi.readthedocs.org/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf" | ||
5 | DEPENDS += "libffi ${PYTHON_PN}-pycparser" | ||
6 | |||
7 | SRC_URI[sha256sum] = "920f0d66a896c2d99f0adbb391f990a84091179542c205fa53ce5787aff87954" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS:${PN}:class-target = " \ | ||
12 | ${PYTHON_PN}-ctypes \ | ||
13 | ${PYTHON_PN}-io \ | ||
14 | ${PYTHON_PN}-pycparser \ | ||
15 | ${PYTHON_PN}-shell \ | ||
16 | " | ||
17 | |||
18 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb b/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb deleted file mode 100644 index b9e6b811c3..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | SUMMARY = "Test vectors for the cryptography package." | ||
2 | HOMEPAGE = "https://cryptography.io/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0 | BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \ | ||
6 | file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \ | ||
7 | file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b" | ||
8 | |||
9 | # NOTE: Make sure to keep this recipe at the same version as python3-cryptography | ||
10 | # Upgrade both recipes at the same time | ||
11 | |||
12 | SRC_URI[sha256sum] = "fc8490afd5424342b868215435bd174dcd76ab396b4ea9435498be5721dcd598" | ||
13 | |||
14 | PYPI_PACKAGE = "cryptography_vectors" | ||
15 | |||
16 | inherit pypi setuptools3 | ||
17 | |||
18 | DEPENDS += " \ | ||
19 | ${PYTHON_PN}-cryptography \ | ||
20 | " | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
23 | |||
24 | UPSTREAM_CHECK_REGEX = "" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch b/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch deleted file mode 100644 index d7ab757bb5..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From ec8d3f3c61280c8140b34ed1479baef5e706f064 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Fri, 14 Jan 2022 22:02:25 -0800 | ||
4 | Subject: [PATCH] Cargo.toml: specify pem version | ||
5 | |||
6 | pem = "1.0" is not resolving, specify the current | ||
7 | pem = { version: "1.0.2"} | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
12 | --- | ||
13 | src/rust/Cargo.toml | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml | ||
17 | index 617167d0..174eaa80 100644 | ||
18 | --- a/src/rust/Cargo.toml | ||
19 | +++ b/src/rust/Cargo.toml | ||
20 | @@ -9,7 +9,7 @@ publish = false | ||
21 | lazy_static = "1" | ||
22 | pyo3 = { version = "0.15.1" } | ||
23 | asn1 = { version = "0.8.7", default-features = false, features = ["derive"] } | ||
24 | -pem = "1.0" | ||
25 | +pem = { version = "1.0.2" } | ||
26 | chrono = { version = "0.4", default-features = false, features = ["alloc", "clock"] } | ||
27 | ouroboros = "0.13" | ||
28 | |||
29 | -- | ||
30 | 2.30.2 | ||
31 | |||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch b/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch deleted file mode 100644 index 366e3a4d39..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From 4b73298b214a5b69ea6edf3c2e21dd82b2b29708 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Fri, 14 Jan 2022 22:34:59 -0800 | ||
4 | Subject: [PATCH 2/2] Cargo.toml: edition 2018 -> 2021 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
9 | --- | ||
10 | src/rust/Cargo.toml | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml | ||
14 | index 174eaa80..7ad053d9 100644 | ||
15 | --- a/src/rust/Cargo.toml | ||
16 | +++ b/src/rust/Cargo.toml | ||
17 | @@ -2,7 +2,7 @@ | ||
18 | name = "cryptography-rust" | ||
19 | version = "0.1.0" | ||
20 | authors = ["The cryptography developers <cryptography-dev@python.org>"] | ||
21 | -edition = "2018" | ||
22 | +edition = "2021" | ||
23 | publish = false | ||
24 | |||
25 | [dependencies] | ||
26 | -- | ||
27 | 2.30.2 | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py b/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py deleted file mode 100755 index c111a9074c..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | #!/usr/bin/env python3 | ||
2 | # https://stackoverflow.com/questions/22102999/get-total-physical-memory-in-python/28161352 | ||
3 | import sys | ||
4 | meminfo = dict((i.split()[0].rstrip(':'),int(i.split()[1])) for i in open('/proc/meminfo').readlines()) | ||
5 | mem_free = meminfo['MemTotal']/1024./1024. | ||
6 | if mem_free < 2.: | ||
7 | raise RuntimeError("Insufficient free memory({:.3f}): requires > 2 GB".format(mem_free)) | ||
8 | sys.exit(1) | ||
9 | else: | ||
10 | print("Free memory: {:.3f} GB".format(mem_free)) | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest deleted file mode 100644 index 1e97dda63e..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | if ./check-memfree.py; then | ||
3 | pytest -vvvv tests/ | ||
4 | fi | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_36.0.1.bb b/meta-python/recipes-devtools/python/python3-cryptography_36.0.1.bb deleted file mode 100644 index 00791dce2d..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography_36.0.1.bb +++ /dev/null | |||
@@ -1,123 +0,0 @@ | |||
1 | SUMMARY = "Provides cryptographic recipes and primitives to python developers" | ||
2 | HOMEPAGE = "https://cryptography.io/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "( Apache-2.0 | BSD-3-Clause ) & PSF-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba \ | ||
6 | file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \ | ||
7 | file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \ | ||
8 | file://LICENSE.PSF;md5=43c37d21e1dbad10cddcd150ba2c0595 \ | ||
9 | " | ||
10 | LDSHARED += "-pthread" | ||
11 | |||
12 | SRC_URI[sha256sum] = "53e5c1dc3d7a953de055d77bef2ff607ceef7a2aac0353b5d630ab67f7423638" | ||
13 | |||
14 | SRC_URI += " \ | ||
15 | file://run-ptest \ | ||
16 | file://check-memfree.py \ | ||
17 | file://0001-Cargo.toml-specify-pem-version.patch \ | ||
18 | file://0002-Cargo.toml-edition-2018-2021.patch \ | ||
19 | " | ||
20 | |||
21 | inherit pypi setuptools3_rust | ||
22 | |||
23 | PIP_INSTALL_DIST_PATH = "${S}/dist" | ||
24 | |||
25 | DEPENDS += " \ | ||
26 | ${PYTHON_PN}-asn1crypto-native \ | ||
27 | ${PYTHON_PN}-cffi-native \ | ||
28 | ${PYTHON_PN}-setuptools-rust-native \ | ||
29 | ${PYTHON_PN}-six-native \ | ||
30 | " | ||
31 | |||
32 | SRC_URI += " \ | ||
33 | crate://crates.io/Inflector/0.11.4 \ | ||
34 | crate://crates.io/aliasable/0.1.3 \ | ||
35 | crate://crates.io/asn1/0.8.7 \ | ||
36 | crate://crates.io/asn1_derive/0.8.7 \ | ||
37 | crate://crates.io/autocfg/1.0.1 \ | ||
38 | crate://crates.io/base64/0.13.0 \ | ||
39 | crate://crates.io/bitflags/1.3.2 \ | ||
40 | crate://crates.io/cfg-if/1.0.0 \ | ||
41 | crate://crates.io/chrono/0.4.19 \ | ||
42 | crate://crates.io/indoc-impl/0.3.6 \ | ||
43 | crate://crates.io/indoc/0.3.6 \ | ||
44 | crate://crates.io/instant/0.1.12 \ | ||
45 | crate://crates.io/lazy_static/1.4.0 \ | ||
46 | crate://crates.io/libc/0.2.112 \ | ||
47 | crate://crates.io/lock_api/0.4.5 \ | ||
48 | crate://crates.io/num-integer/0.1.44 \ | ||
49 | crate://crates.io/num-traits/0.2.14 \ | ||
50 | crate://crates.io/once_cell/1.9.0 \ | ||
51 | crate://crates.io/ouroboros/0.13.0 \ | ||
52 | crate://crates.io/ouroboros_macro/0.13.0 \ | ||
53 | crate://crates.io/parking_lot/0.11.2 \ | ||
54 | crate://crates.io/parking_lot_core/0.8.5 \ | ||
55 | crate://crates.io/paste-impl/0.1.18 \ | ||
56 | crate://crates.io/paste/0.1.18 \ | ||
57 | crate://crates.io/pem/1.0.2 \ | ||
58 | crate://crates.io/proc-macro-error-attr/1.0.4 \ | ||
59 | crate://crates.io/proc-macro-error/1.0.4 \ | ||
60 | crate://crates.io/proc-macro-hack/0.5.19 \ | ||
61 | crate://crates.io/proc-macro2/1.0.36 \ | ||
62 | crate://crates.io/pyo3-build-config/0.15.1 \ | ||
63 | crate://crates.io/pyo3-macros-backend/0.15.1 \ | ||
64 | crate://crates.io/pyo3-macros/0.15.1 \ | ||
65 | crate://crates.io/pyo3/0.15.1 \ | ||
66 | crate://crates.io/quote/1.0.14 \ | ||
67 | crate://crates.io/redox_syscall/0.2.10 \ | ||
68 | crate://crates.io/scopeguard/1.1.0 \ | ||
69 | crate://crates.io/smallvec/1.7.0 \ | ||
70 | crate://crates.io/stable_deref_trait/1.2.0 \ | ||
71 | crate://crates.io/syn/1.0.85 \ | ||
72 | crate://crates.io/unicode-xid/0.2.2 \ | ||
73 | crate://crates.io/unindent/0.1.7 \ | ||
74 | crate://crates.io/version_check/0.9.4 \ | ||
75 | crate://crates.io/winapi-i686-pc-windows-gnu/0.4.0 \ | ||
76 | crate://crates.io/winapi-x86_64-pc-windows-gnu/0.4.0 \ | ||
77 | crate://crates.io/winapi/0.3.9 \ | ||
78 | " | ||
79 | |||
80 | RDEPENDS:${PN} += " \ | ||
81 | ${PYTHON_PN}-asn1crypto \ | ||
82 | ${PYTHON_PN}-cffi \ | ||
83 | ${PYTHON_PN}-idna \ | ||
84 | ${PYTHON_PN}-setuptools \ | ||
85 | ${PYTHON_PN}-six \ | ||
86 | " | ||
87 | |||
88 | RDEPENDS:${PN}:append:class-target = " \ | ||
89 | ${PYTHON_PN}-numbers \ | ||
90 | ${PYTHON_PN}-threading \ | ||
91 | " | ||
92 | |||
93 | RDEPENDS:${PN}-ptest += " \ | ||
94 | ${PYTHON_PN}-bcrypt \ | ||
95 | ${PYTHON_PN}-cryptography-vectors \ | ||
96 | ${PYTHON_PN}-hypothesis \ | ||
97 | ${PYTHON_PN}-iso8601 \ | ||
98 | ${PYTHON_PN}-pretend \ | ||
99 | ${PYTHON_PN}-psutil \ | ||
100 | ${PYTHON_PN}-pytest \ | ||
101 | ${PYTHON_PN}-pytest-subtests \ | ||
102 | ${PYTHON_PN}-pytz \ | ||
103 | " | ||
104 | |||
105 | inherit ptest | ||
106 | |||
107 | do_install_ptest() { | ||
108 | install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/ | ||
109 | install -d ${D}${PTEST_PATH}/tests | ||
110 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
111 | install -d ${D}${PTEST_PATH}/tests/hazmat | ||
112 | cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/ | ||
113 | cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/ | ||
114 | } | ||
115 | |||
116 | FILES:${PN}-ptest += " \ | ||
117 | ${PTEST_PATH}/check-memfree.py \ | ||
118 | " | ||
119 | FILES:${PN}-dbg += " \ | ||
120 | ${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/hazmat/bindings/.debug \ | ||
121 | " | ||
122 | |||
123 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb index cf76a142b5..eb8269e4f5 100644 --- a/meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb +++ b/meta-python/recipes-devtools/python/python3-dnspython_2.2.0.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "e79351e032d0b606b98d38a4b0e6e2275b31a5b85c873e587cc11b73aca026d6" | 6 | SRC_URI[sha256sum] = "e79351e032d0b606b98d38a4b0e6e2275b31a5b85c873e587cc11b73aca026d6" |
7 | 7 | ||
8 | inherit pypi poetry_core ptest | 8 | inherit pypi python_poetry_core ptest |
9 | 9 | ||
10 | SRC_URI += " \ | 10 | SRC_URI += " \ |
11 | file://run-ptest \ | 11 | file://run-ptest \ |
diff --git a/meta-python/recipes-devtools/python/python3-iso8601_1.0.2.bb b/meta-python/recipes-devtools/python/python3-iso8601_1.0.2.bb index aabc47d69b..93af233d29 100644 --- a/meta-python/recipes-devtools/python/python3-iso8601_1.0.2.bb +++ b/meta-python/recipes-devtools/python/python3-iso8601_1.0.2.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "27f503220e6845d9db954fb212b95b0362d8b7e6c1b2326a87061c3de93594b1" | 6 | SRC_URI[sha256sum] = "27f503220e6845d9db954fb212b95b0362d8b7e6c1b2326a87061c3de93594b1" |
7 | 7 | ||
8 | inherit pypi poetry_core | 8 | inherit pypi python_poetry_core |
9 | 9 | ||
10 | RDEPENDS:${PN} += "\ | 10 | RDEPENDS:${PN} += "\ |
11 | ${PYTHON_PN}-datetime \ | 11 | ${PYTHON_PN}-datetime \ |
diff --git a/meta-python/recipes-devtools/python/python3-isort_5.10.1.bb b/meta-python/recipes-devtools/python/python3-isort_5.10.1.bb index 6a6d5ed130..27977821c6 100644 --- a/meta-python/recipes-devtools/python/python3-isort_5.10.1.bb +++ b/meta-python/recipes-devtools/python/python3-isort_5.10.1.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148 | |||
6 | 6 | ||
7 | SRC_URI[sha256sum] = "e8443a5e7a020e9d7f97f1d7d9cd17c88bcb3bc7e218bf9cf5095fe550be2951" | 7 | SRC_URI[sha256sum] = "e8443a5e7a020e9d7f97f1d7d9cd17c88bcb3bc7e218bf9cf5095fe550be2951" |
8 | 8 | ||
9 | inherit pypi poetry_core | 9 | inherit pypi python_poetry_core |
10 | 10 | ||
11 | RDEPENDS:${PN} += "\ | 11 | RDEPENDS:${PN} += "\ |
12 | ${PYTHON_PN}-datetime \ | 12 | ${PYTHON_PN}-datetime \ |
diff --git a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb index c5a74796a0..1aa91deac5 100644 --- a/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb +++ b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.5.bb | |||
@@ -10,7 +10,7 @@ RDEPENDS:${PN} = "pkgconfig \ | |||
10 | ${PYTHON_PN}-shell \ | 10 | ${PYTHON_PN}-shell \ |
11 | " | 11 | " |
12 | 12 | ||
13 | inherit pypi poetry_core | 13 | inherit pypi python_poetry_core |
14 | 14 | ||
15 | BBCLASSEXTEND = "native" | 15 | BBCLASSEXTEND = "native" |
16 | 16 | ||
diff --git a/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb b/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb index 22d7076d01..f3e9b05521 100644 --- a/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb +++ b/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb | |||
@@ -21,7 +21,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=104d5c3c653aeededf4076773aa4c236 \ | |||
21 | 21 | ||
22 | SRC_URI[sha256sum] = "951fc7c1f8d710a94cb49019ee3742125039fc659675912ea614ac2aa405b118" | 22 | SRC_URI[sha256sum] = "951fc7c1f8d710a94cb49019ee3742125039fc659675912ea614ac2aa405b118" |
23 | 23 | ||
24 | inherit poetry_core pypi | 24 | inherit python_poetry_core pypi |
25 | 25 | ||
26 | RDEPENDS:${PN}:append:class-target = "\ | 26 | RDEPENDS:${PN}:append:class-target = "\ |
27 | python3-compression \ | 27 | python3-compression \ |
diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb deleted file mode 100644 index 53b7367903..0000000000 --- a/meta-python/recipes-devtools/python/python3-pycparser_2.21.bb +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | SUMMARY = "Parser of the C language, written in pure Python" | ||
2 | HOMEPAGE = "https://github.com/eliben/pycparser" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea" | ||
5 | |||
6 | SRC_URI[sha256sum] = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206" | ||
7 | |||
8 | inherit pypi setuptools3 | ||
9 | |||
10 | BBCLASSEXTEND = "native nativesdk" | ||
11 | |||
12 | RDEPENDS:${PN}:class-target += "\ | ||
13 | ${PYTHON_PN}-netclient \ | ||
14 | ${PYTHON_PN}-ply \ | ||
15 | ${PYTHON_PN}-pprint \ | ||
16 | " | ||
17 | |||
18 | RSUGGESTS:${PN}:class-target += "\ | ||
19 | cpp \ | ||
20 | cpp-symlinks \ | ||
21 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.155.1.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.155.1.bb index ef18671a0a..613a009d43 100644 --- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.155.1.bb +++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.155.1.bb | |||
@@ -7,7 +7,7 @@ SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main" | |||
7 | SRCREV = "03dc22f9598e6caae81b0e40ce27bf3f17799f4e" | 7 | SRCREV = "03dc22f9598e6caae81b0e40ce27bf3f17799f4e" |
8 | S = "${WORKDIR}/git" | 8 | S = "${WORKDIR}/git" |
9 | 9 | ||
10 | inherit poetry_core | 10 | inherit python_poetry_core |
11 | 11 | ||
12 | PIP_INSTALL_PACKAGE = "pymisp" | 12 | PIP_INSTALL_PACKAGE = "pymisp" |
13 | 13 | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb b/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb index 143125bbb1..97fce690ec 100644 --- a/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb +++ b/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb | |||
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "10befedd97e73fc18b902d02aa3b24e8978aa162242c1b664849c886c0 | |||
12 | 12 | ||
13 | S = "${WORKDIR}/pyruvate-${PV}" | 13 | S = "${WORKDIR}/pyruvate-${PV}" |
14 | 14 | ||
15 | inherit pypi setuptools3_rust | 15 | inherit pypi python_setuptools3_rust |
16 | 16 | ||
17 | PIP_INSTALL_DIST_PATH = "${S}/dist" | 17 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
18 | 18 | ||
diff --git a/meta-python/recipes-devtools/python/python3-rsa_4.8.bb b/meta-python/recipes-devtools/python/python3-rsa_4.8.bb index 7e572a933d..21b664ddd1 100644 --- a/meta-python/recipes-devtools/python/python3-rsa_4.8.bb +++ b/meta-python/recipes-devtools/python/python3-rsa_4.8.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c403f6882d4f97a9cd927df987d55634" | |||
6 | 6 | ||
7 | SRC_URI[sha256sum] = "5c6bd9dc7a543b7fe4304a631f8a8a3b674e2bbfc49c2ae96200cdbe55df6b17" | 7 | SRC_URI[sha256sum] = "5c6bd9dc7a543b7fe4304a631f8a8a3b674e2bbfc49c2ae96200cdbe55df6b17" |
8 | 8 | ||
9 | inherit pypi poetry_core update-alternatives | 9 | inherit pypi python_poetry_core update-alternatives |
10 | 10 | ||
11 | ALTERNATIVE:${PN} = "\ | 11 | ALTERNATIVE:${PN} = "\ |
12 | pyrsa-decrypt \ | 12 | pyrsa-decrypt \ |
diff --git a/meta-python/recipes-devtools/python/python3-semantic-version_2.9.0.bb b/meta-python/recipes-devtools/python/python3-semantic-version_2.9.0.bb deleted file mode 100644 index ee635871bf..0000000000 --- a/meta-python/recipes-devtools/python/python3-semantic-version_2.9.0.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | SUMMARY = "A library implementing the 'SemVer' scheme." | ||
2 | DESCRIPTION = "Semantic version comparison for Python (see http://semver.org/)" | ||
3 | HOMEPAGE = "https://github.com/rbarrois/python-semanticversion" | ||
4 | LICENSE = "BSD-2-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2" | ||
6 | |||
7 | SRC_URI[sha256sum] = "abf54873553e5e07a6fd4d5f653b781f5ae41297a493666b59dcf214006a12b2" | ||
8 | |||
9 | PYPI_PACKAGE = "semantic_version" | ||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb b/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb deleted file mode 100644 index 73dcbb26e6..0000000000 --- a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | SUMMARY = "Setuptools Rust extension plugin" | ||
2 | DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \ | ||
3 | Python extensions implemented with PyO3 or rust-cpython.\ | ||
4 | \ | ||
5 | Compile and distribute Python extensions written in Rust as easily as if they were written in C." | ||
6 | HOMEPAGE = "https://github.com/PyO3/setuptools-rust" | ||
7 | BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues" | ||
8 | |||
9 | LICENSE = "MIT" | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5" | ||
11 | |||
12 | SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz" | ||
13 | SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1" | ||
14 | |||
15 | # While this has a pyproject.toml and declares that setuptools_build_meta should work | ||
16 | # it results in a wheel named UNKNOWN-0.0.0-py3-none-any.whl so stay with setuptools3 | ||
17 | # until that can be resolved | ||
18 | inherit cargo pypi setuptools3 native | ||
19 | |||
20 | # For some reason the wheel is built in ${S} not ${B} | ||
21 | PIP_INSTALL_DIST_PATH = "${S}/dist" | ||
22 | PIP_INSTALL_PACKAGE = "setuptools_rust" | ||
23 | |||
24 | DEPENDS += "python3-setuptools-scm-native python3-wheel-native" | ||
25 | |||
26 | RDEPENDS:${PN}:class-native += " \ | ||
27 | python3-semantic-version-native \ | ||
28 | python3-setuptools-native \ | ||
29 | python3-setuptools-scm-native \ | ||
30 | python3-toml-native \ | ||
31 | python3-typing-extensions-native \ | ||
32 | python3-wheel-native \ | ||
33 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-typing-extensions_3.10.0.0.bb b/meta-python/recipes-devtools/python/python3-typing-extensions_3.10.0.0.bb deleted file mode 100644 index a5f491c770..0000000000 --- a/meta-python/recipes-devtools/python/python3-typing-extensions_3.10.0.0.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | HOMEPAGE = "https://github.com/python/typing" | ||
2 | LICENSE = "PSF-2.0" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f" | ||
4 | |||
5 | # The name on PyPi is slightly different. | ||
6 | PYPI_PACKAGE = "typing_extensions" | ||
7 | |||
8 | SRC_URI[sha256sum] = "50b6f157849174217d0656f99dc82fe932884fb250826c18350e159ec6cdf342" | ||
9 | |||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | BBCLASSEXTEND = "native nativesdk" | ||