summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb b/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
deleted file mode 100644
index 73dcbb26e..000000000
--- a/meta-python/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SUMMARY = "Setuptools Rust extension plugin"
2DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
3Python extensions implemented with PyO3 or rust-cpython.\
4\
5Compile and distribute Python extensions written in Rust as easily as if they were written in C."
6HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
7BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
11
12SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz"
13SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1"
14
15# While this has a pyproject.toml and declares that setuptools_build_meta should work
16# it results in a wheel named UNKNOWN-0.0.0-py3-none-any.whl so stay with setuptools3
17# until that can be resolved
18inherit cargo pypi setuptools3 native
19
20# For some reason the wheel is built in ${S} not ${B}
21PIP_INSTALL_DIST_PATH = "${S}/dist"
22PIP_INSTALL_PACKAGE = "setuptools_rust"
23
24DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
25
26RDEPENDS:${PN}:class-native += " \
27 python3-semantic-version-native \
28 python3-setuptools-native \
29 python3-setuptools-scm-native \
30 python3-toml-native \
31 python3-typing-extensions-native \
32 python3-wheel-native \
33"