summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:31 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:11 -0800
commit90b1f996af78504a6ea233d6db976a9752981511 (patch)
treef4ba22268a838db8038e8592c4d243b5c9a8d20a /meta-python
parent6c2571e713f77f59c9ce255a5699f7836d8bb3bc (diff)
downloadmeta-openembedded-90b1f996af78504a6ea233d6db976a9752981511.tar.gz
Remove deprecated python3-argparse from the RDEPENDS
The python3-argparse package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-can.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-can_2.0.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-chardet.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-chardet_3.0.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-django.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.11.9.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_3.3.2.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb1
15 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc
index 802098ad3..8cdd4d38f 100644
--- a/meta-python/recipes-devtools/python/python-can.inc
+++ b/meta-python/recipes-devtools/python/python-can.inc
@@ -9,7 +9,6 @@ SRC_URI[sha256sum] = "da89e94fa234d4ebe7f43a26d4b06a5d14ea767fbd2c4767732e4d9644
9PYPI_PACKAGE="python-can" 9PYPI_PACKAGE="python-can"
10 10
11RDEPENDS_${PN}_class-target += "\ 11RDEPENDS_${PN}_class-target += "\
12 ${PYTHON_PN}-argparse \
13 ${PYTHON_PN}-ctypes \ 12 ${PYTHON_PN}-ctypes \
14 ${PYTHON_PN}-importlib \ 13 ${PYTHON_PN}-importlib \
15 ${PYTHON_PN}-logging \ 14 ${PYTHON_PN}-logging \
diff --git a/meta-python/recipes-devtools/python/python-can_2.0.0.bb b/meta-python/recipes-devtools/python/python-can_2.0.0.bb
index a698ad365..fcfde2f63 100644
--- a/meta-python/recipes-devtools/python/python-can_2.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-can_2.0.0.bb
@@ -2,5 +2,6 @@ require python-can.inc
2inherit pypi setuptools 2inherit pypi setuptools
3 3
4RDEPENDS_${PN}_class-target += "\ 4RDEPENDS_${PN}_class-target += "\
5 ${PYTHON_PN}-argparse \
5 ${PYTHON_PN}-zlib \ 6 ${PYTHON_PN}-zlib \
6" 7"
diff --git a/meta-python/recipes-devtools/python/python-chardet.inc b/meta-python/recipes-devtools/python/python-chardet.inc
index 246a65aa6..630529978 100644
--- a/meta-python/recipes-devtools/python/python-chardet.inc
+++ b/meta-python/recipes-devtools/python/python-chardet.inc
@@ -19,6 +19,5 @@ FILES_${PN}-cli += " \
19" 19"
20 20
21RDEPENDS_${PN}_class-target += " \ 21RDEPENDS_${PN}_class-target += " \
22 ${PYTHON_PN}-argparse \
23 ${PYTHON_PN}-logging \ 22 ${PYTHON_PN}-logging \
24" 23"
diff --git a/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb
index b7a46e9d7..3b6feeef1 100644
--- a/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb
@@ -1,2 +1,4 @@
1inherit setuptools 1inherit setuptools
2require python-chardet.inc 2require python-chardet.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-argparse"
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc
index 8fff75d5a..9287715ea 100644
--- a/meta-python/recipes-devtools/python/python-django.inc
+++ b/meta-python/recipes-devtools/python/python-django.inc
@@ -14,7 +14,6 @@ FILES_${PN} += "${datadir}/django"
14BBCLASSEXTEND = "native nativesdk" 14BBCLASSEXTEND = "native nativesdk"
15 15
16RDEPENDS_${PN} += "\ 16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-argparse \
18 ${PYTHON_PN}-compression \ 17 ${PYTHON_PN}-compression \
19 ${PYTHON_PN}-ctypes \ 18 ${PYTHON_PN}-ctypes \
20 ${PYTHON_PN}-datetime \ 19 ${PYTHON_PN}-datetime \
diff --git a/meta-python/recipes-devtools/python/python-django_1.11.9.bb b/meta-python/recipes-devtools/python/python-django_1.11.9.bb
index ed92c9bfe..db48ffdd7 100644
--- a/meta-python/recipes-devtools/python/python-django_1.11.9.bb
+++ b/meta-python/recipes-devtools/python/python-django_1.11.9.bb
@@ -1,4 +1,4 @@
1require python-django.inc 1require python-django.inc
2inherit setuptools 2inherit setuptools
3 3
4RDEPENDS_${PN} += "${PYTHON_PN}-zlib" 4RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-zlib"
diff --git a/meta-python/recipes-devtools/python/python-pyserial.inc b/meta-python/recipes-devtools/python/python-pyserial.inc
index 8fe3f2c5e..52a7e05ce 100644
--- a/meta-python/recipes-devtools/python/python-pyserial.inc
+++ b/meta-python/recipes-devtools/python/python-pyserial.inc
@@ -31,7 +31,6 @@ FILES_${PN}-win32 = " \
31" 31"
32 32
33RDEPENDS_${PN} = "\ 33RDEPENDS_${PN} = "\
34 ${PYTHON_PN}-argparse \
35 ${PYTHON_PN}-fcntl \ 34 ${PYTHON_PN}-fcntl \
36 ${PYTHON_PN}-io \ 35 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-logging \ 36 ${PYTHON_PN}-logging \
diff --git a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
index 91a0f26ac..0497087ac 100644
--- a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
@@ -1,4 +1,4 @@
1inherit setuptools 1inherit setuptools
2require python-pyserial.inc 2require python-pyserial.inc
3 3
4RDEPENDS_${PN} += "${PYTHON_PN}-importlib" 4RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-importlib"
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner.inc b/meta-python/recipes-devtools/python/python-pytest-runner.inc
index 262448de1..7546743fb 100644
--- a/meta-python/recipes-devtools/python/python-pytest-runner.inc
+++ b/meta-python/recipes-devtools/python/python-pytest-runner.inc
@@ -10,7 +10,7 @@ inherit pypi
10DEPENDS += " \ 10DEPENDS += " \
11 ${PYTHON_PN}-setuptools-scm-native" 11 ${PYTHON_PN}-setuptools-scm-native"
12 12
13RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-argparse ${PYTHON_PN}-debugger ${PYTHON_PN}-json \ 13RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
14 ${PYTHON_PN}-io" 14 ${PYTHON_PN}-io"
15 15
16BBCLASSEXTEND = "native nativesdk" 16BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb b/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb
index 0a5055cb3..1765a732d 100644
--- a/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb
+++ b/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb
@@ -2,4 +2,4 @@ inherit setuptools
2require python-pytest-runner.inc 2require python-pytest-runner.inc
3 3
4# Dependency only exists for python2 4# Dependency only exists for python2
5RDEPENDS_${PN} += "python-compiler" 5RDEPENDS_${PN} += "python-argparse python-compiler"
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 17d8233f8..c997da990 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -10,7 +10,6 @@ SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools
10 file://pytest_version_fix.patch " 10 file://pytest_version_fix.patch "
11 11
12RDEPENDS_${PN}_class-target += " \ 12RDEPENDS_${PN}_class-target += " \
13 ${PYTHON_PN}-argparse \
14 ${PYTHON_PN}-attrs \ 13 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-debugger \ 14 ${PYTHON_PN}-debugger \
16 ${PYTHON_PN}-json \ 15 ${PYTHON_PN}-json \
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb b/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb
index d7bd0a402..201ab050c 100644
--- a/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb
@@ -2,6 +2,7 @@ inherit pypi setuptools
2require python-pytest.inc 2require python-pytest.inc
3 3
4RDEPENDS_${PN}_class-target += " \ 4RDEPENDS_${PN}_class-target += " \
5 ${PYTHON_PN}-argparse \
5 ${PYTHON_PN}-compiler \ 6 ${PYTHON_PN}-compiler \
6 ${PYTHON_PN}-funcsigs \ 7 ${PYTHON_PN}-funcsigs \
7" 8"
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm.inc b/meta-python/recipes-devtools/python/python-setuptools-scm.inc
index 7a58f14e4..eb66580a6 100644
--- a/meta-python/recipes-devtools/python/python-setuptools-scm.inc
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm.inc
@@ -8,7 +8,7 @@ SRC_URI[sha256sum] = "e163e8a12d2121f77575773cfc2b5988275dc1f1d2541fdf780127c29d
8PYPI_PACKAGE = "setuptools_scm" 8PYPI_PACKAGE = "setuptools_scm"
9inherit pypi 9inherit pypi
10 10
11RDEPENDS_${PN}_class-target = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-argparse ${PYTHON_PN}-debugger ${PYTHON_PN}-json" 11RDEPENDS_${PN}_class-target = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json"
12RDEPENDS_${PN}_class-native = "${PYTHON_PN}-setuptools-native" 12RDEPENDS_${PN}_class-native = "${PYTHON_PN}-setuptools-native"
13 13
14BBCLASSEXTEND = "native" 14BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb
index 5f9bb0b5c..64b36e3a0 100644
--- a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb
@@ -1,2 +1,4 @@
1inherit setuptools 1inherit setuptools
2require python-setuptools-scm.inc 2require python-setuptools-scm.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-argparse"
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
index 436a664a8..0ca58c7b7 100644
--- a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
@@ -22,7 +22,6 @@ DISTUTILS_INSTALL_ARGS = "--prefix=${D}/${prefix} \
22FILES_${PN} += "${datadir}/*" 22FILES_${PN} += "${datadir}/*"
23 23
24RDEPENDS_${PN} += " \ 24RDEPENDS_${PN} += " \
25 ${PYTHON_PN}-argparse \
26 ${PYTHON_PN}-compression \ 25 ${PYTHON_PN}-compression \
27 ${PYTHON_PN}-doctest \ 26 ${PYTHON_PN}-doctest \
28 ${PYTHON_PN}-logging \ 27 ${PYTHON_PN}-logging \