summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:30 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:11 -0800
commit6c2571e713f77f59c9ce255a5699f7836d8bb3bc (patch)
tree451368ab89cd2d6b900b783f8d19c3ddc23490ff /meta-python
parent87cc37b07209002d52e00693d74748fad9a5e8a2 (diff)
downloadmeta-openembedded-6c2571e713f77f59c9ce255a5699f7836d8bb3bc.tar.gz
Remove deprecated python3-enum from the RDEPENDS
The python3-enum package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-automat_0.6.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-click_6.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-decorator_4.2.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpatch_1.21.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-ply_3.10.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-serpent_1.23.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb1
18 files changed, 4 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
index bc672158a..9d9837228 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
@@ -2,7 +2,6 @@ inherit setuptools3
2require python-asn1crypto.inc 2require python-asn1crypto.inc
3 3
4RDEPENDS_${PN}_class-target += " \ 4RDEPENDS_${PN}_class-target += " \
5 ${PYTHON_PN}-enum \
6 ${PYTHON_PN}-selectors \ 5 ${PYTHON_PN}-selectors \
7 ${PYTHON_PN}-shell \ 6 ${PYTHON_PN}-shell \
8" 7"
diff --git a/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb b/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb
index 0469e6138..2c747643f 100644
--- a/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-automat_0.6.0.bb
@@ -1,4 +1,2 @@
1inherit setuptools3 1inherit setuptools3
2require python-automat.inc 2require python-automat.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-enum "
diff --git a/meta-python/recipes-devtools/python/python3-click_6.7.bb b/meta-python/recipes-devtools/python/python3-click_6.7.bb
index ecd1514a8..192064404 100644
--- a/meta-python/recipes-devtools/python/python3-click_6.7.bb
+++ b/meta-python/recipes-devtools/python/python3-click_6.7.bb
@@ -1,4 +1,2 @@
1inherit pypi setuptools3 1inherit pypi setuptools3
2require python-click.inc 2require python-click.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-enum"
diff --git a/meta-python/recipes-devtools/python/python3-decorator_4.2.1.bb b/meta-python/recipes-devtools/python/python3-decorator_4.2.1.bb
index 7840b20c0..844cbdc9a 100644
--- a/meta-python/recipes-devtools/python/python3-decorator_4.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-decorator_4.2.1.bb
@@ -1,6 +1,2 @@
1inherit setuptools3 1inherit setuptools3
2require python-decorator.inc 2require python-decorator.inc
3
4RDEPENDS_${PN}_class-target += "\
5 ${PYTHON_PN}-enum \
6"
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
index 26024c68f..e28389ef1 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
@@ -3,7 +3,6 @@ require python-dnspython.inc
3 3
4# Requires _pydecimal.py which is in misc 4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
8 ${PYTHON_PN}-selectors \ 7 ${PYTHON_PN}-selectors \
9" 8"
diff --git a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
index 3d30af29a..bd2bcb3de 100644
--- a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
@@ -1,4 +1,4 @@
1inherit setuptools3 1inherit setuptools3
2require python-hyperlink.inc 2require python-hyperlink.inc
3 3
4RDEPENDS_${PN} += "${PYTHON_PN}-selectors ${PYTHON_PN}-enum" 4RDEPENDS_${PN} += "${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-jsonpatch_1.21.bb b/meta-python/recipes-devtools/python/python3-jsonpatch_1.21.bb
index eb5593485..73efceeed 100644
--- a/meta-python/recipes-devtools/python/python3-jsonpatch_1.21.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonpatch_1.21.bb
@@ -1,6 +1,2 @@
1inherit setuptools3 1inherit setuptools3
2require python-jsonpatch.inc 2require python-jsonpatch.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-enum \
6"
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
index 429c6bfb5..436a664a8 100644
--- a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
@@ -25,7 +25,6 @@ RDEPENDS_${PN} += " \
25 ${PYTHON_PN}-argparse \ 25 ${PYTHON_PN}-argparse \
26 ${PYTHON_PN}-compression \ 26 ${PYTHON_PN}-compression \
27 ${PYTHON_PN}-doctest \ 27 ${PYTHON_PN}-doctest \
28 ${PYTHON_PN}-enum \
29 ${PYTHON_PN}-logging \ 28 ${PYTHON_PN}-logging \
30 ${PYTHON_PN}-xml \ 29 ${PYTHON_PN}-xml \
31" 30"
diff --git a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
index a64abcc83..be55770dd 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
@@ -2,6 +2,5 @@ require python-netaddr.inc
2inherit setuptools3 2inherit setuptools3
3 3
4RDEPENDS_${PN} += " \ 4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-enum \
6 ${PYTHON_PN}-selectors \ 5 ${PYTHON_PN}-selectors \
7" 6"
diff --git a/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb b/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
index 080372c4f..997b0cad7 100644
--- a/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
@@ -11,4 +11,4 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
11 11
12inherit setuptools3 python3native pypi 12inherit setuptools3 python3native pypi
13 13
14RDEPENDS_${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-selectors ${PYTHON_PN}-enum" 14RDEPENDS_${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-ply_3.10.bb b/meta-python/recipes-devtools/python/python3-ply_3.10.bb
index de8881d51..72410baeb 100644
--- a/meta-python/recipes-devtools/python/python3-ply_3.10.bb
+++ b/meta-python/recipes-devtools/python/python3-ply_3.10.bb
@@ -1,6 +1,2 @@
1require python-ply.inc 1require python-ply.inc
2inherit setuptools3 2inherit setuptools3
3
4RDEPENDS_${PN}_class-target += "\
5 ${PYTHON_PN}-enum \
6"
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
index d8f6389cc..1067d156a 100644
--- a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
@@ -3,7 +3,6 @@ require python-prompt-toolkit.inc
3 3
4RDEPENDS_${PN} += " \ 4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-datetime \ 5 ${PYTHON_PN}-datetime \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-shell \ 6 ${PYTHON_PN}-shell \
8 ${PYTHON_PN}-textutils \ 7 ${PYTHON_PN}-textutils \
9" 8"
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
index 9f02cab13..55b0314a0 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
@@ -3,7 +3,6 @@ require python-pymongo.inc
3 3
4# Requires _pydecimal which is in misc 4# Requires _pydecimal which is in misc
5RDEPENDS_${PYTHON_PN}-bson += " \ 5RDEPENDS_${PYTHON_PN}-bson += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
8 ${PYTHON_PN}-selectors \ 7 ${PYTHON_PN}-selectors \
9 ${PYTHON_PN}-subprocess \ 8 ${PYTHON_PN}-subprocess \
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
index 44c13685e..6807b9510 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
@@ -6,4 +6,4 @@ do_install_append() {
6 rmdir ${D}${bindir} 6 rmdir ${D}${bindir}
7} 7}
8 8
9RDEPENDS_${PN} += "${PYTHON_PN}-enum ${PYTHON_PN}-selectors" 9RDEPENDS_${PN} += "${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
index f8aa01be8..e5f00e871 100644
--- a/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
+++ b/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
@@ -2,7 +2,6 @@ inherit pypi setuptools3
2require python-pysocks.inc 2require python-pysocks.inc
3 3
4RDEPENDS_${PN}_class-target += "\ 4RDEPENDS_${PN}_class-target += "\
5 ${PYTHON_PN}-enum \
6 ${PYTHON_PN}-netclient \ 5 ${PYTHON_PN}-netclient \
7 ${PYTHON_PN}-selectors \ 6 ${PYTHON_PN}-selectors \
8" 7"
diff --git a/meta-python/recipes-devtools/python/python3-serpent_1.23.bb b/meta-python/recipes-devtools/python/python3-serpent_1.23.bb
index 199dcfafd..bc8bfff86 100644
--- a/meta-python/recipes-devtools/python/python3-serpent_1.23.bb
+++ b/meta-python/recipes-devtools/python/python3-serpent_1.23.bb
@@ -3,6 +3,5 @@ require python-serpent.inc
3 3
4# Requires _pydecimal which is in misc 4# Requires _pydecimal which is in misc
5RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
8" 7"
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb
index 01f1e97ec..eaa009096 100644
--- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb
+++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.1.15.bb
@@ -2,4 +2,4 @@ inherit setuptools3
2require python-sqlalchemy.inc 2require python-sqlalchemy.inc
3 3
4# Requires _pydecimal.py which is in misc 4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += "${PYTHON_PN}-enum ${PYTHON_PN}-misc" 5RDEPENDS_${PN} += "${PYTHON_PN}-misc"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index 4a4e679fb..b8dc1741b 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -3,7 +3,6 @@ require python-whoosh.inc
3 3
4# Requires _pydecimal.py which is in misc 4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += " \ 5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \ 6 ${PYTHON_PN}-misc \
8 ${PYTHON_PN}-selectors \ 7 ${PYTHON_PN}-selectors \
9" 8"