summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2018-08-02 20:27:03 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-03 09:34:29 -0700
commit4dc3c05e72fb97800f3902b8a634f1df5a27193f (patch)
tree2b943a18d258d887e847fbac31f70f0d37b6f64a /meta-python
parent4f39906e1c40cff080dae42abed8631b155e42c7 (diff)
downloadmeta-openembedded-4dc3c05e72fb97800f3902b8a634f1df5a27193f.tar.gz
python-parse-type: Add Python 3 recipe
Clarify license from BSD to BSD-3-Clause. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-parse-type.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-parse-type_0.4.2.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb2
3 files changed, 16 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-parse-type.inc b/meta-python/recipes-devtools/python/python-parse-type.inc
new file mode 100644
index 000000000..4549ec98b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-parse-type.inc
@@ -0,0 +1,12 @@
1SUMMARY = "Simplifies building parse types based on the parse module"
2HOMEPAGE = "https://github.com/jenisys/parse_type"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d07323820cca0f1d192cbbf8a0516f95"
5
6SRC_URI[md5sum] = "b5fa59e45965d1b2896023742df2e707"
7SRC_URI[sha256sum] = "f596bdc75d3dd93036fbfe3d04127da9f6df0c26c36e01e76da85adef4336b3c"
8
9PYPI_PACKAGE = "parse_type"
10inherit pypi
11
12RDEPENDS_${PN} += "${PYTHON_PN}-parse"
diff --git a/meta-python/recipes-devtools/python/python-parse-type_0.4.2.bb b/meta-python/recipes-devtools/python/python-parse-type_0.4.2.bb
index b516c5912..8e10e801c 100644
--- a/meta-python/recipes-devtools/python/python-parse-type_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/python-parse-type_0.4.2.bb
@@ -1,11 +1,2 @@
1SUMMARY = "Simplifies building parse types based on the parse module" 1inherit setuptools
2LICENSE = "BSD" 2require python-parse-type.inc
3LIC_FILES_CHKSUM = "file://LICENSE;md5=d07323820cca0f1d192cbbf8a0516f95"
4PYPI_PACKAGE = "parse_type"
5
6SRC_URI[md5sum] = "b5fa59e45965d1b2896023742df2e707"
7SRC_URI[sha256sum] = "f596bdc75d3dd93036fbfe3d04127da9f6df0c26c36e01e76da85adef4336b3c"
8
9RDEPENDS_${PN} += "python-parse"
10
11inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb b/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb
new file mode 100644
index 000000000..91d9ce2d4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-parse-type.inc